WordPress.org

Ready to get started?Download WordPress

Forums

blank pages after post and after comment (7 posts)

  1. idiotprogrammer
    Member
    Posted 6 years ago #

    Wow, I tried installing this wp-super cache plugin on my site http://www.teleread.org/blog/ with high hopes. I'm using 2.2.2

    It seemed to be a bit faster. but it created blank pages whenever users made comments or posts.

    For making posts, we could live with blank pages, but not comments.

    When I tried removing/deactivating it, it deactivated, but now the wp site is even slower than before I installed it.

    I have no idea why this is happening. This is quite painful.

    Suggestion: provide instructions about a safe way to bring the site to a state before wp-super cache was installed.

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Did you see anything in your PHP error log?

  3. idiotprogrammer
    Member
    Posted 6 years ago #

    actually, we had hosting problems at the same time, so it might be related to that. I am not a php coder, so I can't be of much help in deciphering logs or rewrite errors. But I will try to upgrade to the latest wp, then reinstall supercache, and then let you know.

  4. idiotprogrammer
    Member
    Posted 6 years ago #

    update: the webhost says:

    It seems one of your WordPress websites is hammering MySQL with the following SQL queries and it's caused the load on Web 5 to spike.

    SELECT DISTINCT YEAR(post_date) AS year, MONTH(p...
    SELECT DISTINCT YEAR(post_date) AS year, MONTH(p...
    SELECT SQL_CALC_FOUND_ROWS wp_posts.*, wp_sticky....

    ************
    I'm guessing it's related to the Collapsible Archives plugin. (Actually I think plugin compatibility is the underlying problem).

    supercache is already disabled, when I disable collapsible archives, performance improves, although curiously, whenever you post or comment, you get a blank screen after successful completion. More info as I find it.

  5. Donncha O Caoimh
    Member
    Posted 6 years ago #

    So, you were still seeing blank pages even when super cache was disabled?

  6. idiotprogrammer
    Member
    Posted 6 years ago #

    I'm happy to report that the problem is not with the cache plugin.

    I incorrectly edited the wp-config.php file and upgraded wp. Then everything worked perfectly! I even got the Collapsible Archives plugin to work after the upgrade.

    Well, almost perfectly. I couldn't figure out why in the supercache menu you need to set gzip to yes, but in another generic wordpress menu you have to set it (and it always seems to be set on "Off"

  7. Jason Pelker
    Member
    Posted 6 years ago #

    What were there errors in the wp-config.php file?

Topic Closed

This topic has been closed to new replies.

About this Topic