WordPress.org

Ready to get started?Download WordPress

Forums

FeedWordPress
Blank pages (10 posts)

  1. rudyz
    Member
    Posted 1 year ago #

    I installed this in an earlier version of WP. I deactivated and deleted as I didn't have time to get the configuration exactly as I wanted and I was seeing unexpected posts as a result.

    I then upgraded WP to 3.5 and downloaded and installed the latest version of FeedWordPress. As part of the install, the original data from the previous install was detected and upgraded.

    Once activated my blog should blank space where any post should be. When deactivated my posts appeared as normal.

    http://wordpress.org/extend/plugins/feedwordpress/

  2. shabicht
    Member
    Posted 1 year ago #

    I have the same issue. I tried upgrading to 2010.1212 and to 2012.1218 and both resulted in empty pages that relied on /category/. For now I'm staying on 2011.1019 until I have time to figure this one out.

    I really can't take the site offline too long to troubleshoot but would be willing to try a few things if anyone has some suggestions.

  3. talgalili
    Member
    Posted 1 year ago #

    Did you try to repair your database?

  4. shabicht
    Member
    Posted 1 year ago #

    No I didn't try to repair it. I'll see if I can try that this weekend.

  5. shabicht
    Member
    Posted 1 year ago #

    Tried the repair/optimize, and it didn't fix the issue:

    The wp_users table is okay.
    The wp_users table is already optimized.

    The wp_usermeta table is okay.
    The wp_usermeta table is already optimized.

    The wp_posts table is okay.
    The wp_posts table is already optimized.

    The wp_comments table is okay.
    The wp_comments table is already optimized.

    The wp_links table is okay.
    The wp_links table is already optimized.

    The wp_options table is okay.
    The wp_options table is already optimized.

    The wp_postmeta table is okay.
    The wp_postmeta table is already optimized.

    The wp_terms table is okay.
    The wp_terms table is already optimized.

    The wp_term_taxonomy table is okay.
    The wp_term_taxonomy table is already optimized.

    The wp_term_relationships table is okay.
    The wp_term_relationships table is already optimized.

    The wp_commentmeta table is okay.
    The wp_commentmeta table is already optimized.

    Repairs complete.

  6. shabicht
    Member
    Posted 1 year ago #

    I've done some testing. Whenever I turn on the 2012.1218 version I get the following errors in the apache error_log when trying to access anything like http://example.com/category/foobar.

    [Thu Jan 03 09:50:33 2013] [error] [client x.x.x.x] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 for query SELECT SQL_CALC_FOUND_ROWS wp_posts.ID FROM wp_posts INNER JOIN wp_term_relationships ON (wp_posts.ID = wp_term_relationships.object_id) WHERE 1=1 AND ( wp_term_relationships.term_taxonomy_id = 6251 made by require('wp-blog-header.php'), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts

    [Thu Jan 03 09:50:52 2013] [error] [client x.x.x.x] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 for query SELECT SQL_CALC_FOUND_ROWS wp_posts.ID FROM wp_posts INNER JOIN wp_term_relationships ON (wp_posts.ID = wp_term_relationships.object_id) WHERE 1=1 AND ( wp_term_relationships.term_taxonomy_id = 23479 made by require('wp-blog-header.php'), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts

    [Thu Jan 03 09:51:35 2013] [error] [client x.x.x.x] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 for query SELECT SQL_CALC_FOUND_ROWS wp_posts.ID FROM wp_posts INNER JOIN wp_term_relationships ON (wp_posts.ID = wp_term_relationships.object_id) WHERE 1=1 AND ( wp_term_relationships.term_taxonomy_id = 23479 made by require('wp-blog-header.php'), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts

    [Thu Jan 03 09:51:41 2013] [error] [client x.x.x.x] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 for query SELECT SQL_CALC_FOUND_ROWS wp_posts.ID FROM wp_posts INNER JOIN wp_term_relationships ON (wp_posts.ID = wp_term_relationships.object_id) WHERE 1=1 AND ( wp_term_relationships.term_taxonomy_id = 6636 made by require('wp-blog-header.php'), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts

    I'll need to look more, but thought I'd share that information.

  7. shabicht
    Member
    Posted 1 year ago #

    To eliminate this as a theme issue I tried both "Twenty Ten" and "Twenty Twelve", both which still gave the error:

    "Nothing Found
    Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post."

    For the record:
    PHP 5.4.10 (cli) (built: Dec 19 2012 11:45:14)
    Copyright (c) 1997-2012 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

    mysqladmin Ver 8.42 Distrib 5.5.28, for Linux on x86_64
    Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.

    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.

    Server version 5.5.28
    Protocol version 10
    Connection Localhost via UNIX socket
    UNIX socket /var/lib/mysql/mysql.sock
    Uptime: 12 days 1 hour 55 min 41 sec

    Threads: 7 Questions: 41300184 Slow queries: 690 Opens: 309 Flush tables: 1 Open tables: 234 Queries per second avg: 39.569

    Server version: Apache/2.2.15 (Unix)
    Server built: Feb 13 2012 22:31:42

  8. shabicht
    Member
    Posted 1 year ago #

    Rolled back to:
    PHP 5.3.3 (cli) (built: Jul 3 2012 16:53:21)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

    Same issue.

  9. shabicht
    Member
    Posted 1 year ago #

    Rolled back mysql to CentOS repo. Same issue.

    mysqladmin Ver 8.42 Distrib 5.1.66, for redhat-linux-gnu on x86_64
    Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.

    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.

    Server version 5.1.66
    Protocol version 10
    Connection Localhost via UNIX socket
    UNIX socket /var/lib/mysql/mysql.sock
    Uptime: 22 min 8 sec

    Threads: 2 Questions: 86440 Slow queries: 3 Opens: 87 Flush tables: 1 Open tables: 64 Queries per second avg: 65.90

  10. shabicht
    Member
    Posted 1 year ago #

    Mark this post as [resolved]. Turning off "Optimize IN clauses" fixed the issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.