WordPress.org

Ready to get started?Download WordPress

Forums

Debug Objects
[resolved] blank page with 3.8 (11 posts)

  1. guix69
    Member
    Posted 7 months ago #

    Hello, I select "display in footer" option and reload my homepage and get a blank page (sams thing with the URL param ?debugobjects=true)
    any idea?

    Thank you
    G.

    http://wordpress.org/plugins/debug-objects/

  2. guix69
    Member
    Posted 7 months ago #

    actually it's the query debug which causes the blank page...

    PHP version: 5.5.5-1~dotdeb.1
    Server: Apache/2.2.22

  3. guix69
    Member
    Posted 7 months ago #

    Had to increase the php memory_limit A LOT.
    Don't know is this is site related or plugin related.

    Hope this helps :)

    G.

  4. Frank
    Member
    Plugin Author

    Posted 7 months ago #

    If you have set the constant WP_DEBUG to true in the wp-config.php? Maybe this helps to find a bug. See also in the settings of the plugin, that you have deactivate the option "All Hooks", there use a lot of RAM.

  5. guix69
    Member
    Posted 7 months ago #

    Thank you for the reply.
    I found the problem thanks to the apache log on the server. Even only with the query log activated in your plugin it was using a looooot of RAM. Maybe the website is even more poorly coded than I thought ;)

    G.

  6. guix69
    Member
    Posted 7 months ago #

    By the way, great plugin ! Really helpfull.

  7. landwire
    Member
    Posted 6 months ago #

    Running into the same problem.
    Do I have to do increase memory_limit in my php settings on host and in the wp-config file? Or is it enough on just one of those locations?

    And to how much did you increase it in the end?
    Thanks,
    Sascha

  8. guix69
    Member
    Posted 6 months ago #

    Modify only php.ini, that is the only place where this setting takes place.

  9. landwire
    Member
    Posted 6 months ago #

    Thanks!
    I don't think I have direct access to php.ini, but I can set the memory_limit in my php settings on host, so I assume they will write that value to php.ini.

    I just increased it to 512M. The plugin then worked and showed me used memory of 354M! Is that normal or incredibly high?

  10. guix69
    Member
    Posted 6 months ago #

    It doesn't write to php.ini but it must override its values ;) Anyway I'm glad it worked out.
    354M...well, with WordPress nothing surprises me anymore. While you're at it you might want to find out which plugin is using the most memory by disabling / enabling them one by one and looking at the memory usage.

  11. landwire
    Member
    Posted 6 months ago #

    Just FYI:
    I get a much lower (peak!) memory usage with the following plugin:

    http://wordpress.org/plugins/query-monitor/

    But I do not know if they monitor the same thing. As said the one above says peak memory usage. Maybe Debug Objects measures total memory usage or something like that.
    If they do measure the same, then it might be an issue with the Debug Objects plugin. Not sure. Just thought I let you know.

Reply

You must log in to post.

About this Plugin

About this Topic