WordPress.org

Ready to get started?Download WordPress

Forums

Blank page when updating to 2.0 (49 posts)

  1. crjensen
    Member
    Posted 8 years ago #

    Greetings from Denmark - and happy New Year!

    I used version 1.5
    I have, of course, made a backup of my database
    I followed the guidelines and installed the new version 2.0
    When I go to /my-admin/upgrade.php I get a blank page. Nothing happens.
    It's the same with the front page of my website (www.riisjensen.dk). It's blank!

    What is happening?

    /Carsten.

  2. MichaelH
    Member
    Posted 8 years ago #

    Maybe you should try deleting the WordPress files and then upload the 2.0 files again.

    Then do the upgrade.php.

    Good Luck.

  3. crjensen
    Member
    Posted 8 years ago #

    Thank,
    But that didn't help. I tried to delete and re-upload. I even tried to delete cookies etc. in my browser. But still all I get is a blank page, when accessing /wp-admin/upgrade.php and the main page.
    Is my website lost?

  4. kennbiv
    Member
    Posted 8 years ago #

    I had the same problem and found the issue was that I didn't have a theme selected. Also, deactivate all of your plugins.

  5. crjensen
    Member
    Posted 8 years ago #

    OK, for now I've decided to roll back to version 1.5.
    The only problem now, after re-installing 1.5 is that when I click on Admin, i.e. go to riisjensen.dk/wp-admin, I get the following:

    Warning: Cannot add header information - headers already sent by (output started at /usr42/home/riisjens/public_html/wp-config.php:96) in /usr42/home/riisjens/public_html/wp-includes/functions.php on line 1644

    Warning: Cannot add header information - headers already sent by (output started at /usr42/home/riisjens/public_html/wp-config.php:96) in /usr42/home/riisjens/public_html/wp-includes/functions.php on line 1645

    Warning: Cannot add header information - headers already sent by (output started at /usr42/home/riisjens/public_html/wp-config.php:96) in /usr42/home/riisjens/public_html/wp-includes/functions.php on line 1646

    Warning: Cannot add header information - headers already sent by (output started at /usr42/home/riisjens/public_html/wp-config.php:96) in /usr42/home/riisjens/public_html/wp-includes/functions.php on line 1647

    Warning: Cannot add header information - headers already sent by (output started at /usr42/home/riisjens/public_html/wp-config.php:96) in /usr42/home/riisjens/public_html/wp-includes/functions.php on line 1649

    ... these lines, i functions.php, look like this:

    header('Expires: Mon, 11 Jan 1984 05:00:00 GMT');
    header('Last-Modified: ' . gmdate('D, d M Y H:i:s') . ' GMT');
    header('Cache-Control: no-cache, must-revalidate, max-age=0');
    header('Pragma: no-cache');

    header('Location: ' . get_settings('siteurl') . '/wp-login.php?redirect_to=' . urlencode($_SERVER['REQUEST_URI']));

  6. Mark (podz)
    Support Maven
    Posted 8 years ago #

    The error start in wp-config.php and snowballs from there it seems.

    Open that up and check there is nothing at all after the last >
    Nothing - not even a carriage return or a space.

  7. BillyG
    Member
    Posted 8 years ago #

    same exact problem

  8. crjensen
    Member
    Posted 8 years ago #

    Problem fixed. Thanks, podz.
    There were carriage returns in wp-config.php

  9. TheQRM
    Member
    Posted 8 years ago #

    Interesting. Having same problem, but when I went to the end of my wp-config.php there were nothing after the last >. Still see nothing apart from blank page. Hmmmm...

  10. residualforces
    Member
    Posted 8 years ago #

    I'm having the same problem. Blank white page. I've tried starting over. I tried re uploading 2. I tried re uploading 1.5.2. config has no extra spaces. I deleted all my plugins except the new ones.

    I can't get anything to show up. Even when I try the upgrade, I get a blank page. It doesn't acknowledge that it worked like I remember it did last time.

    The only thing is selecting a theme. How do I do that if I can't even login in?

  11. vkaryl
    Member
    Posted 8 years ago #

    Use something like this in your browser addy bar:

    http://yoursitename.com/yourblogfoldername/wp-admin/themes.php

    You might wind up at the login page, or you might wind up at the Presentation screen.

  12. residualforces
    Member
    Posted 8 years ago #

    I switched to the new version on config, and I am now ok. Well the upgrade is now running.

  13. residualforces
    Member
    Posted 8 years ago #

    That was it.

  14. TheQRM
    Member
    Posted 8 years ago #

    Not sure what you meant by "new version on config"??

  15. residualforces
    Member
    Posted 8 years ago #

    The one from 2.0 (of not on, sorry)

    I changed the settings, and that seemed to take care of it for me.

  16. TheQRM
    Member
    Posted 8 years ago #

    Sorry to be dense, but this is my first time. Which settings? The one's in:

    http://trac.wordpress.org/changeset/3382

    http://trac.wordpress.org/ticket/2153

  17. mindbash
    Member
    Posted 8 years ago #

    I got the same problem and can't get it to work.

    I did the upgrade all over. Deleted and uploaded.

    Applied the changeset above, 3382.

    Cleared the cache folder.

    I still only get blank pages. I don't even get anything from the upgrade.php script. All blank.

  18. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    This new version of wp-settings.php might help. Copy it over your current wp-settings.php.

  19. residualforces
    Member
    Posted 8 years ago #

    These settings in config.php (in <b>) Change them to match your server/database settings.

    (
    ... // ** MySQL settings ** //
    define('DB_NAME', '<b>wordpress</b>'); // The name of the database
    define('DB_USER', '<b>username</b>'); // Your MySQL username
    define('DB_PASSWORD', '<b>password</b>'); // ...and password
    define('DB_HOST', '<b>localhost</b>');

  20. seahills
    Member
    Posted 8 years ago #

    I had the same problem with blank .php pages after upgrading to WP2. vkaryl's suggestion worked for me. When I went to the themes.php page I got a notice that my active theme was broken, it loaded the default WP theme and I can see all the pages again.

  21. mindbash
    Member
    Posted 8 years ago #

    Tried the new 'wp-settings.php' suggested by ryan. Now i got content on the 'upgrade.php' page. But after clicking the upgrade link - going to '...?step=1' i get a blank page again.

    And the rest of them still remains blank. I can't get to the themes.php to try that solution - since it is also blank.

  22. mindbash
    Member
    Posted 8 years ago #

    Anyone have any suggestions for how to solve this?

    I did expect some issues upgrading. That's normal. But i wasn't prepared for total shutdown of my site. I really need to get this solved. Anyone?

  23. TheQRM
    Member
    Posted 8 years ago #

    Turns out that you must have a default directory under:

    wp-content/themes

    Here's how my dir looks now:

    drwxr-xr-x 4 user ftpusers 4096 Jan 1 19:12 .
    drwxr-xr-x 4 user ftpusers 4096 Jan 1 16:33 ..
    drwxr-xr-x 2 user ftpusers 4096 Jan 1 16:44 blix
    drwxr-xr-x 2 user ftpusers 4096 Jan 1 19:12 default

    Once I added the default theme directory and the files from that theme into this dir everything was normal again and I could switch themes with no problem.

  24. mindbash
    Member
    Posted 8 years ago #

    I still have my default theme folder in place :/

  25. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    Curious. Does disabling the cache make a difference? Look for the following in wp-settings.php.

    // For now, disable persistent caching by default. To enable, comment out
    // the following line.
    //define('DISABLE_CACHE', true);

    Change that last line to:

    define('DISABLE_CACHE', true);

    Any difference?

  26. mindbash
    Member
    Posted 8 years ago #

    ryan - that did it.

    So - why did it fuck things up? Do i need the cache? Can i work around this and get the cache back?

    Strange...

    Thanks a lot for the fix anyway!

  27. mindbash
    Member
    Posted 8 years ago #

    Btw - should i leave the fixes from 3382 changeset in place?

    Also - looking over the the upgraded WP for just a couple of minutes i am glad i got it to work. It just gets better :) Thanks!

  28. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    I have no idea why that happens with the cache. I'm investigating. You don't need the cache, so turn it off and forget about it.

  29. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    You can leave 3382 in. It's in the WP repository and will be part of the next release.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags