WordPress.org

Ready to get started?Download WordPress

Forums

Blank Page Syndrome and 403 error (17 posts)

  1. sharebear
    Member
    Posted 3 years ago #

    Hello helpful friends and WordPress-users.

    I have downloaded WordPress. And Filezilla. And changed all of the necessary items for wp-config.php. I also changed my name servers on my host (mydomain.com). For a hot-minute, I think I installed wordpress using the installing script (http://www.andanzas.com/wp-admin/install.php), BUT, then the page turned white. It said I installed it, but I can't see anything.

    Now, if I try to go to the website (andanzas.com), it says, "Error occurred: 403 - forbidden". This website worked temporarily after installing the site, and looking like a normal, basic, WordPress site, though I wasn't sure how to edit it. Now I just see an error message.

    I tried re-downloading WordPress, re-doing all the steps, including re-FTP'ing.

    Any ideas?

    (Thank you -- in advance!)

  2. govpatel
    Member
    Posted 3 years ago #

    Looks like you have permission problem on server check if you have right permissions normally folders are 755 and files are 644

  3. mikeymizrahi89
    Member
    Posted 3 years ago #

    HI,

    I am having a similar issue. When I try to access ...wp-admin/install.php i either arrive at error 404 page not found, or a blank white page. I am not sure what you mean by 755 and 644

    Thanks.

  4. govpatel
    Member
    Posted 3 years ago #

    what you mean by 755 and 644

    This are typical permissions given to files and folders in a linux server so that they open.

    Using ftp filezilla log in on server and you will permissions on last column

    To change them highlight the folder and right click and click on file permissions.

  5. mikeymizrahi89
    Member
    Posted 3 years ago #

    Thanks for the fast reply... the actual file install.php is set to 644 now... do i need to change this to 755?

  6. govpatel
    Member
    Posted 3 years ago #

    No all files should be 644 and folders 755
    what is public_html set at it should be 750

  7. mikeymizrahi89
    Member
    Posted 3 years ago #

    Hi, then my file permissions are correct. Yet I still can't access /wp-admin/install.php or /wp-config.php

    Any clue why? Can you assist me in this?

  8. govpatel
    Member
    Posted 3 years ago #

    If you use skype send me invitation at
    id govindjip

  9. sharebear
    Member
    Posted 3 years ago #

    Hello -- thank you for your thoughts.

    The permissions I see don't have any numbers -- they say, "-rw-r--r--" for files and "drwxr-xr-x" for folders. I'm not sure where the numbers you mentioned fit into this. When I FTP-transferred files over originally, 15 files failed and the reason listed was "incorrect password." I went back and manually dropped those 15 into the correct locations and they seemed to transfer fine. Could this be a part of the reason, do you think?

  10. govpatel
    Member
    Posted 3 years ago #

    could be try and delete all files and folders and re upload them
    your files are fine

    Folders should have this permissions
    owner: read, write and execute permissions,
    group: read and execute permissions,
    others: read and execute permissions.

  11. sharebear
    Member
    Posted 3 years ago #

    I already re-uploaded them twice. Once there were 15 failed ones, once 8, and once 16 -- and I think they're often the same files that fail. I'm not sure how to check on the folder permissions, but underneath owner/group, it's listed f255770 pemcln.

  12. arkgroup
    Member
    Posted 3 years ago #

    sharebear,

    It should not be owner/group issue, however this could be mod_security issue on the server side.
    -rw-r--r-- means 644 and it's ok for files.
    drwxr-xr-x means 755 and it's ok for folders.

    You may try to change all permissions with Filezilla recursively first. Set 644 for files and 755 for folders. You need to choose all your files and folders in main folder of your site, click with the right mouse button and click "File Attributes..."? set 644 for files (755 for folders), click on checkbox at the bottom and choose only files (only folders) option.

  13. arkgroup
    Member
    Posted 3 years ago #

    sharebear,

    If your Conrol Panel is Plesk, try also a function Fix Permissions. It's somewhere in control panel, I just don't remember where exactly. It should eliminate all issues with permissions and ownership using Plesk methods.

  14. mikeymizrahi89
    Member
    Posted 3 years ago #

    hi,

    i am receiving this error message when trying to upload a picture..."The uploaded file could not be moved to /home/a7384958/public_html/wp-content/uploads/2011/03." do you have any idea why?

  15. arkgroup
    Member
    Posted 3 years ago #

    mikeymizrahi89,

    Uploads folder should have 777 permissions if you have php-cli. Try to set 777 permission for /home/a7384958/public_html/wp-content/uploads/ folder. It should help.

  16. sharebear
    Member
    Posted 3 years ago #

    First of all, thank you so much, all, for responding!

    All of my folders are already set at 755 and all of my files are already set at 644. The folder permissions were set at what GovPatel suggested.

    I tried to change the folder attributes by checking "recurse into subdirectories," however, while filezilla acts like it's making changes, when I check back later, that box isn't checked anymore! And, when I tested the website, the same blank page/forbidden error persisted.

    Also, I think mydomain.com offers plesk, but it seems like it costs money, and I signed up for the cheapest package, so I don't think I have it activated. Do you mean in the control panel of mydomain.com? I'm not sure where to find that, and their support tab does not offer any help.

    I don't understand why I was able to access the website for a few (hopeful) moments when I first installed it, either. What could have changed?

  17. arkgroup
    Member
    Posted 3 years ago #

    sharebear,

    I've checked support videos at mydomain.com, and according to it, they have some hosting control panel. May be there's a link to logs anywhere. Access (httpd) logs may be have some more information than just 403 error.

    Also check permissions for website root folder, it usually called like public_html, httpdocs, www or by your domain name. Try to set also 755 for it.

Topic Closed

This topic has been closed to new replies.

About this Topic