WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blank page some times?!? (8 posts)

  1. qzha017
    Member
    Posted 1 year ago #

    Hi everyone

    I am getting blank white screen for my website (admin and frontend) only sometimes, I have looked in google for solutions but it is hard to pin down what is the exact cause as it only shows blank page sometimes...if I would to wait a few minute it would show up as normal again.

    Could this actually be a problem on my server side?
    from what I can see the server is using:
    PHP Version : 5.3.3-7+squeeze14+webhost / 64Bit OS

    I read from website I should add php_flag display_errors on in my .htaccess file to force an error report, but where in that file to I add it? and how would it work?

    Thanks everyone!

  2. linux4me2
    Member
    Posted 1 year ago #

    Those blank white pages usually mean you're getting some kind of PHP error on your server, and PHP is configured to log rather than display errors. While setting display_errors to "true" is okay in a development environment, it's usually not a good idea in a production environment because it can be a security leak. You don't want to give away any more information regarding your PHP functioning than you have to. : )

    The best thing to do rather than turning on display_errors is to look at your error log when you get a blank white page. Most control panels like cPanel and Plesk give you access to your error logs for just this purpose. You should contact your web host to see how to access yours.

    Luckily, PHP error messages are pretty good. They usually tell you the file name, type of error, and even the line number of the script that generated the error. Once you have that, troubleshooting them is much easier.

  3. qzha017
    Member
    Posted 1 year ago #

    Hi thanks linux4me2
    I have written an e-mail to my server, hope they can help me sort out this problem.

    But the thing is I have a localhost install that is very much similar to the one that I have on the server, I mean all the plugins are the same, and I never have experienced any white screen on my localhost version.

    The only difference I can think of is that my localhost install I changed the variable from 1000 to
    `max_input_vars = 3000
    suhosin.request.max_vars = 3000
    suhosin.post.max_vars = 3000`

    in my php.ini because I had too much categories and it can't handle with the default 1000 variable.

    Could this be of any clue as to the white screen problem?

  4. qzha017
    Member
    Posted 1 year ago #

    Alright things are going fast for me I followed some trouble shooting steps and obtained the error for my white blank page as follows:

    Fatal error: Internal Zend error - Missing class information for in /server/mywebsite/wp-content/plugins/wp-super-cache/wp-cache-base.php on line 5

    I am not getting this error in localhost

    I guess I can solve this by clear all my cache and then deactivate the wp-super-cache?

    anyone?

  5. linux4me2
    Member
    Posted 1 year ago #

    I'd hate to see you have to remove WP Super Cache. It's a great caching plug-in. I'd try fixing the issue first. It looks like it's a conflict between APC and WP Super Cache. If you Google "wp super cache zend error" you'll see a number of links to people with similar issues and some various fixes. I tried wading through them and didn't find a solution that I liked.

    One thing I would try is to set WP Super Cache to cache via mod_rewrite instead of PHP (the default) to see if that bypasses the issue. It seems like using mod_rewrite wouldn't be using Zend, but I'm not certain of that.

    I suspect you aren't hosting with Hostgator, but they do have a suggested setup for mod_rewrite configuration of WP Super Cache on their servers, and the settings look pretty generic. It would walk you through the steps you need to take to set it up and tell you what you're doing. If you keep track of the changes you make, you should be able to set WP Super Cache back the way you have it now if it doesn't work and take it from there.

  6. qzha017
    Member
    Posted 1 year ago #

    Thank you linux4me2

    I have reported the problem to my server and waiting for their reply, I dont want to do any changes just yet because the white page problem is not consistent, yesterday I was working on my site all day and didn't experience anything so I suspect its my server side of things

  7. linux4me2
    Member
    Posted 1 year ago #

    Cool. Let us know what you figure out. It may help someone else.

  8. qzha017
    Member
    Posted 1 year ago #

    My server wont do anything about it and I have had no response from WP Super Cache plugin help.
    So I have just removed the WP Super Cache (I am not saying it is a bad plugin because my localhost works fine without any faults.) But still I might use W3 total cache instead, although I do not know what other problems that may bring but I have heard alot of good reviews and recommendations about it.

    So for now nothing has really being done I am just gona use another plugin instead for anyone else having the same issue.

Topic Closed

This topic has been closed to new replies.

About this Topic