WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type UI
[resolved] Blank page instead of post (10 posts)

  1. evoweb
    Member
    Posted 10 months ago #

    Hi, i am using a your plugin with theme called Geotheme.

    I install your plugin, and create a post type and some taxonomies, but when i save a post, and go infront to see it, i only get a blank page.

    I can't figure whats wrong.. Any suggestions?

    http://wordpress.org/plugins/custom-post-type-ui/

  2. Michael Beckwith
    Member
    Plugin Author

    Posted 10 months ago #

    Could you follow the instructions here to enable WP_DEBUG and then refresh the page? Let me know if any errors show up and what they are.

    http://codex.wordpress.org/Editing_wp-config.php#Debug

  3. evoweb
    Member
    Posted 10 months ago #

    Thank you for your very quick response!
    I got two messages:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead

    Notice: attribute_escape is deprecated since version 2.8! Use esc_attr() instead

  4. Michael Beckwith
    Member
    Plugin Author

    Posted 10 months ago #

    Hrm, nothing that relates to CPT UI. Does your site load properly when it's disabled? Are you able to log into the admin still?

  5. evoweb
    Member
    Posted 10 months ago #

    Yes, everything is fine..

    And the installation is fine.. the only problem, is when i try to see the custom posts infront, where i get a blank page. All other pages, and posts work normally.

    Only my posts http://www.example.com/custom/%example fails and gives me blank screen..

  6. Michael Beckwith
    Member
    Plugin Author

    Posted 10 months ago #

    If you know what template file it's using, could you pastebin that file at pastebin.com?

    Also if I could get what settings you used for your CPT, that'd be awesome as well.

  7. evoweb
    Member
    Posted 10 months ago #

    the code is

    add_action('init', 'cptui_register_my_cpt');
    function cptui_register_my_cpt() {
    register_post_type('astheneies', array(
    'label' => '__('Ασθένειες')',
    'description' => '',
    'public' => 'true',
    'show_ui' => 'true',
    'show_in_menu' => 'true',
    'capability_type' => 'post',
    'hierarchical' => 'false',
    'rewrite' => array('slug' => 'astheneies', 'with_front' => '1'),
    'query_var' => 'true',
    'has_archive\' => 'true',
    'exclude_from_search' => 'false',
    'supports' => array(''title','editor','excerpt','trackbacks','custom-fields','comments','revisions','thumbnail','author','page-attributes','post-formats','),
    'labels' => 'array (
    'name' => 'Ασθένειες',
    'singular_name' => 'Ασθένεια',
    'menu_name' => 'Ασθένειες',
    'add_new' => 'Προσθήκη νέας',
    'add_new_item' => 'Προσθήκη νέας ασθένειας',
    'edit' => 'Επεξεργασία',
    'edit_item' => 'Επεξεργασία ασθένειας',
    'new_item' => 'Νέα ασθένεια',
    'view' => 'Προβολή',
    'view_item' => 'Προβολή ασθένειας',
    'search_items' => 'Αναζήτηση ασθένειας',
    'not_found' => 'Δεν βρέθηκαν ασθένειες',
    'not_found_in_trash' => 'Δεν βρέθηκαν ασθένειες στα απορρίμματα',
    'parent' => 'Γονική ασθένεια',
    )'
    ) ); }

  8. evoweb
    Member
    Posted 10 months ago #

    how can i find which theme file is using?

    I havent edited any other file, except from functions.php, where i inserted the code above.. :(

  9. Ov3rfly
    Member
    Posted 10 months ago #

    The generated code of your plugin version has errors, e.g.
    'supports' => array(''title','editor','excerpt','trackbacks','custom-fields','comments','revisions','thumbnail','author','page-attributes','post-formats','),
    should be
    'supports' => array('title','editor','excerpt','trackbacks','custom-fields','comments','revisions','thumbnail','author','page-attributes','post-formats'),
    etc.

    In general, if you have Custom Post Type UI installed and active, do NOT copy the code to your functions.php, the register_post_type() is done by the plugin itself.

  10. Michael Beckwith
    Member
    Plugin Author

    Posted 10 months ago #

    And the Get Code is hopefully fixed in 8.1 which I am waiting on a bit of testing + permission to release. Ov3rfly is right though, the Get Code bit doesn't handle the registering when the plugin is active.

    It should be stable enough that I am fine with doing this. Evoweb, download this here: https://github.com/WebDevStudios/custom-post-type-ui/archive/master.zip

    and extract the contents into the same plugin folder on your server. Keep the folder name the same though. Once things get pushed out to WP.org, if there's anything different, you should get a prompt to update it via your admin later, and you'll still get the latest version.

Reply

You must log in to post.

About this Plugin

About this Topic