WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blank page for everything (7 posts)

  1. zigggy
    Member
    Posted 4 years ago #

    Hi guys,
    Without making any modifications to the site in the last few days, all of a sudden I visited my site to realize it's giving me blank pages for all WordPress pages. Homepage doesn't appear, login doesn't work, etc. etc.

    The files are still on the server, and reading files from it works (e.g. this: [URL redacted])

    Can anyone help? What's the issue? I Googled around and couldn't find anything. The site is here.

  2. jimisaacs
    Member
    Posted 4 years ago #

    Initially, my first response to a blank page without making any modifications, is to check/contact your host for any support or maintenance alerts.

  3. zigggy
    Member
    Posted 4 years ago #

    Nothing on their site, and nothing when I called. What else could it be?

  4. jimisaacs
    Member
    Posted 4 years ago #

    Try to enter this at the top of your index.php file in the root temporarily, to see if there are any errors output after the fact.

    <?php
    ini_set('display_errors',1);
    ini_set('display_startup_errors',1);
    error_reporting(E_ALL);
    ?>

  5. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Check with these options:

    - Upgrade wordpress to the latest version
    - Disable all the plugins via FTP.
    - Remove all unwanted code from htaccess
    - Check with default theme to ruled out theme level issue.

    Thanks,

    Shane G.

  6. WPpremium
    Member
    Posted 4 years ago #

    Sometimes this happens due to PHP memory issue. Try following solutions:

    [1] You can contact your host to increase limit for php_memory.
    [2] You can add following line in your .htaccess:

    php_value memory_limit 64M

    This will not work if suPHP is enabled on your server. If suPHP is enabled on your server then you will need to put php.ini in the root of your domain and modify the following line:

    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    [3] You can also raise PHP memory from wp-config.php file. Just add the following line after opening PHP tag:

    define(‘WP_MEMORY_LIMIT’, ‘64M’);

  7. zigggy
    Member
    Posted 4 years ago #

    Thanks guys. I called the host, and apparantly a virus infected all the files on my server...I reinstalled and will have to pick up from the ashes...very annoying, but I'll live.

    Thanks for all your help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.