WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blank page after submit or save (8 posts)

  1. chillbilly
    Member
    Posted 4 years ago #

    When a comment is being posted after clicking save I get redirected to a blank white page.

    This also happens when I click save in the theme editor and also after clicking activate or deactivate in the plugin section.

    I tried to play around with the permalink structure with no luck.
    I tried deleting the .htaccess file with no luck.
    I repaired the wp-comment table in the database with no luck.
    I tried re-uploading 2.8.4 with no luck.

    This is happening just after updating to 2.8.4

    Tried a few other blank white page type fixes found in the support here with no luck.

  2. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Check with these options:

    -> Disable all the plugins and enable it one by one to find out the culprit.
    -> Change your wordpress theme to default in order to rules out theme level problems.
    -> Remove all unwanted code from htaccess

    Thanks,

    Shane G.

  3. chillbilly
    Member
    Posted 4 years ago #

    I tried the disabling of the plugins with no results... huge pain though becuase every time I click disable I get a white page.

    I also removed the htaccess file completely with no results good or bad.

    I did switch over to the default theme and that did help with the posting of comments, but did nothing for the admin section giving me a blank white page when saving template files and disabling plugins.

  4. chillbilly
    Member
    Posted 4 years ago #

    No... wait... I just switched to the default again and did some testing and it works.

    What would be the problem with my theme? it has got to be one of the most plain themes out there and I chose it as to avoid problems like this.

    I am using the white as milk theme.

    site is www dot 108billy dot ca

  5. chillbilly
    Member
    Posted 4 years ago #

    Fixed it.

    Logged into my host and opened the php.ini file to edit it. On some hosts it is found in the CGI and php scripting options.

    I changed the memory limit to 64.

    memory_limit = 64M ; Maximum amount of memory a script may consume (8MB)

    I thought I had done it all ready, but I guess I did it in another site I have that's using joomla.

    Once that was done I saw an error on my site... the warning header all ready called pluggable.php stuff.

    So I opened my wp-config.php file and deleted a random extra line in the file that can only bee scene in an editor that numbers the lines like dreamweaver.

    I also made a copy of the comments.php file in the default theme and replaced the comments.php file in the theme I am using with the default one. I left the one that came with my theme in the theme folder, but re titled it comments.bak.php.

    I also disabled and deleted my theme your login plugin becuase I was mentioned in the header warning I got. Not sure if that was a problem, but in a few minutes I will try to reinstall that plugin and see if it works....probably will.

    Site is workin just fine now! Hopefully this info will help someone else out with the same issue.

  6. workingroup
    Member
    Posted 4 years ago #

    I have this same problem, when saving a draft or saving a pending, but the problem never occurs when I do these when the server is not being accessed by visitors; when there are even 6+ visitors it happens.

    I tried changing the php options to allow 64M of memory as susggested above, but to no avail.

    I don't have the other problems you describe, I only get a completely white blank screen.

  7. workingroup
    Member
    Posted 4 years ago #

    oh I use WP 2.9.1 and php. 5.2.11

  8. pressorder
    Member
    Posted 4 years ago #

    Can changes in the functions.php file cause the blank pages?
    It looks like I have a theme related problem that is causing the blank pages and inaccessible admin panel, as they disappeared when I removed the theme.
    Could anyone help me fix the problem and take a look at my functions file?
    I added another sidebar to the theme and had to alter the functions.php.

Topic Closed

This topic has been closed to new replies.

About this Topic