WordPress.org

Ready to get started?Download WordPress

Forums

Welcart e-Commerce
Blank page after registration/order and sending emails problem (11 posts)

  1. Tyfa
    Member
    Posted 2 years ago #

    Hi,
    I have a problem after finishing registration or order. There is only white page after both actions. Anyway, registration and order are both in DB. I have Welcart version 1.0.5, WP 3.2.1 and I don't use SSL setup.

    Also I can't send email with order information. Nothing happend after I click on Send button.

    Can you help me please.

  2. hitotch
    Member
    Posted 2 years ago #

    Tyfa,

    Hi,

    I will pass this info to the development team in Japan.
    Could you please give us some information about your environment?
    1) When you installed your WordPress, the email from WordPress system has been successfully sent to your email address?
    2) Are you using paypal or some other payment method?
    3) "registration" means the user registration during the order process?

    Thank you,
    Hitotch

  3. Tyfa
    Member
    Posted 2 years ago #

    Hi Hitotch,
    of course:
    1) yes, there was no problem
    2) no, just prepayment method to our account
    3) problem appears also during registration itself without sending order

    I also use czech language, I translated part of eshop visible for users

    Iva

  4. hitotch
    Member
    Posted 2 years ago #

    Tyfa,

    Alright, please try the followings.
    1) Turn the warning message on.
    wp-config.php > change WP_DEBUG from false to true
    This setting shows PHP errors. Please check if the white screen has any error.

    2) Send email from New order, and check your email is fine.
    Press "show the mail/print field" and click Mail for confirmation of order, and send email.

    Hitotch

  5. Tyfa
    Member
    Posted 2 years ago #

    Hitotch,

    1. I Turn warning message on, but there is no PHP error, just white page.

    2. I tried it, but nothing happend after I click on Send button. But wp sends emails, also I instaled MEE News plugin and I can get emails from it.

    Iva

  6. hitotch
    Member
    Posted 2 years ago #

    Okay, I will pass this info to Japan team.

  7. hitotch
    Member
    Posted 2 years ago #

    Tyfa,

    In Japan, there was same issue, and resolved in the following way.
    1. Changing theme (try Welcart default theme)
    2. Removing another plugin (Some of plugins will have conflict with Welcart)

    Please try above.

  8. hitotch
    Member
    Posted 2 years ago #

    Tyfa,

    If you can, try followings also.
    - Show error message by:
    php_flag display_errors On in .htaccess
    ref: http://perishablepress.com/press/2008/01/14/advanced-php-error-handling-via-htaccess/

    Developers can investigate your error.

  9. Tyfa
    Member
    Posted 2 years ago #

    Hitotch,

    I tried to remove theme and plugins, problem with the white page is with Mee News. After deactivation of this plugin is order OK. But still there is a problem with sending emails, I can get error message now: Failure in sending e-mails.

    Iva

  10. Tyfa
    Member
    Posted 2 years ago #

    Thank you for solving my problem, I found error in sending emails in setup.

    Iva

  11. hitotch
    Member
    Posted 2 years ago #

    Okay,

    Please let me confirm your issue for the following people.
    1. There was a conflict issue with the plug-in Mee News.
    This was the root cause of the white screen.
    2. Email setting was not set correctly.

    Thank you,
    Hitotch

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags