WordPress.org

Ready to get started?Download WordPress

Forums

Blank page after migration (4 posts)

  1. taliesin1077
    Member
    Posted 3 years ago #

    To begin, yes, I've used the search, and tried a plethora of solutions, all to no avail.

    I am migrating to a different host, and have already moved one of my wordpress sites to the new host. It works fine, so WordPress has no problem with PHP settings on the new host.

    I turned off all my plugins. I switched to the default Twenty-Ten theme. I made sure WordPress was up to date, and installed 3.1.3 when I saw it was available. Old site can still be viewed on the host's provided URL. Backed up the database using PHPMyAdmin. Backed up the files using FileZilla.

    On the new host: Created a new database, created a user, assigned that user to the database. Imported backup database. Uploaded all the files into new directory. Edited database details in wp-config.php to be correct for the new database settings. Went into wp-options using phpmyadmin on new host to change blogurl to be correct for the new host.

    Blank page. I can't get anything to display on this page. I even copied the code from the wp-config-sample.php, and edited the database details just to make sure it wasn't some custom mod I'd done over the years. I've deleted the .htaccess. This is what the page source looks like on the new host:

    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define('WP_USE_THEMES', true);
    
    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>

    Seriously frustrating. I've moved WordPress several times, and every time I've had weird issues, but on this one, I thought I actually did everything right for once.

    In trying to troubleshoot the problem, I blew away the backup I made from the old host, made it again, blew away the sql backup, did another one of those, etc. I've reuploaded and reimported all backups, and same blank page. With no error messages, I don't even know what to look at.

    I can provide the url to the old and new blogs if you'd like to see them in action, but the old one still works fine, and the new one just gets a blank page.

  2. taliesin1077
    Member
    Posted 3 years ago #

    More information, because I'm trying whatever I can to get this fixed. lol.

    I have uploaded a fresh (new downloaded) copy of wp-admin and wp-includes.

    I attempted the plugin reset instructions, but cannot log into my dashboard, so I just got back my old plugins directory.

    Still a blank page.

  3. taliesin1077
    Member
    Posted 3 years ago #

    Ok, now this is interesting....

    I blew in a new copy of a wordpress download, and still got the blank page after verifying that wp-config.php is set correctly.

    I decided to run wp-admin/install.php, just to see if I could get SOMETHING to load, and it tells me:

    Error: PHP is not running
    
    WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.

    Now, this is not true because I have another WordPress site up and running. This is set up on a subdomain of an add-on domain. Any thoughts?

  4. taliesin1077
    Member
    Posted 3 years ago #

    AHA!!!!!!!!!!!!!

    This looks like the culprit. On add-on domains, I have to add a php handler to the .htaccess file in the root of the add-on domain.

    I had to add the following code:
    AddHandler application/x-httpd-php5 .php

    That at least got SOMETHING displaying. Need to figure out why it looks all wiggy, but this is a start. For anyone who's having the same problem, try to go to http://www.your-domain.com/wp-admin/install.php

    If your add-on domain (or even possibly main domain) is not configured correctly, it'll tell you php is not running.

    Another option is to create a file called info.php and put the following code in it:

    <? php
         phpinfo();
    ?>

    And put it in your root directory. (public_html or httpdocs or something like that.) Then go to http://www.your-domain.com/info.php and if it doesn't display a list of PHP settings, you need to do what I mentioned above.

Topic Closed

This topic has been closed to new replies.

About this Topic