WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] blank page after installation (11 posts)

  1. tizianopitisci
    Member
    Posted 2 years ago #

    Hello, I'm tring to install wordpress but nothing happens: the only thing you see is a blank page. I've installed wordpress several times without problems. But since I've changed webhost (which requieres to put all file in a folder called public_html ) I'm having troubles...

    Would you help me? Thanks...

  2. tizianopitisci
    Member
    Posted 2 years ago #

    Some extra information... as I edited config.php turning the line

    define('WP_DEBUG', false);
    in
    define('WP_DEBUG', true);

    I've got the following error message from the server:

    Fatal error: Out of memory (allocated 21233664) (tried to allocate 71 bytes) in /home/sitename/public_html/wp-includes/pomo/streams.php on line 86

    Does it make any sense?

  3. frodoh
    Member
    Posted 2 years ago #

    Yes, your new server has memory limits that you have exceeded. A quick fix would be:

    <?php

    ini_set('memory_limit', '64M');

    ?>

  4. frodoh
    Member
    Posted 2 years ago #

    Are you still experiencing the blank page error? Wasn't sure if you solved that yet or not.

  5. tizianopitisci
    Member
    Posted 2 years ago #

    Hello Frodoh, in which file should I put that code?
    Thanks

  6. frodoh
    Member
    Posted 2 years ago #

    I apologize, that probably would have helped. wp-config.php should be fine.

  7. tizianopitisci
    Member
    Posted 2 years ago #

    Thank you but still have the same problem... see http://www.sgpp.it

  8. tizianopitisci
    Member
    Posted 2 years ago #

    for diagnostic purpuse, I've also created a tester.php file with this code:

    <?
    ini_set('display_errors','1');
    ini_set('display_startup_errors','1');
    error_reporting (E_ALL);include('index.php');
    ?>

    and the result is this message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/sitename/public_html/tester.php:9) in /home/mm5061/public_html/wp-includes/pluggable.php on line 866

  9. frodoh
    Member
    Posted 2 years ago #

    Try:

    <?php

    ini_set('memory_limit', '128M');

    ?>

    Also, can you post the source code, preferably line 866 of pluggable.php ?

  10. tizianopitisci
    Member
    Posted 2 years ago #

    I've tried with 128M but it didn't work.

    source code, line 866: header("Location: $location", true, $status);

  11. tizianopitisci
    Member
    Posted 2 years ago #

    Hello Grodoh, as you said the problem was the php memory limit of my new server. Now they've changed the settings (think 64 M) and everything goes well. Thank's for the support.

Topic Closed

This topic has been closed to new replies.

About this Topic