WordPress.org

Ready to get started?Download WordPress

Forums

blank page after comment is submitted (27 posts)

  1. griffithstoby
    Member
    Posted 6 years ago #

    hi

    i cant seem to find an answer to this anywhere that helps me. + there are quite a few posts about this.

    After posting a Comment a blank page is shown in any theme - default etc..

    This works fine for me if I am logged in... i commment and i am returned to the page where i commented

    - for anyone else you are shown a blank white page with

    http://www.tobysplace.me.uk/blog/wp-comments-post.php in the address bar.

    Is there a solution for this?
    many thanks,
    Toby

  2. birdyoshi
    Member
    Posted 6 years ago #

    I've got the same problem, and many people have this problem, and NOTHING from the WordPress folks. Not a peep. I can see 7 different people with the same problem. WordPress is so amazing, as long as someone is paying attention... if not, you've no options.

  3. Tdude
    Member
    Posted 6 years ago #

    Hi!
    You could try to follow the tips (erasing the files in wp-content/uploads/js_cache) from this site
    If you can post something more about your WP version, the kind of server it's on (os, php version etc.), it would be easier for someone knowledgable to help you.
    I have this on one site out of 15 on the same IIS server with WP 2.5.1/php5, so it could be plugin related, which kind of explains why you don't get anyone answering. The error doesn't show up on Apache servers for me. Don't moan, send more data!
    /T

  4. aocbrasil
    Member
    Posted 6 years ago #

    I think i have the same problem, would you mind checking it out? Just go and try to comment here for example http://liquide.890m.com/stock/?p=10#respond
    My website is hosted on a linux based server and its wp version is 2.5.1
    I might also say that last time i got a comment, i had 2.3 version. Dont know if theres something related.

  5. conall
    Member
    Posted 6 years ago #

    I have this problem too. I don't think it's my PHP setup, since I can post blog entries, but not add comments.

    Version details of my setup:

    WordPress: 2.5.1
    O/S: FreeBSD 6.3
    MySQL: 5.0.41
    PHP: 5.2.6 (running in CGI mode)
    Apache: 2.2.8

    I suspect there is a bug in my DB following a recent upgrade (either to 2.5.0 or a release shortly before), since dumping my DB and restoring it to a fresh WordPress install reproduces the same effect.

  6. conall
    Member
    Posted 6 years ago #

    I should also mention that I could add comments to the clean install, prior to the DB restore which introduced the bug

  7. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Have you looked in your error log? Anything there? What about adding error_log() statements to wp-comments-post.php and checking how far into the file PHP got? You may need to dig deeper and look in wp-includes/comment.php but do the same there and I think you should find out why that's happening very quickly.

  8. conall
    Member
    Posted 6 years ago #

    Using error_log, the problem appears to be with the line:

    $comment_id = wp_new_comment( $commentdata );

    $commentdata is a populated array created by compact() immediately before, and $comment_id is NULL afterwards, so I suspect the wp_new_comment() function is the culprit

  9. Aleph Ozuas
    Member
    Posted 6 years ago #

    I am having the same problem and cant solve. when a user try to post in my blog and didn't fill any field, (s)he receive a blank page, not one telling (s)he to correctly fill the fields (the correct behavior). I am having this problem in 4 blogs, all with 2.5 version.

  10. Aleph Ozuas
    Member
    Posted 6 years ago #

    I mean, I would like to receive the "Error: please fill the required fields (name, email)." message, any idea?

  11. Aleph Ozuas
    Member
    Posted 6 years ago #

    Please, someone can help us?

  12. Hedley
    Member
    Posted 6 years ago #

    I started having this problem recently as well. Posting was fine, but if anyone left a comment, they would be shown a blank page after clicking submit. I tried turning off each plugin individially, as well as upgrading WordPress.

    While I was experimenting, I noticed that a visit who is not logged in would get the blank page, but if I - as admin - left a comment while logged in, I did not get the blank page. This led me to consider what might be triggered by an anonymous visitor that would not be triggered for admin. Further thinking led me to a solution. Since I have my system set to hold comments for Admin approval, an e-mail to Admin is generated when someone leaves a comment, but because comments by the Admin are auto-approved and not held for moderation, no e-mail is generated. It seemed likely that the e-mail was failing for some reason, and WP (or a plugin) didn't handle the error well enough to do anything but stop processing while trying to execute the remaining sections of "wp-comments-post.php". This was reinforced by the fact that I had not received any e-mails recently reminding me to moderate new comments.

    Then I remembered that I had recently changed my Gmail password. The reason that that is relevant, in my case, is that I use the "Swift SMTP" plugin from Shift This to send e-mail from my site, which allows me to send mail through my Gmail account. I went into the Swift SMTP options, updated the password, and the blank page problem went away.

    There may be some of you who do not use this plugin and are having this problem, but perhaps my experience will give you a hint of somewhere to look for a solution that you hadn't previously considered.

    Good luck!

    HB

  13. Tdude
    Member
    Posted 5 years ago #

    You could also try the tips on this link if you're on an IIS server (Windows).
    /T

  14. Clicknathan
    Member
    Posted 5 years ago #

    Yeah, this is really weird. So many people with so many different problems.

    I personally can only post when I'm not logged in. Anonymous posters / those that aren't registered have no problems posting.

  15. cma01
    Member
    Posted 5 years ago #

    I'm getting the same thing. After someone submits a comment, logged in or otherwise, the post content doesn't reload. The entire left content area is empty.

    I've tried different things, and all of them have the same thing.

  16. josieprogramme
    Member
    Posted 5 years ago #

    I was seeing the same problem. I disabled Akismet and now commenting works.

  17. zeppb
    Member
    Posted 5 years ago #

    I've been having the same problem myself. I noticed a lot of other sites have this problem but there are a few who don't

  18. Z
    Member
    Posted 5 years ago #

    I've been having this problem too, only it happens at random times and I don't know why. I've tried all the fixes, such as adding the line of code WordPress recommends in their FAQ (already there in my theme, so wasn't the cause), deleting a blank line in wp-comments-post.php (didn't make a difference), etc.

    The ONLY thing that works for me is restarting my server. The tech support people at my server company say it's a problem with my js_cache, but I don't know how to fix it. I'm thinking it might be plugin related (Google XML Sitemaps maybe?), but I really don't know. If anyone has any fixes for the js_cache problem, I'd love to hear about them.

  19. daisycutter
    Member
    Posted 5 years ago #

    I'm having the same problem for Admin user and anyone else, I've tried all the suggested solutions to no avail, but here's the clincher for me: it's only happening in IE7, and works just fine when I test it in Opera. It's happening from a clean install of version 2.7.1 with no plugins and I've tried a number of different themes.

    If you've previously posted here and you're still experiencing the same problem or if you're a new poster, can you please tell us what browser you're using to test your page and perhaps try another and tell us how that worked, it may lead us to a solution...

  20. Deceth
    Member
    Posted 5 years ago #

    I am having the same problem on http://www.looble.com.

    I can post comments if I am logged in as admin, but nobody else can comment. If I log out, I can no longer comment. I've tried disabling plugins and changing theme but this has not helped.

  21. blynnerobson
    Member
    Posted 5 years ago #

    Same problem here...I have no problems on other blogs on the same server...
    have tried to reinstal, have the same problem on all themes, going to try to disable some plug ins and see...will let you all know

  22. blynnerobson
    Member
    Posted 5 years ago #

    I have deactivated all plugins...and it is working...going to reactivate plugins one at a time and let you know...

  23. blynnerobson
    Member
    Posted 5 years ago #

    it is the ShiftThis.net | Swift SMTP plugin...
    I am going to download and reinstal it...

  24. blynnerobson
    Member
    Posted 5 years ago #

    appears that this plugin is no longer supported...can't even find it on the developers site...
    If you must have a plug in like this for your wordpress...I am going to recoment http://wordpress.org/extend/plugins/cimy-swift-smtp/

    They have current documentaion

  25. Deceth
    Member
    Posted 5 years ago #

    I do not have the Swift SMTP plugin, but am experiencing this problem. Even if I disable all plugins and use the default theme.

  26. pacothelovetaco
    Member
    Posted 5 years ago #

    Hopefully this will be a solution for some of you. I was having the same problem. However comments worked in the default WP theme, it just would not work in my theme. Comparing the two themes, I found that my single.php template was missing <?php if (have_posts()) : while (have_posts()) : the_post(); ?> After I added it, everything worked fine. So check if you are calling the loop in this way:

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    <div>
    YOUR POSTS CONTENT
    </div>
    
    <?php comments_template(); ?>
    
    <?php endwhile; else: ?>
    
    <p>Sorry, no posts matched your criteria.</p>
    
    <?php endif; ?>
    
    </div>
    
    <?php get_footer(); ?>

    I have a feeling this is the correct way to do it. I rarely looked at the documentation when I learned to use WP. Hope this helps for someone, and it isn't my own isolated newbie mistake.

  27. sultan111
    Member
    Posted 5 years ago #

    I get the same blank page when i submit my url. I guess akismet is wrongly flagging by site as spam or it is is a bug either of wordpress or akismet. Please i need some help in getting my site unbloked from this spam issue. I am providing my website url for you to check

    Thanks
    Sultan
    http://www.forexfreedownload.com

Topic Closed

This topic has been closed to new replies.

About this Topic