WordPress.org

Ready to get started?Download WordPress

Forums

blank page after comment (6 posts)

  1. ozgeekmum
    Member
    Posted 3 years ago #

    hi

    I've done a search for blank pages after commenting, and made the following suggested changes:
    - ensured no blank lines at bottom of files
    - ensured database tables repaired
    - upgraded to latest version of core plus plugin
    - ensured the form had the required lines.

    but the only thing that fixed it was turning off Akismet.
    It is sporadic - seems to depend on the content rather than IP address. So if I enter a boring comment by user test, at test@test.com with comment test, that will trigger the problem. Long interesting comments with unusual names usually won't, but enough people have reported having problems, that it needs to be fixed.

    So are there any good alternatives to Akismet?
    I was looking for wp-spamfree, but apparently WordPress disabled it this week.

    If preferable, I'd avoid captchas, and go for pattern matching like Akismet or WP-spamfree, but I'm open to the best suggestion.

    cheers

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

  3. ozgeekmum
    Member
    Posted 3 years ago #

    hi esmi,

    yeah, i tried it with the default theme, and the problem was still there.

    i dont really have a lot of plugins on this particular blog:
    allinoneseo, googleanalytics, googlexmlsitemaps, wordpressstats, sociable, wp-cache, plaintextpaste.

    just finished upgrading to the latest core.

    but i got so much spam since disabling akismet yesterday, that i may have to turn it back on.

  4. James
    Happiness Engineer
    Posted 3 years ago #

    Did you deactivate all of the plugins? You don't have to leave them deactivated. Just deactivate all of them and try a test comment. If it works, reactivate each one individually until you find the one causing the problem.

  5. artmuns
    Member
    Posted 3 years ago #

    I found that a user would get a blank page after a comment if he mentioned his name twice in the comment. Removing one instance of the name fixed the problem. Go figure!

  6. Learn french in france
    Member
    Posted 3 years ago #

    did not solve my problem...

Topic Closed

This topic has been closed to new replies.

About this Topic