Ready to get started?Download WordPress


Easy Digital Downloads
[resolved] Blank Page (16 posts)

  1. bajan4evr2
    Posted 1 year ago #

    All my download pages are showing up blank.


  2. Can you please elaborate? Are you getting a 404 error on the download pages? Have you consulted the documentation? https://easydigitaldownloads.com/documentation/

  3. bajan4evr2
    Posted 1 year ago #

    Well i sent i detailed message the last time but its was deleted. Everything was working before. I did not make any changes since i installed and setup this plugin. Now if i create or event try to go to a download page, all i get is a blank page, like this: http://trobaz.com/downloads/free-wordpress-cherry-framework-theme-for-pet-project/

    It just installed it in a domain. It should look like this: http://trobook.net/downloads/pet-project/

    I don't know why the first one stopped working. I have not touched it since it was installed weeks ago. It was only after a recent EDD update.

    Thanks for your quick response.

  4. It was deleted? On these forums or the ones on easydigitaldownloads.com? I assure you, I didn't delete it :)

    Can you enable WP_DEBUG so we can see if there is an error on the page?

  5. bajan4evr2
    Posted 1 year ago #

    Not sure if i want to put my live site in debug mode for this, afterall, i just want to give away some free themes. I thought maybe there was a simple solution. I'll do some 'debugging' on my own and get back to you later if necessary. Thanks for your help.

  6. Ok sounds good.

  7. cyndimarie
    Posted 1 year ago #

    Hello, I installed this plugin on a client's site and it is also giving me blank download pages. http://thesewingloftblog.com/downloads/dangerous-with-scissors/
    When I "preview" the download everything looks great, but when I go to the actual download page it is just blank. No error or anything. Also using firebug I detect no code in the body tag at all...

  8. bajan4evr2
    Posted 1 year ago #

    @cyndumarie. I unchecked the 'No Caching on Checkout?' option under Settings >Misc, cleared my cache (i use wp-supercache) and looks like that fixed the problem. Hope this helps.

  9. cyndimarie
    Posted 1 year ago #

    Thanks @bajan4evr2 but it looks like the solution isn't the same for me. The "no caching on checkout" was already unchecked under settings. I cleared the cache (also with wp-supercache) and also my browser cache + tried it in a different browser and still nothing.

  10. @cyndimarie I just loaded the link you posted above and it works perfectly fine for me . . .

  11. cyndimarie
    Posted 1 year ago #

    Yep I just saved the permalink settings like you suggested and it fixed it! Not sure why exactly that worked, but it did. Thanks so much.

  12. Great!

  13. bajan4evr2
    Posted 1 year ago #

    Blank page again but i think i've narrowed it down. Firstly, there's no problem with IE or Firefox, only with Chrome. Secondly if i deactivate wp super cache, the page displays in Chrome. I won't be deactivating either super cache or EDD. If someone needs a free theme bad enough, it shouldn't be too much trouble to contact me. :)

  14. Take a look at our WP Super Cache compatibility doc: https://easydigitaldownloads.com/docs/wp-super-cache/

  15. bajan4evr2
    Posted 1 year ago #

    I applied those settings Pippin and everything looks good so far.

  16. Great!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.