WordPress.org

Ready to get started?Download WordPress

Forums

Blank install.php (23 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    Running Debian
    Apache
    Mysql (4.0.18)
    PHP (4.3.4)
    When I run through wp-admin/install-config.php the second step just has the WordPress header and is then blank. I figure, ok, I probably need to manually edit the file.
    I copy wp-config-sample.php to wp-config.php and edit it so that it looks as follows:
    // ** MySQL settings ** //
    define('DB_NAME', 'gordy'); // The name of the database
    define('DB_USER', 'gord'); // Your MySQL username
    define('DB_PASSWORD', 'MYPASSWORD'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    When I go to wp-admin/install.php I just get a blank page (IE 6 and Firebird 0.8) There is nothing in the source, and no errors logged anywhere)
    I have installed the php-mysql module as suggested in another thread. Restarted both Apache and MySQL. I have absolutely no idea what's wrong. (the database gordy exists and the user gord has permission to do pretty well everything to that database) Any ideas? (oh it's WordPress 1.02)

  2. gord
    Member
    Posted 10 years ago #

    That above post was me. I just decided to register. If you have any other questions you need answered in order to give me a hand, just let me know.

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    Could you give us a URL of the site you're trying to set up?

  4. Anonymous
    Unregistered
    Posted 10 years ago #

    i have the exact same problem. i manually made my config file (didnt even try install-config.php) everything was cool there. Then i tried to run install.php, and all i got was a blank screen on the web browser. I have gone so far to give the files wide open permissions (0777), mysql stuff is all good. nothing happens. does anyone have any advice! thanks!

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    I also am having the same issue. I've verified that the userid/password are valid for the database table and no errors are showing up in the apache errors_log file. :/ I'm confused ...

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    Argh. In addition to being confused, I'm also dumb ... I'd just installed the php-mysql package but neglected to restart the webserver so php could see the extension. Duh.

  7. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    My suggestions would be to first try out a nightly build to see if it's something we've fixed already. Also try installing another php/mysql script like phpBB to see if there's something wrong with your PHP setup

  8. gord
    Member
    Posted 10 years ago #

    Did install a nightly build, exact same error.
    I installed the php-mysql package and /did/ restart my server and php-info shows the extension.
    I worked on it for several hours, including some while talking to Mat trying to work it out. I hate to say it, but I've given up.

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    I'm seeing the exact same problem. I followed the instructions in the readme exactly. Checked and double checked my info, but it still does not work.

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    I just tried upgrading to the nightly build (4/22). This resolved the issue where config.php was not being generated, but install.php still just gives me a blank page. Any assistance would be appreciated. Again, I've checked and double checked my php and mySql setting over and over.
    - Todd

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    okay heres the deal, this fixed the problem for me. You need to find the corrent php-mysql mod so that php can talk to the database. find the exact version of php that you have, mine was 4.2.2-17.2. then just search on google for 'php-mysql (apend your version number of php)'. download and run the rpm and you should be home free.

  12. Anonymous
    Unregistered
    Posted 10 years ago #

    I hit this same problem. I'm not even going to bother getting it working. It should have worked the first time I tried it, but all wp-admin/install.php gave me was a blank page. You guys need to take a close look at it, because something is messed up with it. I'm curious as to what other problems would be lingering if I did manage to get it working.

  13. Anonymous
    Unregistered
    Posted 10 years ago #

    I get the same problem too. Running fedora core 2, apache 2, newest php and mysql. Tried the nightly builds and get the same blank page :(

  14. Anonymous
    Unregistered
    Posted 10 years ago #

    Hi all,
    I've come across exactly the same problem. I'm using Gentoo Linux, a source distribution, compiling everything from source.
    I've only just found out the cause of this same problem for me. I use Apache 2.0.49, MySQL 4.0.20 and PHP 4.3.6 (going to 4.3.8 now). The problem for me was that the 'mod_php' module didn't have MySQL support compiled in. I discovered this after installing phpmyadmin, which told me this: 'cannot load MySQL extension, please check PHP Configuration'.
    I suggest something like the following as an addition to one or more PHP files of WordPress (stolen from 'phpmyadmin/libraries/common.lib.php'):

    /**
    * Loads the mysql extensions if it is not loaded yet
    */
    if (!@function_exists('mysql_connect')) {
    PMA_dl('mysql');
    }
    // check whether mysql is available
    if (!@function_exists('mysql_connect')) {
    if (empty($is_header_sent)) {
    require_once('./libraries/header_http.inc.php');
    }
    echo $strCantLoadMySQL . '
    ' . "\n"
    . ''
    . $GLOBALS['strDocu'] . '
    ' . "\n";
    exit();
    }

    Kind regards,
    Jonathan

  15. Anonymous
    Unregistered
    Posted 10 years ago #

    Oh.. and by the way, the short description about allowed tags when posting a reply could be more clear ;-) What's the need for a 'code' tag when you can put code between 'backticks'?
    'some code'
    or
    some code

  16. JLudwig
    Member
    Posted 10 years ago #

    Same problem here, SuSE 9.1:
    PHP 4.3.4
    MySQL 4.0.18
    Apache 2.0.49 "Pre-fork"
    I used YaST to install phpMyAdmin which worked just fine so I think my mod_php does have the proper options compiled in. php is used all over my site and is working properly.
    Jeff

  17. Anonymous
    Unregistered
    Posted 10 years ago #

    I still have the same problem with the blank install.php!!!
    I installed phpMyAdmin and it works just fine. Added user, granted him ALL privileges under the sun and still BLANK.
    EL BLANCO. Please help.

  18. Anonymous
    Unregistered
    Posted 10 years ago #

  19. krag
    Member
    Posted 10 years ago #

    Hi,
    I had the exact same problem with the same setup as the original poster (Debian, Apache Mysql (4.0.18) PHP (4.3.4)).
    So, I tried installing phpBB to check it wasn't a general php problem and the phpBB install complained that php-mysql module wasn't setup for use with MySQL ver4.
    I didn't need to recompile, just a cheeky dpkg-reconfigure php4-mysql and a restart of apache did the trick for me.
    Hope this helps someone.
    Cheers,
    Craig.

  20. Anonymous
    Unregistered
    Posted 10 years ago #

    install php-mysql (right version), (with Fedora 2: 'yum install php-mysql') and all will work!

  21. ganges
    Member
    Posted 10 years ago #

    Sure!
    All perfectly work after proper installation all about php + MySQL modules
    Mandrake 10
    Thanx

  22. kbyrd
    Member
    Posted 9 years ago #

    Another successful fix.
    I'm running debian unstable, w/ apache2.
    "dpkg-reconfigure php4-mysql" worked perfectly for me.

  23. zfade3
    Member
    Posted 8 years ago #

    Also check your php.ini file to see if you have a memory_limit = 8M setting. The install.php script requires more than 8M to run.

    Some default php configurations from package managers have the memory_limit set to 8M.

    Change it to 16M that worked for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.