WordPress.org

Ready to get started?Download WordPress

Forums

Blank Install Page (8 posts)

  1. AjayFry
    Member
    Posted 5 years ago #

    So I've uploaded all the files, modified the config.php with the correct path to my empty MySql database with the correct name and when I load up http://www.mydomain.com/wordpress/wp-admin/install.php all I get is a blank screen.

    I even look up the source code and it is totally empty.

    I'm certain I've got all the files uploaded, as I've uploaded everything twice now with no 'upload failed' reports from dreamweaver.

    What's the problem?

    Thanks.

  2. vietknight
    Member
    Posted 5 years ago #

    Paste your error logs on your server here. Your server may be restricting memory access.

  3. babysneaks
    Member
    Posted 5 years ago #

    I am having the exact same problem. My webserver company set up the database, and they will not share any error logs with me other than to say there is a permissions issue and that there may be "problems with the version of PHP they are running and the latest version of WordPress." I reviewed with the server folks my entries on the wp-config.php page and they are correct. Is there where the world ends?

  4. vietknight
    Member
    Posted 5 years ago #

    What is your host? There are plenty of other hosts out there that you can use that have cPanel, PHP support,etc... The one I use is http://x10hosting.com

  5. BernardBorealis
    Member
    Posted 5 years ago #

    Double-check that you are able to use php. Also, make sure your permissions are set correctly. Set directories at 755 and files at 644 permissions. Re-upload everything or make sure you aren't missing certain files and try using something other than dreamweaver. Try filezill-project.org perhaps.

  6. babysneaks
    Member
    Posted 5 years ago #

    I went down to my server company and they got WordPress to work. I will try to explain what they did. It seemed to have to do with the security settings set by the server company.

    In short, in the wp-admin folder, where ever there was a require_once('../wp-load.php'); or a require('../wp-load.php);, they replaced it with the full address: require_once('/full/path/to/file/wp-load.php'); or just require('/full/path/to/file/wp-load.php');.

    There are nine files in this folder where they did this replacement:

  7. /admin-ajax.php,
  8. /admin-post.php,
  9. /admin.php,
  10. /async-upload.php,
  11. /install.php,
  12. /link-parse-opml.php,
  13. /moderation.php,
  14. /update-links.php, and
  15. /upgrade.php.
  16. This is certainly not the ideal, but it did get me going for now. I am curious is this is a common problem.

  • scarlettpromotions
    Member
    Posted 5 years ago #

    Hey babysneaks!

    I am getting the same problem with the blank page and I tried to go in and make the changes as you suggested above but it's still not working. I'm wondering if I should be looking to change all relative paths to absolute?

    Are you hosted by media temple? All my files are in a httpdocs folder and I can't help but wonder if that has anything to do with it?

    Help!

  • enxaqueca
    Member
    Posted 5 years ago #

    Hello to all!

    I had a similar problem: a blank /install.php page. Fortunately, my web host's technical support person (ixwebhosting.com) checked and solved the issue:

    On my wp-config file, as you can see below, my

    define('DB_PASSWORD', 'PasswordHere);

    had no closing quote '

    So putting that simple quote was all that it took to finally see the so-expected /install.php page .

    I hope it helps! Good luck!

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags