WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blank Content Pages (index.php and admin are fine) (8 posts)

  1. noreeeen
    Member
    Posted 8 years ago #

    Hi everyone. I'm am a newbie to wordpress and php so please bear with me. I've been searching through the codex, these forums, and google for the past few days looking for answers but I haven't found any.

    I have installed wordpress 1.5 for the second time at http://noreen.sunday51.org/index.php . The first time was an experiment, kind of. With the default theme and then with a theme I installed, everything worked perfectly. Then, suddenly all of my content pages and comment pages stopped showing up (they are just blank pages with almost nothing in the source). I also installed a few plugins, and I can't remember whether this problem started before or after them. As well, I was messing around with the permalink option and ended up with a 500 error page for everything. I read support here and someone mentioned to delete htacces, which i did...but then I had no idea what to do after that.

    I decided to uninstall wordpress and try again. I removed all files from /noreen, and all the wordpress tables were deleted from the database.

    My problem now is that even with a fresh install of wordpress, none of my content or comment pages show up. I have no idea what I should do next.

    I would very much appreciate if someone could point me in the right direction. Please keep in mind that I don't understand php all that well, and thank you in advance...I'm just so lost with this right now.

    Noreen

  2. IAMalik
    Member
    Posted 8 years ago #

    This is just a theory. I noticed it's calling index.php, which isn't normal. WP usually adds a mod rewrite function that customizes that out. you can see all your pages if you just add index.php to it.

    For example,
    http://noreen.sunday51.org/?page_id=2
    does not show but
    http://noreen.sunday51.org/index.php?page_id=2
    does.

    I think the problem is that the posts and page links are calling to the links without index.php. So try this.

    In your wordpress folder create a file called .htaccess
    (if it doesn't exist already)

    put this in it:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /home/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /home/index.php
    </IfModule>

    # END WordPress

    and save.
    hope that helps.

    Imran

  3. noreeeen
    Member
    Posted 8 years ago #

    Hi Imran, thank you the reply.

    /noreen didn't have a .htaccess file in it, so I created it with the code that you wrote. Now, all my pages are "Internal Server Error"s. Any idea of what to do next?

    Thank you so much.

    Noreen

  4. Direkt
    Member
    Posted 8 years ago #

    If that's occuring it ( your server ) probably doesn't have mod_rewrite enabled, so do remove that, as it won't be helping much.

  5. Direkt
    Member
    Posted 8 years ago #

    So, it's a completely fresh install right, the entire installation of the previous WordPress is gone, correct?

  6. noreeeen
    Member
    Posted 8 years ago #

    From what I know, yes. I deleted everything in /noreen, and then the host of my subdomain followed the instructions here: http://wordpress.org/support/topic/56894?replies=2 to delete the wordpress tables.

    Do you think the permalinks thing might help? I don't know if I know what i'm talking about, but as the page says "For the above to work you must have something called mod_rewrite installed on your server. (Ask your host.) If that isn’t available, you can prefix the structure with /index.php/ ."
    Because, er, it doesn't do the index.php thing to begin with, as Imran said?
    Or my idea totally off, and is there something else I should be doing?

    Thank you

  7. noreeeen
    Member
    Posted 8 years ago #

    Okay, when I do the Permalink think by adding "/index.php/" followed by whatever else, like "/index.php/%year%/%monthnum%/%day%/%postname%/", it yields working linked pages (eg. http://noreen.sunday51.org/index.php/hello/). Why does this work? Is there anything I can do to make these links look more aesthetically pleasing? Every single link has /index.php/ in it...is it supposed to be that way?

    Why didn't it work to begin with? I want to keep the default linking structure.

    Thank you.

  8. noreeeen
    Member
    Posted 8 years ago #

    Okay, so since my server apparently doesn't have mod_rewrite, the permalinks must contain index.php, am I correct? If that is the case, how do I make it so my Pages links don't contain index.php...or is this not possible?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags