WordPress.org

Ready to get started?Download WordPress

Forums

blank comments page (11 posts)

  1. Bubbles00
    Member
    Posted 9 years ago #

    I just upgraded to wordpress 1.5 and everything works fine except that I can not see the comments page. I see the link and when I click on it, the page just shows my entry and blank space below it...no comments posting place and all. I dont know whats wrong with it. Please help me!
    http://bouncy-bubbles.net/ you can see what I mean there.

  2. moshu
    Member
    Posted 9 years ago #

    You should upgrade to 1.5.1 - since yesterday that's the latest stable version.

    It is possible there is no comments.php template in your theme and in addition (probably) you don't have the deafult theme installed either. If your theme doesn't have a comments template WP will be looking for in in the default theme, but if it's not there... :(

  3. Bubbles00
    Member
    Posted 9 years ago #

    My theme has the comments template.... do I still need a proper comment template in default theme too?

  4. Bubbles00
    Member
    Posted 9 years ago #

    :( please help me! I do not want to upgrade to 1.5.1 as yet. I just noticed that the comments work fine if I use the default theme. I tried uploading the default theme's comments.php to my current theme folder but the comments still dont work! Please help!

  5. moshu
    Member
    Posted 9 years ago #

    Paste here http://pastebin.com/ your index.php file and post back with the uri

  6. Bubbles00
    Member
    Posted 9 years ago #

    Okay. I am using s theme made by myself. My wordpress is in the directory called wordpress. I uploaded ind4ex.php (wordpress/index.php) file to my root directory and changed the blog & wordpress url accordingly in the wordpress cpanel > options.

    http://pastebin.com/282134 - this is my theme's index.php file

    http://pastebin.com/282137 - thats the index.php in my root directory

  7. Bubbles00
    Member
    Posted 9 years ago #

    Oh and this is my comments.php page in the current theme folder http://pastebin.com/282140

  8. moshu
    Member
    Posted 9 years ago #

    You don't have the call for your comments.php template in the theme's index.
    Insert this:
    <?php comments_template(); // Get wp-comments.php template ?>
    in the code like this:
    <!--
    <?php trackback_rdf(); ?>
    -->

    <?php comments_template(); // Get wp-comments.php template ?>

    </div>

    <?php endwhile; else: ?>
    <p><?php _e('Sorry, no posts matched your criteria.'); ?></p>
    <?php endif; ?>

  9. oriecat
    Member
    Posted 9 years ago #

    You need to make sure that <?php comments_template(); ?> is in there.

  10. lawtai
    Member
    Posted 9 years ago #

    add this line in your loop to get your comment box to show up

    <?php comments_template(); ?>

    heh yea, what the other 2 have said.

  11. Bubbles00
    Member
    Posted 9 years ago #

    okay! Yay its there now :D thank you so much! Wow the text area looks huge! I will have to fix that. Thanks alot!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.