WordPress.org

Ready to get started?Download WordPress

Forums

Blank Admin Pages and CSS Disabled on Front End? (13 posts)

  1. Lins
    Member
    Posted 1 year ago #

    Hi there!

    Running a website in volunteer capacity at my son's school. Suddenly, the CSS is disabled on the front-end (still shows correctly in the editor) and a lot of my admin pages are BLANK.

    Eg. I can use http://www.mydomain.com/wp-login.php but I get blank page at http://www.mydomain.com/wp-admin.

    Also I tried uninstalling a plugin and got a blank screen instead of a confirmation or status screen.

    Just wondering if there were any others out there who have recently experienced &/or solved this.

    Doing some research on wordpress.org, it's possibly something on the host's end-- as we did not change anything at all on the site (other than adding a new post). I've contacted the host asking about this and requesting a php error log if possible.

    Would appreciate any other suggestions or ideas. We're running version 3.4.x, I don't know. I know I need to update WP to 3.5, but an weary of doing it when there's a problem.

    I will try disabling plugins but some are configured with options and I don't want to have to re-figure them out -- can I zero in on the one that's causing a conflict if that's what's up?

    This is a volunteer website for me and this is happening at a really busy time... which stinks! Really need help!

    Thanks!!

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Site url? Why are you using an older version of WordPress?

  3. Lins
    Member
    Posted 1 year ago #

    Ok... so that's fascinating... just renamed the plugin folder temporarily to easily disable all plugins... and the CSS started to work again on the front-end. Seems to be a plugin conflict...

  4. Lins
    Member
    Posted 1 year ago #

    @esmi... only because I haven't put the time in to maintain over the past few months as I've been working hard on paid work... guess it's a good reminder to teach someone else to run updates.

    It seems to be a plugin maybe? My best bet is to disable all of them then?

    http://www.uplandspac.ca

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    I;d suggest leaving all plugins deactivated for now. Then switch to the Twenty Eleven theme, backup your database and upgrade WordPress asap. Right now, your site is at real risk of being hacked.

  6. Lins
    Member
    Posted 1 year ago #

    @esmi - thank you for your reply.

    Unfortunately when I tried to disable all the plugins, I got the blank screen again. So no disabled plugins... not sure how to disable them over FTP without losing all the settings.

    When I went to check on the settings for Gravity Forms, I got this message: ***You do not have sufficient permissions to access this page.*** Great.

    After renaming the plugins folder back to Plugins, I got some of the CSS back on the front-end... so now the website is a really big mess. :(

    I hate to leave it but I just can't put the time in at this moment. Scrap.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Can you try renaming the plugin's folder? That didn't seem to cause any problems before.

  8. Lins
    Member
    Posted 1 year ago #

    Yes... thanks... just figured that out too. So I renamed it, and there are some php error messages on most admin pages. But I can navigate to the Themes page. However when I try to activate TwentyEleven, I get this:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/07/7324307/html/wp-content/themes/thematic/functions.php:1) in /home/content/07/7324307/html/wp-includes/pluggable.php on line 881

    Can I activate TwentyEleven without this user interface?

    The php error on the Themes page is just this (instead of Admin header): Warning: Cannot modify header information - headers already sent by (output started at /home/content/07/7324307/html/wp-content/themes/thematic/functions.php:1) in /home/content/07/7324307/html/wp-includes/option.php on line 563

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Can I activate TwentyEleven without this user interface?

    Yes. Switch to the default theme by renaming:

    wp-content/themes/thematic

    to:

    wp-content/themes/thematic-old

    using FTP or whatever file management application your host provides.

  10. Lins
    Member
    Posted 1 year ago #

    Okay. Done. Thank you so much for your help... I might have it working again...

    Know what's crazy -- I read a tip on this support page about extra blank lines in your wp-config file. http://wordpress.org/support/topic/blank-admin-pages

    Opened mine, turned out that W3C Total Cache plugin had inserted a line at the beginning, and there were some blank lines around it.

    Took the blank lines out at the beginning & end of the file.

    Functionality so far seems to be restored. Just backing up & will update to 3.5.

    Now to put everything back to "normal" again... sigh! Hopefully this will do it.

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    Just be careful when reactivating your old theme and each of the plugins. There's always a chance that one or more of them could have problems with WP 3.5 - especially if they haven't been updated in a while.

  12. Lins
    Member
    Posted 1 year ago #

    Will do. Thanks again!

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    Glad I could help. Any further problems, just post a new topic and we'll do our best to help again. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic