WordPress.org

Ready to get started?Download WordPress

Forums

WP YouTube Lyte
[resolved] Black Screen on embed videos (18 posts)

  1. Snakeman
    Member
    Posted 1 year ago #

    All videos i have embed with youtube lyte are have only a black screen and no graphics from you lytesprite.png

    http://www.nils-snake.de/archives/sin-city-the-all-green-version

    http://wordpress.org/extend/plugins/wp-youtube-lyte/

  2. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like Cloudflare is doing something with the javascript that causes lyte-min.js not to load. Anything in Cloudflare config to exclude it from acting on lyte-min.js?

  3. Snakeman
    Member
    Posted 1 year ago #

    i will deactivate cloudflare and then we will see ;-)

  4. Snakeman
    Member
    Posted 1 year ago #

    problem solved: amazon cloudfront was the problem, the lyte-min.js was hosted with cloudfront and can't works on that way with your plugin

  5. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    based on the error-message I saw;

    TypeError: p.style.width.match(...) is null

    you were still getting the 1.1.9-version lyte-min.js instead of the 1.2.0 one. if your CDN ignores querystring-parameters, that might indeed be the case. either flushing your cache or telling cloudfront it should not consider a request with a different querystring as a different request (i.e. not serving from cache), it should work from a CDN (I'm on MaxCDN and indeed changed an option).

    hope this helps,
    frank

  6. camafive
    Member
    Posted 1 year ago #

    Hi, i have this same problem, it means that i have to deactivate cloudflare?

  7. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    hmmm, probably not, if i understand correctly snakeman's problem was related to a caching issue on his CDN. excluding lyte-min.js from cdn or flushing the cache should do the trick.

  8. camafive
    Member
    Posted 1 year ago #

    Ok, flushing the cache didn't do anything, so i will try to exclude lyte-min.js, so i have to exclude this url---> http://web.com/wp-content/plugins/wp-youtube-lyte/lyte/lyte-min.js ??

  9. Snakeman
    Member
    Posted 1 year ago #

    futta was right, cloudflare was not the problem!

    the amazon cdn cloudfront was the problem i exclude the lyte-min.js with w3tc from cloudfront and the problem was solved

  10. camafive
    Member
    Posted 1 year ago #

    :( i tried flushing the cache from wordpress and nothing happens, i've excluded lyte-min.js and nothing happens :( help me please.

    example link

    http://tripeomusic.info/d-vega-lo-que-pase-aqui-official-preview-dvega_music/

  11. Snakeman
    Member
    Posted 1 year ago #

    on your example link i see that lyte is working!

    probably you must clear your system cache =)

  12. camafive
    Member
    Posted 1 year ago #

    So you can play the video?

    Edit: Now i see is Google Chrome, because i tried with Firefox and it works

  13. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Morning Camafive;
    I'm afraid you have a problem with one of your ad partners; with adblock enabled in Chrome, the LYTE video is present, without adblock it does not work. Lots of errors in the console as well, in that case.

    Hope this helps,
    frank

  14. camafive
    Member
    Posted 1 year ago #

    Hi, now i see, thanks, but is there a div id? or a class for the player to place with my ad partner to exclude the player? the problem is that my ad partner is showing ads in the title of the video player

  15. camafive
    Member
    Posted 1 year ago #

    Thanks for your help man, i excluded this Id "lyte-wrapper" from my text ads partner and it works like a charm

  16. TCNina
    Member
    Posted 11 months ago #

    Hi,

    I got the same problem, only a dark grey screen shows up. De-activating my adblocker and / or cleaning the cache didn't solve the problem.

    I'm searching for a YT-plugin for about 5 hours, now I'm tired.

    WP-Version is 3.6 and I'm using FF 23.0.1 (as you can see, browser, wordpress and plugin are the latest versions)

    http://true-crime.info/tv-archiv/medical-detectives-geheimnisse-der-gerichtsmedizin/

    Hope you can help.

  17. Frank Goossens
    Member
    Plugin Author

    Posted 11 months ago #

    I'm on holiday, so can't test now. I can look in to this next week, but the problem is more then likely caused by a plugin's java script, so systematically disabling plugins should help you identify the culprit.

  18. TCNina
    Member
    Posted 11 months ago #

    Hi,

    yeah, got it. I used other plugins to create spoilers and they disturbed the video shorttags, so I had to decide what to use, vids or spoilers, and I chose the videos.

    It's a pity for in earlier wp- or / and mysql /php versions they both worked.

    Thanks and happy holidays.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.