WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
Black Screen and no backup when run BackWPup (9 posts)

  1. m@gik
    Member
    Posted 2 years ago #

    Black Screen and no backup when run BackWPup

    http://wordpress.org/extend/plugins/backwpup/

  2. xclamation
    Member
    Posted 2 years ago #

    I'm getting this on one of my installations too. WordPress 3.4 and BackWPup Version 2.1.11.

    Upon running the job from the 'Jobs Overview', the backup tries to start but I get a Black screen with no output or activity.

    Any ideas?

  3. m@gik
    Member
    Posted 2 years ago #

    seems to be a recurrent problem, according to the offical forum.
    Everybody is waiting for 3.0 release.
    Maybe we could help daniel in the developement !

  4. xclamation
    Member
    Posted 2 years ago #

    Just done a little testing and found that if I deactivate, uninstall then re-install the plugin it appears to work again.

    I recently moved my WordPress site from a local development machine to the live server so perhaps this is what caused the problem?

  5. fdq
    Member
    Posted 2 years ago #

    I have the same problem as xclamation. Moved the website from the testing environment to the productive server (other hosting provider) and now no backups are created, the log files are empty and a blank output screen is shown.

  6. Ov3rfly
    Member
    Posted 1 year ago #

    Had a similar problem with a production server. You can try this:

    1. Upload this code as test.php on your production server. Replace http://www.example.com/ with your site.

    <?php
    $mysite = "http://www.example.com/";
    error_reporting(E_ALL & ~E_NOTICE);
    ini_set('display_errors', TRUE);
    $html = file_get_contents($mysite);
    if ($html !== false) {
    	echo htmlentities($html);
    } else {
    	echo "No data from $mysite";
    }
    ?>

    2. Open http://www.example.com/test.php in your browser. Replace http://www.example.com/ with your site.

    Does something like this appear?

    Warning: file_get_contents(http://www.example.com/): failed to open stream: Connection refused in /...
    No data from http://www.example.com/

    3. If yes, add this line define('ALTERNATE_WP_CRON', true); in wp-config.php, then manually start the job in backend.

    4. Now BackWPup probably works, but only manually!

    It's a problem of production servers behind firewalls, load balancers or similar, they can't access the own site via http.

  7. haleeben
    Member
    Posted 1 year ago #

    Adding define('ALTERNATE_WP_CRON', true); in wp-config.php worked for me, thanks for the tip.

  8. Marcelo Pedra
    Member
    Posted 1 year ago #

    @Ov3rfly: I've tested the PHP script you provided and my server didn't fail to show the results. But Backwpup is failing anyway.

    Although, after setting define('ALTERNATE_WP_CRON', true); in wp-config.php worked fine, when executing manually.

  9. Marcelo Pedra
    Member
    Posted 1 year ago #

    SOLUTION FOUND!
    There is some strange issue with cURL php script in WordPress that is causing long delays in the cron processes. I was able to solve the issue with BackWPup by installing Core Control plugin, and using it to deactivate usage of cURL in WordPress.
    I don't know for sure if it can cause new different issues, but this setting managed to workaround the backwpup issue.

    It is not an ideal scenario, but this workaround worked fine for me. I Hope Daniel can provide some feedback about taking care of this new issues in the next version of this awesome script.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.