WordPress.org

Ready to get started?Download WordPress

Forums

Bizarre Behavior - Not Working- GoDaddy Hosting (19 posts)

  1. dreamwhisper
    Member
    Posted 5 years ago #

    Can anyone verify that WP Super Cache works on GD Linux Deluxe Shared Hosting as it is supposed to? And, if necessary, what modifications need to be made?

    On the surface, it appears to work. I see this on the first page load:

    <!-- Dynamic page generated in 0.779 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2009-04-16 09:55:51 -->

    and this on the second:

    <!-- Dynamic page generated in 0.779 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2009-04-16 09:55:51 -->
    <!-- Compression = gzip -->

    I have checked the headers using the plugin for firefox, in which WP-Super-Cache: WP-Cache is there.

    However, YSlow reports that it is not gzipped. I tried using a couple online, which also report the same.
    http://www.whatsmyip.org/mod_gzip_test/
    http://nontroppo.org/tools/gziptest/
    http://www.seositecheckup.com/html_compression_status.php

    I will also add that I am having this problem on 3 sites, each hosted within a separate hosting account. I have WP-Cache running on one site on one of those accounts that reports being served as gzipped. So, WP-Cache is working and WP-Super-Cache is not. The sites with Super Cache never had WP Cache installed.

    I also tried using the ismyblogworking.com link and got this:
    The important stuff:

    * Your web server [IP] is working fine.
    * Your RSS feed is available.
    * Your blog is not indexed by Google. (it is)
    * Your blog seems slow. It took 4.91 seconds to generate the page.
    * Your blog application doesn't support gzip compression.
    * Your blog doesn't support client caching (no 304 response).
    * WP Super Cache is active.
    * Your feed doesn't support caching (no 304 response).

    So, even though it appears to report that it is working, it doesn't appear to actually be serving cached files or gzipped files.

    I tried it with the WP-Cache enabled blog and:
    * Your web server [IP] is working fine.
    * Your RSS feed is available.
    * Your blog is indexed by Google.
    * Your blog supports client caching (304 response).
    * Your feed supports caching (304 response).

  2. dreamwhisper
    Member
    Posted 5 years ago #

    I should also mention that the version is 0.9.3.1 (latest) the rewrite rules are in place and I also tried altering:

    AddEncoding gzip .gz
     AddType text/html .gz

    to

    AddEncoding x-gzip .gz
     AddType text/html .gz

    And, why this didn't end up in the proper forum, I have no idea. it should be in the plugins forum :-)

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    dreamwhisper - what happens if you turn wp-super-cache to half-on mode?

    I don't know why it's not working for you and I don't have a Dreamhost account to figure out why it's not working.

  4. dreamwhisper
    Member
    Posted 5 years ago #

    Actually, the host is GoDaddy.
    Half on gives this (feedburner is now running the feeds).
    The important stuff:
    * Your web server [72.167.168.61] is working fine.
    * Your RSS feed is available.
    * Your blog is indexed by Google.
    * Your blog seems slow. It took 2.08 seconds to generate the page.
    * Your blog application doesn't support gzip compression.
    * Your blog supports client caching (304 response).
    * WP Super Cache is active.
    * Your feed supports caching (304 response).

    Full On:
    The important stuff:
    * Your web server [72.167.168.61] is working fine.
    * Your RSS feed is available.
    * Your blog is indexed by Google.
    * Your blog seems slow. It took 1.84 seconds to generate the page.
    * Your blog application doesn't support gzip compression.
    * Your blog doesn't support client caching (no 304 response).
    * WP Super Cache is active.
    * Your feed supports caching (304 response).

    I could give you FTP to a test blog.

  5. dreamwhisper
    Member
    Posted 5 years ago #

    still getting this even on brand new install for a different domain. :-(

  6. uncatim
    Member
    Posted 5 years ago #

    Any new thoughts on this topic?
    I'm having the same problem. Hosted on iPower.

    Your web server [66.96.131.xxx] is working fine.
    Your RSS feed is available.
    Your blog is indexed by Google.
    Your blog seems slow. It took 2.42 seconds to generate the page.
    Your blog application doesn't support gzip compression.
    Your blog doesn't support client caching (no 304 response).
    WP Super Cache is active.
    Your feed doesn't support caching (no 304 response).
    Your blog is a self-hosted WordPress blog

    <!-- Dynamic page generated in 1.117 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2009-06-16 07:37:02 -->
    <!-- Compression = gzip -->

    MakeMeThinner.Com
    Thanks for your input.

  7. uncatim
    Member
    Posted 5 years ago #

    Additional Info:
    This might give you some more clues.
    Header Check:

    HTTP/1.1 200 OK =>
    Date => Tue, 16 Jun 2009 15:36:29 GMT
    Content-Type => text/html; charset="UTF-8"
    Connection => close
    Server => Apache
    Vary => Cookie
    Set-Cookie => PHPSESSID=5eb67cc244e771956b83619f6c14d2d5; path=/
    Expires => Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control => no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma => no-cache
    X-Pingback => http://makemethinner.com/xmlrpc.php
    Content-Length => 51787

  8. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Try the development version from the download page. Delete the .htaccess rules so the plugin will regenerate them.

    Does that help?

  9. uncatim
    Member
    Posted 5 years ago #

    Thanks donncha,
    I'll give it a whirl and report back.
    Tim

  10. uncatim
    Member
    Posted 5 years ago #

    You mean the dev version of Super Cache?
    I've got 9.4.3

  11. merid
    Member
    Posted 4 years ago #

    I have this exact same problem. did anyone find the solution?

  12. ecastano
    Member
    Posted 4 years ago #

    @donncha

    I have the same problem, half and full get the same: the files are created but not served.

    I tried to use the dev version as well as the production one, I also deleted the .htaccess rules (the plugin regenerated the rules), without luck.

    As dreamwhisper I'm hosting the site in GoDaddy.

    I'd love to help in order to solve this problem, so if you want me to check anything, please tell me!

    thanks in advance,
    emiliano

  13. asjbak
    Member
    Posted 4 years ago #

    Here the same problem,

    Generated, not served! :(

  14. asjbak
    Member
    Posted 4 years ago #

    Maybe this is the solution: Worked for me:

    1.
    </html>
    <?php while (ob_end_flush()) {} ?> (must be in your footer or header file)

    2.
    Turn on $use_flock = true;
    in your wp-cache-config

    Hope this will work for you also!

  15. Donncha O Caoimh
    Member
    Posted 4 years ago #

    askbak - sounds like another plugin is using the output buffer and not closing it properly!
    You can turn off coarse locking completely now(the default is off) so you won't need to change the $use_flock setting.

  16. merid
    Member
    Posted 4 years ago #

    What I have found is that godaddy doesnt support gzip. look here: http://www.thetechtalkblog.com/wordpress/godaddy-gzip-support/

  17. Donncha O Caoimh
    Member
    Posted 4 years ago #

    merid - wp-super-cache doesn't use either of mod_gzip or mod_deflate. It does it's own gzipping and stores the gzipped cache page.

  18. jwarren
    Member
    Posted 4 years ago #

    Hey, I spent a couple of hours hacking away at this, and finally got it working.

    OKAY! SO!

    I used the instructions here to enable compression. I have PHP5 running on my client's account, so I went to their root directory, created a php5.ini file, and pasted in

    output_buffering = On
    output_handler = ob_gzhandler
    zlib.output_compression = Off

    I believe if you're using PHP4, then you need to name it php.ini, but don't quote me on that!

    Anyway, after that, it seemed to work perfectly. I tested it at http://ismyblogworking.com, whatsmyip and YSlow.

    This still doesn't help for gzipping the CSS and JS, but it's a definite start.

    I hope that helps!

  19. stvbaker
    Member
    Posted 4 years ago #

    I also have ismyblogworking.com telling me that my site is not enabled for Gzip compression, even though I have WP Super Cache operating in Full mode. I found this site that tells how to turn gzipping on (it's a very simple solution):
    http://wpbloghost.com/blog/gzip-compression/

    He recommends that you check your site at http://www.port80software.com/support/p80tools.asp

    When I run my site - without any change - on port80software, it tells me that gzip compression is working, in direct contradiction of ismyblogworking.com.

    It occurs to me that ismyblogworking is checking the wrong thing when a blog is using WP Super Cache. Donncha says above that his plugin uses its own gzipping, which perhaps turns off the standard WP or PHP gzipping process. It is possible that, when you "fix" this problem identified by ismyblogworking, you are actually duplicating Donncha's process.

    Any thoughts?

    Steve

Topic Closed

This topic has been closed to new replies.

About this Topic