WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Biographical Information cannot contain image tags (6 posts)

  1. mike
    Member
    Posted 5 years ago #

    I am trying to add biographical information to a user's profile that includes the <img ... /> tag, but it keeps getting stripped (I assume strip_tags() is doing it). Why can't I add images to the biographical information section? I really don't want to edit core files or write a plugin.

  2. mike
    Member
    Posted 5 years ago #

    Anyone? I don't think that this is a bug, but it would be nice if one could include images in the bio field for users. I remember years ago when a response on this board took 5 mins.

  3. moshu
    Member
    Posted 5 years ago #

    And I rememeber that it has been posted N+1 times: you cannot use html tags in the user profile. Period. That's how it was done by the devs.

    There is a slight chance that somebody figured out a solution and, eventually, posted it to the forum - but you will have to search for it.

  4. mike
    Member
    Posted 5 years ago #

    Thanks for the reply. However, you can put in "a" tags and italics, so there must be an explicit setting for images. I will check the core files for the line of code.

  5. mike
    Member
    Posted 5 years ago #

    I believe that this can be modified by messing with the global variable $allowedtags in kses.php. Any help with this so that I don't have to mess with core files? I can't find a plugin that does it (yes, I searched!)

  6. mike
    Member
    Posted 5 years ago #

    Solution (though ugly):

    - download http://www.cimatti.it/blog/2007/02/12/cimy-user-extra-fields-for-wordpress-21/
    - add an extra field called "FULLBIO"
    - turn on the get_cimy function
    - add the following in your template:

    if(is_single()) { echo "<hr>"; echo get_cimyFieldValue(get_the_author_ID(), 'FULLBIO'); echo "<br /><br />";}

Topic Closed

This topic has been closed to new replies.

About this Topic