WordPress.org

Ready to get started?Download WordPress

Forums

Bing Webmaster Center + Sitemap.xml (7 posts)

  1. prestone
    Member
    Posted 2 years ago #

    Hi,

    I'm not sure if this is the right section or not, but I'm having a slight issue (maybe not really an issue) with my sitemap with WordPress.

    I'm using the plugin called "XML Sitemap Feed" which says its compatible with Google, Bing, Yahoo!, etc. but when I submit my sitemap to Bing Webmaster Center it shows up as 'Errors have occurred' and when I click on the sitemap link is says Bing encountered 'Unknown error' while processing my sitemap.

    I'm not sure if it's a problem with the way the plugin is structuring the file or with Bing itself, but it seems my Sitemap isn't working at the minute.

    Here's a link to my sitemap.xml file:

    http://www.atopic-dermatitis-treatment.com/sitemap.xml

    Is that how it's supposed to look?

    Also if you have a suggestion for another Sitemap plugin that doesn't throw errors, I'd love to hear them

  2. Samuel B
    moderator
    Posted 2 years ago #

    http://wordpress.org/extend/plugins/google-sitemap-generator/
    is this the one you use? It works well with me - Bing included

    also, that's a normal looking site map these days

  3. prestone
    Member
    Posted 2 years ago #

    Unfortunately, no. :(

    The one I've been using is this one:

    http://wordpress.org/extend/plugins/xml-sitemap-feed/

    I will give the one you posted a try. Hopefully that will fix everything.

  4. RavanH
    Member
    Posted 2 years ago #

    Hi Prestone, I cannot reproduce the error. Does Bing not provide any more info about it? The sitemap complies with xml sitemap rules. So it might be something else like during the last check your site was temporarily unavailable... Does the error message persist after re-submitting the sitemap?

    One thing I would like to suggest is to try the development version of XML Sitemap Feed.

  5. prestone
    Member
    Posted 2 years ago #

    Hi RavanH,

    I am still using the old plugin as I had submitted the Sitemap again after I created this thread just to see what would happen. It's showing up as 'Pending' in Bing now with the type being 'Unknown,' I'm not sure how long it will take their spider to crawl it, but I'll update this thread if the problem persists or I get more info on it.

    Thanks for checking it out.

  6. prestone
    Member
    Posted 2 years ago #

    Hi RavanH,

    I resubmitted the Sitemap.xml file to Bing and it came back with 'Success' and 'No problems or errors found.'

    I guess it was just an intermittent issue with Bing rather than the plugin or file structure.

    Thanks for your help guys.

  7. RavanH
    Member
    Posted 2 years ago #

    Well, that's a relief ;)

    I've noticed Bing can take a really long time to revisit a sitemap after re-submission. So thanks for your patience and reporting back on this.

    Oh... could you mark this thread as resolved please?

Topic Closed

This topic has been closed to new replies.

About this Topic