WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Bigger & Slower (40 posts)

  1. acp73
    Member
    Posted 1 year ago #

    Done! :)

    I think I've come a long way since starting with this plugin... though I am not too technical and savvy with all this techy stuff!!!

  2. acp73
    Member
    Posted 1 year ago #

    OMG!!!! I think I'm gonna lose the plot!
    Suddenly today I keep getting HTTP 500 errors and my site hardly loads....
    Just about can't get into my admin it's THAT bad & when I manage to get in I get this error message:
    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.
    WTF!!
    Somebody shoot me please :) .... or some advise maybe! :))

  3. alpha4
    Member
    Posted 1 year ago #

    If this is plugin related, deleting the plugin folder should resolve the issue and bring your site back.

  4. acp73
    Member
    Posted 1 year ago #

    But I don't want to delete the plugin becuase it has been working SO WELL!!!!

  5. acp73
    Member
    Posted 1 year ago #

    I just deactivated the plugin (still version 0.9.2.5) and the load time decreased from 32 seconds to 5 seconds.
    Strange yesterday it was really fast and performing well....

  6. acp73
    Member
    Posted 1 year ago #

    Sorry to be back again! I am totally useless at all this :)

    Checking out some loading stats on PINGDOM and notices 3 files which are the culprits with the longest wait times and don't recall them being there before.

    http://www.anthonypeyper.com/?staticfile=masthead.js&cb=1360698876811
    http://www.anthonypeyper.com/?staticfile=script.js
    http://www.anthonypeyper.com/?staticfile=style.css

    Just wondering if I can reset minify in some way or reset the complete app or uninstall and reinstall it from scratch now that I know a little better what I am doing ( ONLY A LITTLE BETTER)

    What are the best settings to use for Minify? I see in the help option that there are blocking and non-blocking options and positions to minify before/after head etc...

    Maybe this is where I messed up!

    ps: sorry about the WTF earlier...didnt mean it as a curse i'm just frustrated with myself :)

  7. noisegate95
    Member
    Posted 1 year ago #

    @acp73
    Looking at your source, you are using disk "enhanced" for page cache. Change that to Disk "basic". Also disable database and object cache.

    As for Cloudfront: I was always under the impression that Cloudfront needed to pull from somewhere. Not needing S3 with Cloudfront doesn't sound right to me, but I could be wrong.

    You basically setup an S3 bucket, Setup your CNAME's, (cdn.yoursite.com, cdn1.yoursite.com), then setup Cloudfront and W3. Depending on your W3 config, you can either push (manual) or pull (auto) your content.

    A user will go to your site, W3 will direct them to Cloudfront - Cloudfront will pull the content from S3 and serve it to the user.

    There are many sites that will assist you in getting W3 working with CLoudfront.

  8. wp-fan
    Member
    Posted 1 year ago #

    Not needing S3 with Cloudfront doesn't sound right to me

    I can fully confirm I use cloudfront successfully without S3. It pulls the files directly from wordpress and stores them in the cloud, in my experience there is no need to use a S3 bucket at all.

    Looking at your source, you are using disk "enhanced" for page cache. Change that to Disk "basic". Also disable database and object cache.

    I agree here.

    Why the behaviour of your setup should change all over sudden is yet unclear to me. is there anything you did or changed?

    BTW, just checked your front page via browser and pingdom tools. Everything looks like normal to me.

  9. acp73
    Member
    Posted 1 year ago #

    Thanks for the tips guys! Made the change as suggested... (disk basic)

    I uninstalled and reinstalled the plugin and it seems better now. Not sure what happened - all i did was update my blog and noticed that front page categories was no longer working so I deactivated and deleted the plugin.

    The today noticed my site being super slow and could hardly get into my admin panel and most of the time any actions would freeze and no sections load (admin).

    I somehow have a feeling that it might be related to Godaddy servers...I definitely want to look into getting onto better hosting.

    Thanks again to everybody for helping ... I think I am done before I lose anymore sleep over this... not to mention my head exploding!

    :)

  10. acp73
    Member
    Posted 1 year ago #

    Perfect update to latest version 0.9.2.8!!!
    Only had to configure 1 setting: Page Cache defaut was "enhanced" and had to change it to "basic".
    Thanks Frederick!!!!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.