WordPress.org

Ready to get started?Download WordPress

Forums

Diginews
Big Red First Letter - My is gone? (7 posts)

  1. jackholland
    Member
    Posted 1 year ago #

    Hi, not sure what happened but I lost the big red first letter that appeared in my posts? Any ideas?

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Without seeing the site, impossible to offer much in the way of specific help. But first letter is often styled in the CSS with pseudo-element -- for example:

    p:first-letter  {
       color:#ff0000;
       font-size:xx-large;
    }

    http://www.w3schools.com/css/css_pseudo_elements.asp

    So check your CSS -- Firebug is a useful tool for that kind of thing. Also make sure you don't have CSS or Mark-up errors causing that problem by validating your pages:

    http://codex.wordpress.org/Validating_a_Website

  3. jackholland
    Member
    Posted 1 year ago #

    Thanks for the response. Site is thelastamericannewspaper.com

    I have figured out that the big red letter disappears only when I add a photo at the top? Got a work around in your hat?

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    It looks like what is happening is that your image is inside the paragraph tag -- so then the text is not getting the CSS style that it would if the image was not there -- look at your HTML:

    <p style="text-align: justify;">
    <img width="612" height="429" src="http://thelastamericannewspaper.com/wp-content/uploads/2012/11/No_Gun_Ri_bridge-1960-1024x718.jpg" alt="Bridge at No Gun Ri ">
    At No Gun Ri, over 300 Korean civilians were slaughtered by U.S. ground forces using machine guns and rifles along with strafing and bombing by pilots of the U.S. Air Force using Lockheed P-80s configured as the F-80 and known as the shooting stars.

    So try taking the image out of the p tags or starting a new p for the text.

  5. WPThemes.co.nz
    Member
    Posted 1 year ago #

    Hi @jackholland,

    did @WPyogi answer your question right? is everything good? Let us know so we can help :)

  6. jackholland
    Member
    Posted 1 year ago #

    I did as instructed to no avail. How about a theme fix to correct this.

  7. WPThemes.co.nz
    Member
    Posted 1 year ago #

    Hi @jackholland, the big red first letter only appears if the first line of your page is text and not an image.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.