WordPress.org

Ready to get started?Download WordPress

Forums

big problem with url (4 posts)

  1. Theeponymus
    Member
    Posted 1 year ago #

    Hello,
    I have a problem that i can not resolve and need some help.
    I have few blogs with wordpress and multisite option enable with configuration folder http://www.mainsite.com/secondaryblog/ .

    for all my sites i use domain mapping to have secondaryblog.mainsite.com
    it works good !
    i use sunrise.php | and domain mapping plugin without problem.

    but now when i create a new blog and want :
    http://www.mainsite.com/newblog i have a problem. It create the blog when i want to connect to dashbord http://www.mainsite.com/newblog/wp-admin i connect to the good url but with the data of http://www.mainsite.com

    You understand ! i ve tried lot of things but can not resolve this problem.

    any help ?

    thx a lot

  2. Domain mapping won't redirect a site unless you've mapped it, so did you do any mapping on the new site?

  3. Theeponymus
    Member
    Posted 1 year ago #

    in my actual configuration : i did not map the new site (but tested in mapping config with the same result).

    in fact, http://www.mainsite.com grab secondary blog.
    ie
    http://www.mainsite.site/newsite/ -> go to the right url but with the content of http://www.mainsite.com ...idem with dashbord.

    i've taken a look to .htacess (seems right).
    my actual wp-config /

    define('SUNRISE', 'on');
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.mainsite.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    ---
    .htaccess -> with the default multisite options
    and idem with domain mapping

    the only thing thahT i can tell you, I ve changed one day DOMAIN_CURRENT_SITE .

    frankly speaking, i don't why it works not good. It is out of my knowledge ;-)

    thx a lot

  4. i did not map the new site (but tested in mapping config with the same result).

    No... That's not how it works. I mean it is, but only becuase you're half-way there.

    1) Park the domain (secondsite.com) on your server to mainsite.com - This will make mainsite's content show up when you go to second site. This is OKAY! :)

    2) Within WP, map secondsite.com to mainsite.com/secondsite

    3) Drink beer.

    Until you do 1 and 2, it won't work.

Topic Closed

This topic has been closed to new replies.

About this Topic