WordPress.org

Ready to get started?Download WordPress

Forums

Big problem with bad links (16 posts)

  1. Martin
    Member
    Posted 1 year ago #

    I've really messed up and I just don't know where to begin trying to fix this problem.
    After creating my site, http://www.thericepost.com, a couple of weeks ago, using the Oxygen theme, I wanted to experiment with some different themes.

    I cloned my thericepost folder on my server at Bluehost and played around there with the different themes. I could get to see it online at judyandmartin.com/trp.old. trp.old was what I named the experimental folder. Everything seemed to work ok, that is, I could experiment with trp.old and look at it online while, at the same time, I could make new posts at thericepost.com.

    Then I noticed two problems: first, for people who subscribed to email updates to new posts, the link that was in the email notification went to trp.old instead of to thericepost. That is, the short link at the foot of the email notification, not the link that was in the post's title, which was accurate.

    In addition, the SEO plugin that lets me send a tweet from the new post page in WP was also generating a link that led to trp.old. Of course these links -- in the tweet and in the email, led to an error online because the links' target was not on trp.old but on thericepost.com.

    So I simply deleted the entire trp.old folder from my server. I figured I could experiment some way later.

    Now, however, the email notifications and the tweets are still generating links that try to go to trp.old. Of course if you go to these you get a 404 error. I can deal with the tweets by simply editing the link before I send it -- it's a pain but it works. I can't do anything about the bad link generated in the email notification.

    Can anyone tell me what's going on and, more importantly, what I can do to fix this?

    Thanks,
    Martin

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    I cloned my thericepost folder on my server at Bluehost and played around there with the different themes.

    Did you also clone and edit the database appropriately? See Moving_WordPress for the correct way to clone a site.

    Have you tried deleting & re-installing the plugins that are now causing errors?

  3. Martin
    Member
    Posted 1 year ago #

    Thanks, esmi. I really think that I did clone and edit the db correctly, though I'll read the Moving_WordPress article for next time.

    I'll try the idea of deleting and re-installing the plugins right away and report back. Thanks!

  4. Martin
    Member
    Posted 1 year ago #

    Well, no joy. I did delete and re-install the plugins and that didn't make any difference. (I'm pretty sure that I did it with the correct plugins and did not miss something. But I can't be 100% sure.)

    I also went to the SQL databases on the server and got rid of the one I created when I cloned the site.

    But that judyandmartin.com/trp.old reference is still in existence somewhere and I need to find it, but I'm afraid that I'm still too new at WP to really know where to look. I guess it could be in some .php file somewhere, but checking them out is a bit beyond me.

  5. Martin
    Member
    Posted 1 year ago #

    Just had something else happen and I'm hoping that from this message someone might be able to tell me where to go and how to fix the problem discussed above. I was commenting on http://www.thericepost.com on one of the posts. When I clicked the button to post the comment, I got the following message:
    ---------------------------------------------------
    The requested URL /trp.old/wp-comments-post.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache Server at http://www.judyandmartin.com Port 80
    ----------------------------------------------------
    So even though I had deleted the directory /trp.old/ the site is still using that for various things. Any suggestions for what to do?

    Thanks,
    Martin

  6. bhpress
    Member
    Posted 1 year ago #

    Have you changed your wp-url settings? Here are the basic steps on how to do it:

    You will want to change the default URL for the website when using WordPress's script.  This is configured when WordPress is installed. You can change this configuration in the database what the default URL is for your WordPress site.

      1)  In the cPanel, choose phpMyAdmin icon and, in left column, choose your WordPress *database.
      2)  Select the wp_options table on the left column.
      3)  Along the top, click the Browse tab.
      4)  There are two records to modify.  Record #1 (siteurl) and #39 (home) (these can vary, but unlikely).  For each, click the pencil icon to edit and change the option value to read the URL that you intend your links to display, such as http://domain.com.

    * = If you do not know the database's name, return to the cPanel and select the File Manager icon.  Navigate to the directory where the WordPress script is installed.  Select the 'wp-config.php' file and click the Edit button along the top to view the name.

  7. Martin
    Member
    Posted 1 year ago #

    bhpress, thank you so much for these detailed instructions. I followed them carefully (it turns out that the home record wasn't #39, but I found it. In both the site url and home records, the URL was correct. So since I was in there I used the search function on all the records in wp_options and I came up with this in the results:

    SELECT *
    FROM judyand1_wrd3.wp_options
    WHERE (
    CONVERT( option_id
    USING utf8 ) LIKE '%judyandmartin.com/trp.old%'
    OR CONVERT( option_name
    USING utf8 ) LIKE '%judyandmartin.com/trp.old%'
    OR CONVERT( option_value
    USING utf8 ) LIKE '%judyandmartin.com/trp.old%'
    OR CONVERT( autoload
    USING utf8 ) LIKE '%judyandmartin.com/trp.old%'
    )
    LIMIT 0 , 30

    Unfortunately (even though it's probably staring me right in the face) I can't figure out what record this is in and don't know where to change it. It's precisely that judyandmartin.com/trp.old that's the culprit.

    Any suggestions as to where I go to change this?

    Again, thanks so much!
    Martin

  8. bhpress
    Member
    Posted 1 year ago #

    Ok that is referencing multiple lines in the wp-options table. You will need to find those and remove the trp.old from the back.

  9. Martin
    Member
    Posted 1 year ago #

    Thanks again, bhpress. So far I was able to find one of the references and change it, but unfortunately that wasn't the one that's resulting in the wrong links. Of course I don't really know what I'm doing there in phpMyAdmin and am searching rather randomly. I've been staying in judyand1_wrd3.wp_options but still no joy in finding the other three.

    I guess I'll just have to stick with it, though I'm running out of ways to search in that I'm just blundering around.

    But it's a new day, so time to take a new try.

    Thanks again,
    Martin

  10. Starejosel
    Member
    Posted 1 year ago #

    I am a n00b, but could permalinks solve the problem?

  11. Martin
    Member
    Posted 1 year ago #

    Thanks. I've tried playing around with them as much as I can, but if it is the answer I haven't been able to figure it out yet.

  12. bhpress
    Member
    Posted 1 year ago #

    If it were permalinks you would be able to just go to the permalinks settings page, and click save. That would essentially make sure your .htaccess has the right code so that everything redirects properly. This would actually just be the database settings. You will also need to check the wp_posts table to see what entries there use the old folder.

  13. Starejosel
    Member
    Posted 1 year ago #

    Probably the pros would consider it an ugly hack, but you could try to rederict the bad links to the correct ones using the .htaccess file; I'm not knowledgeable enough to tell you what precisely to do, but I used
    RewriteRule author/([^/]+)/?$ http://yourwebsite/forums/users/$1/ [R=301,L]
    to change "href="http://[yourwebsite]/author/[xyz]", to
    href="http://[yourwebsite]/forums/users/[xyz]"

    So you would need to change references to trp.old to whatever they
    should be using this rule.

    I am using a plugin called htaccess control, and the discussion is
    here: http://forum.ternstyle.us/topic322-markup-question.html
    The writer of the plugin seems to be very knowledgeable, terse, and helpful.

  14. Martin
    Member
    Posted 1 year ago #

    bhpress and Starejosel, thanks for the answers. I've been playing around and I'm afraid that I'm just in too deep for what I know to do. I put up a post looking for someone to hire to help me but it was closed down because that type of post isn't allowed on the forum so I'm looking on the Internet for a consultant.

    Thanks again,
    Martin

  15. antonioandra.de
    Member
    Posted 1 year ago #

    Hey Martin,

    I tried getting back at you but the email address you provided when contacting me returned an Undelivered Error.

    Please provide a working address or write back using regular email.

    Antonio

  16. Martin
    Member
    Posted 1 year ago #

    Hi, Antonio,

    Sorry about the bad address, must have been a typo. You can get me at

    martin (at) thericepost (dot) com
    or
    martinrice1 (at) mac (dot) com

    Thanks,
    Martin

Topic Closed

This topic has been closed to new replies.

About this Topic