WordPress.org

Ready to get started?Download WordPress

Forums

Widget Logic
BIG PROBLEM: Warning: preg_match & Warning: implode (12 posts)

  1. chrisaudio
    Member
    Posted 10 months ago #

    Dear Developer-Team,

    after the last update three days ago to the version 0.56 I recognized the following massiv errors:

    Warning: preg_match() [function.preg-match]: No ending delimiter '/' found in /wp-content/plugins/widget-logic-by-path/widget_logic_by_path.php on line 75

    Warning: implode() [function.implode]: Invalid arguments passed in /wp-content/plugins/widget-logic-by-path/widget_logic_by_path.php on line 79

    They are repeated several times in the site header, the sidebar an the footer.

    Please help me.

    Thanks a lot,
    Chris

    http://wordpress.org/plugins/widget-logic/

  2. chrisaudio
    Member
    Posted 10 months ago #

    Would u need more info to answer my request= Please let me know. thx

  3. irrer-drongo
    Member
    Posted 10 months ago #

    Same problem here. got a solution? except deactivation, of course. It did not work simple upload the old 0.55 version.
    widget_logic_by_path had already an update to work with 0.56.

  4. chrisaudio
    Member
    Posted 10 months ago #

    Got the same config. Also with widgetlogic by path. Hopefully we two guys get feedback soon, because I couldn't provide a solution yet ...

  5. ABCDiamond
    Member
    Posted 10 months ago #

    I've just installed widget logic and I get the same problem.

    However, I am hitting problems similar to this on all my WP 3.6 sites. My 3.5 sites are OK.

    But I now have 4 plugins that are giving these warnings in the site header.

    Deactivation of plugins like this appears to be my only option right now. But I am not sure it is the plugins fault. The best advice from WP is to only use plugins that are 100% compatible :(

  6. chrisaudio
    Member
    Posted 10 months ago #

    Hey guys, let's try something. Without telling the exact domain, please write down your plugin arrangement / setup completly (only activated plugins) to try to find the same issues.

    Here's my:

    Advanced Page Manager
    Broken Link Checker
    Contact Form 7
    Google Analytics for WordPress
    Google Plus Authorship
    Kwayy HTML Sitemap
    Lightbox Plus ColorBox
    Permalink Editor
    Really Simple CAPTCHA
    SEO Auto Linker
    SlideShare
    Social
    Ultimate Posts Widget
    Widgetkit
    Wordpress Plugin Framework Reloaded
    WordPress SEO
    WP Permalauts

    Got it?

  7. irrer-drongo
    Member
    Posted 10 months ago #

    okay:

    Akismet
    Collapsing Archives
    Custom Field List Widget
    Lightbox Plus ColorBox
    Multilang Contactform
    qTranslate
    qTranslate slug
    Share Buttons by AddToAny
    Simple Vimeo Shortcode
    Super Tags Widget
    Ultimate TinyMCE
    Widget Logic
    Widget Logic by Path
    WP Geo

  8. ABCDiamond
    Member
    Posted 10 months ago #

    Being a new install, I only have a few on this site:

    Akismet : Version 2.5.9
    Child Themify : Version 1.0.1
    Contact Form 7 : Version 3.5.2
    Jetpack by WordPress.com : Version 2.3.5
    List category posts : Version 0.30.3
    OCWS Admin Bar Greeting : Version 1.2
    Really Simple CAPTCHA : Version 1.7
    Search & Replace : Version 2.6.5
    UpdraftPlus - Backup/Restore : Version 1.7.3
    WordPress Importer : Version 0.6.1

  9. irrer-drongo
    Member
    Posted 10 months ago #

    Mmh, I have nothing of yours, ABCDiamond. So it does not seem to be a problem with a specific plug-in. What is your error message?

  10. chrisaudio
    Member
    Posted 10 months ago #

    In common we do not have a single plugin alltogether. Shouldn't there be some more people with that problem?

    These two are my errors:

    Warning: preg_match() [function.preg-match]: No ending delimiter '/' found in /wp-content/plugins/widget-logic-by-path/widget_logic_by_path.php on line 75

    Warning: implode() [function.implode]: Invalid arguments passed in /wp-content/plugins/widget-logic-by-path/widget_logic_by_path.php on line 79

    If I switch off Widgetlogic by Path single the error returns that:

    Parse error: syntax error, unexpected T_STRING in /wp-content/plugins/widget-logic/widget_logic.php(284) : eval()'d code on line 2

    Parse error: syntax error, unexpected '/' in /wp-content/plugins/widget-logic/widget_logic.php(284) : eval()'d code on line 1

    The code says in that doc an that line: Nothing ... I cannot understand the error at all - I have to reasearch that.

  11. chrisaudio
    Member
    Posted 10 months ago #

    Thats' to hard for me. Sorry guys. I'll have to wait for the developer to reply to this errors.

  12. irrer-drongo
    Member
    Posted 10 months ago #

    Okay. I got help in the widget logic by path support board.

    I had to remove the following pathes:
    /author/*
    /page/*
    I do not need them anyway (anymore?).
    Maybe you delete some pathes in your widgets and try what is working and what not.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.