WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Big problem suddenly with external images! (12 posts)

  1. AmpLiF1eR
    Member
    Posted 2 years ago #

    My blog is http://strictlyhonest.com.

    The external images in the main area suddenly don't update anymore.
    If the source of the external image is "http://www2.nict.go.jp/y/y223/simulation/realtime/images/latest" , it changes nowadays to "http://strictlyhonest.com/wp-content/uploads/2011/08/latest6" , it suddenly changes the source after saving the page to a local image , making my blog useless for monitoring.

    This was never the case, is this solvable or do I need to downgrade WP or something.

    Please help.

    Many thanks in advance!

  2. AmpLiF1eR
    Member
    Posted 2 years ago #

    this problem is really a disaster

  3. AmpLiF1eR
    Member
    Posted 2 years ago #

    I will try to explain it more detailed:

    if I have put this:
    <p style="text-align: center;"><img class="aligncenter" title="Magnetosphere Realtime" src="http://www2.nict.go.jp/y/y223/simulation/realtime/images/latest" alt="" width="550" height="480" />Copyright@NICT</p>

    it changes to this:
    <p style="text-align: center;"><img class="aligncenter" title="Magnetosphere Realtime" src="http://strictlyhonest.com/wp-content/uploads/2011/08/latest11" alt="" width="550" height="480" />Copyright@NICT</p>

    the link of the sources changes from external to a local copy which is not desired.
    This is happening since an update of wordpress because a member told me the images didn't update anymore, I wasn't aware of this change

  4. AmpLiF1eR
    Member
    Posted 2 years ago #

    not found a solution yet

  5. AmpLiF1eR
    Member
    Posted 2 years ago #

    Am I really the only one using external images on purpose to monitor changes ?

  6. AmpLiF1eR
    Member
    Posted 2 years ago #

    it should be:

    <p style="text-align: center;">USGS Earthquakes M2.5+ (click image to see list)</p>
    <p style="text-align: center;"><a href="http://earthquake.usgs.gov/earthquakes/recenteqsww/Quakes/quakes_all.php"><img class="aligncenter" title="World Recent Earthquakes (Click for all M2.5+ earthquakes)" src="http://earthquake.usgs.gov/earthquakes/recenteqsww/Maps/world_moll/world_moll.gif" alt="" width="550" height="" /></a></p>

    src changes after saving to:

    <p style="text-align: center;">USGS Earthquakes M2.5+ (click image to see list)</p>
    <p style="text-align: center;"><a href="http://earthquake.usgs.gov/earthquakes/recenteqsww/Quakes/quakes_all.php"><img class="aligncenter" title="World Recent Earthquakes (Click for all M2.5+ earthquakes)" src="http://strictlyhonest.com/wp-content/uploads/2011/08/world_moll5.gif" alt="" width="550" height="" /></a></p>

    [Please post code snippets between backticks or use the code button.]

  7. AmpLiF1eR
    Member
    Posted 2 years ago #

    is it the update to 3.2.1 that caused this change ? my blog is to complex to install again. do I need to downgrade ?

  8. AmpLiF1eR
    Member
    Posted 2 years ago #

    arghhh

  9. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    How are you adding your images? I have tried this on a test site and am unable to reproduce the behaviour you have described.

    In the text editor I placed the cursor where I wanted to place an image then added an external image by clicking the add an image link in the media buttons, selected add from URL, filled in the Image URL, Image Title & Alternate Text etc then clicked Insert into post.

    Everything worked as expected - the image did not change to a local copy and the path did not change.

    If this is not the same process you used can you describe your method?

  10. AmpLiF1eR
    Member
    Posted 2 years ago #

    I've done the prccess like you described above more than a year ago.
    When I check the revisions of that page from months ago, all links are correct (no local copies), but when I activate that revision of the page with the correct links, they get replaced to local copies instantly as well, so it's really a puzzle.

    I've checked other posts on this forum and I've seen that plugins might cause problems in many situations. I will change the blog to maintenance mode later today and disable every plugin to check if there's a conflict and report back here.

    thanks in advance.

  11. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

    yes investigating plugins is the next step. Deactivate all plugins and test to see whether the problem disappears. Is so reactivate each plugin one by one testing to see whether the problem appears when any single plugin is activated.

  12. AmpLiF1eR
    Member
    Posted 2 years ago #

    thanks for your replies, I should have looked to other answers much sooner, I've found the problem, it was a plugin named Zemanta that probably had this feature after an update.
    problem solved :)

    I'm happy again!

Topic Closed

This topic has been closed to new replies.

About this Topic