WordPress.org

Ready to get started?Download WordPress

Forums

Big problem, something went wrong and I don't know what... (11 posts)

  1. ghanes14
    Member
    Posted 5 years ago #

    I decided to change the layout of my site today (the other one was kind of dull). Now I don't know what happened, but when my posts are clicked, or even other pages of the site it doesn't go to them.

    Top of the browser shows "Nothing found for Blog Index Php "permalink here". My site is http://all-notions.com you can go there and click a post or a page and see what it does.

    All I did after switching themes so far was add a few links to the footer, change the banner at top to Google Adsense, change the color of my RSS counter button, and edit the text in the gray box on top of the sidebar.

    I tried switching to a totally different theme and it does the same thing. I even uploaded the theme (StudioPress) again through the FTP software, still didn't fix it.

    Help, I was having a good day with traffic, now they won't be able to use the site!

  2. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    Switch to default theme and see if all posts are working there.

  3. Chris_K
    Member
    Posted 5 years ago #

    I'd say your Permalinks aren't working. Check that page for troubleshooting tips. In particular, confirm with your host that mod_rewrite and AllowOverride are both on and enabled.

    Out of curiosity, if you set your Permalinks to "Default" do they start working?

  4. ghanes14
    Member
    Posted 5 years ago #

    [mercime]

    I tried, it shows up with 404 error.

    [HandySolo]

    I will read it, not sure why it would be a problem with the permalinks though. The site worked great before I started editing the new theme, but I didn't change anything big.

    I set it back to default, unless it takes a period of time for it to activate, it still shows 404 error on default theme.

    Far as confirming with my host, how do I do that? I host my site with Yahoo, kind of a task to find a costumer service email though. I have been trying to remember the URL to sign into the MySQL database, but I can't remember it or find anything online neither.

  5. ghanes14
    Member
    Posted 5 years ago #

    Nearly 10 min later I tried again with permalinks still at default, and it appears to be working. But why wouldn't it work before...Does this mean all the links to my posts I have posted won't send people to the post anymore?

  6. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    Now that HandySolo's default solution worked for you, try setting the Permalinks to your previous custom permalink. Then clear cookies and cache.

  7. ghanes14
    Member
    Posted 5 years ago #

    Do you mean the cache and cookies in my browser, or in wordpress: Options>WP-Cache>Delete Cache?

  8. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    All and both. Then view website in another browser as well. Good luck.

  9. ghanes14
    Member
    Posted 5 years ago #

    Well it works when permalinks are default, I switch it back and it does the same error thing. I guess I will have to leave it at default, anybody know why it would suddenly not work with this style?

    Date and name based
    ยป http://all-notions.com/blog/2008/08/27/sample-post/

    The default is going to make it hard to know what pages of the site the statistics shows which is disappointing. It also means the 100s of links to my posts and time to get them to it is wasted...

    I deleted cache in wordpress and my browser I have had friends try it and didn't work for them so it's not just my end. I have tested it with IE, Firefox, Safari, and Opera so it's not the browser.

    What a day... Thanks for the default tip though, guess it's better than not working at all.

  10. Chris_K
    Member
    Posted 5 years ago #

    Ugh. Yahoo. Do you still have to run their special plugin to get Pretty Permalinks working? If so, is it active?

  11. ghanes14
    Member
    Posted 5 years ago #

    Customizable permalink plug-in is activated, has been since the first day. That's why I cannot understand why they suddenly stopped working. It's weird.

Topic Closed

This topic has been closed to new replies.

About this Topic