WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate Maintenance Mode
[resolved] Big Problem after uninstall, help appreciated (8 posts)

  1. jjsbetteroff
    Member
    Posted 1 year ago #

    Hi guys, this plugin is causing me an odd problem.

    I had it installed on site and it is now totally uninstalled. Yet sometimes, when I change something on site like a menu or featured content, the whole thing breaks on some browsers and shows an almost safe-mode-like page and the seedprod logo comes up witha broken x, missing all the images ( because the plugin is uninstalled).

    i know very little about javascript but it looks like your plugin maybe left something bad behind that is popping up every now and then. Last night it happened again and I managed to pull the code off the page source before it went away again;

    <!DOCTYPE html>
    <html lang="en">
    	<head>
    		<meta charset="utf-8">
    		<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    		<title>Just fixing some stuff, be back in an hour</title>
    		<meta name="viewport" content="width=device-width, initial-scale=1.0">
    		<script src="http://dropkickrugby.com/wp-includes/js/jquery/jquery.js"></script>
    		<script src="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/script.js"></script>
    		<script src="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/bootstrap/js/bootstrap.js"></script>
    		<link rel="stylesheet" href="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/bootstrap/css/bootstrap.min.css">
    		<link rel="stylesheet" href="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/bootstrap/css/bootstrap-responsive.min.css">
    
    		<style>
    		body{
    			background-color: #000;
    			background-image: url('http://s.wordpress.com/mshots/v1/http%3A%2F%2Fdropkickrugby.com%2F%3Fmshot%3Dtrue?w=1600');
    			background-repeat: no-repeat;
    			background-attachment: fixed;
    			background-position: top center;
                -webkit-background-size: cover;
                -moz-background-size: cover;
                -o-background-size: cover;
                background-size: cover;
    			text-align: center;
    		}
    		body p{
    			font-size:14px;
    		}
    		</style>
    	</head>
    	<body>
    	<div id="mmModal" class="modal hide fade">
    	  <div class="modal-header">
    	  			<h1>Just fixing some stuff, be back in an hour</h1>
    			  </div>
    	  <div class="modal-body">
    	    <p>Just updating some stuff, be back in an hour</p>
    	  </div>
    	    	  <div class="modal-footer">
    	  <a href="http://www.seedprod.com/">
    	  <img id="credit" src="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/framework/seedprod-footer-logo-gray.png" alt="Powered by SeedProd" /></a>
    	  </div><!-- .modal-footer -->
    	  	</div>
    	<script>
    	jQuery(document).ready(function($){
    		$('#mmModal').modal({
    		  keyboard: false
    		})
    		$('#mmModal').on('shown', function () {
    			$('body,.modal-backdrop').unbind();
    		});
    
    	});
    	</script>
    	  <!--[if lt IE 9]>
    	  <script>
    	  jQuery(document).ready(function($){
    	    	    $.supersized({
    	      slides:[ {image : 'http://s.wordpress.com/mshots/v1/http%3A%2F%2Fdropkickrugby.com%2F%3Fmshot%3Dtrue?w=1600'} ]
    	    });
    	    	  });
    	  </script>
    	  <![endif]-->
    	</body>
    </html>

    [Please post code or markup between backticks or use the code button. Or better still - use a pastebin. Your posted code may now have been permanently damaged/corrupted by the forum's parser.]

    Like I said, it comes and goes - and the plugin is definitely uninstalled (I dont know much about this stuff, but you can slso see it is uninstalled because none of the images referenced in teh code above ever show, jsut a weird old version of the home page when it was uninstalled).

    Do you have any suggestions as to what has remained and where i can find it to fix this? Many Thanks

    http://wordpress.org/extend/plugins/ultimate-maintenance-mode/

  2. John Turner
    Member
    Plugin Author

    Posted 1 year ago #

    What's you r url? Are you running a caching plugin? Clear your cache.

  3. jjsbetteroff
    Member
    Posted 1 year ago #

    Hi John,

    i have cleared the cache i'd say a hundred times since it first happened. It's w3 total cashe i'm using.

    Weirdly, it happened last night on chrome and i had only just installed chrome last night. As i said it comes in and out when I change things on site like menus or featured content.

    i think it's something to do with the javascript but i haven't a clue what i'm looking at. As you can see on the 5th or 6th line of code above ( sorry mods for doing it wrong), the script source is causing something no?

  4. John Turner
    Member
    Plugin Author

    Posted 1 year ago #

    It's has to do with the cache. This happens all the time. Either the bowser has cache a page or the caching plugin has cached a page. If a plugin has been removed it can't still use code. Not possible, unless its being servered form a cache source.

  5. jjsbetteroff
    Member
    Posted 1 year ago #

    John I really need some help with this, it happened again for no reason today - just popped up out of nowhere. Not just on my machine either-

    I went into w3tc cache and 'cleared/emptied all caches' and that seems to have fixed it for now, but i can't figure out why it popped up ( i've cleared caches a shit load of times since the last time it happened.
    There's nothing in the plugin folder and it is deleted. Is there anywhere else this script (i assume its a script) could be running from?

    thanks.

    <!DOCTYPE html>
    <html lang="en">
    	<head>
    		<meta charset="utf-8">
    		<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    		<title>Just fixing some stuff, be back in an hour</title>
    		<meta name="viewport" content="width=device-width, initial-scale=1.0">
    		<script src="http://dropkickrugby.com/wp-includes/js/jquery/jquery.js"></script>
    		<script src="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/script.js"></script>
    		<script src="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/bootstrap/js/bootstrap.js"></script>
    		<link rel="stylesheet" href="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/bootstrap/css/bootstrap.min.css">
    		<link rel="stylesheet" href="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/template/bootstrap/css/bootstrap-responsive.min.css">
    
    		<style>
    		body{
    			background-color: #000;
    			background-image: url('http://s.wordpress.com/mshots/v1/http%3A%2F%2Fdropkickrugby.com%2F%3Fmshot%3Dtrue?w=1600');
    			background-repeat: no-repeat;
    			background-attachment: fixed;
    			background-position: top center;
                -webkit-background-size: cover;
                -moz-background-size: cover;
                -o-background-size: cover;
                background-size: cover;
    			text-align: center;
    		}
    		body p{
    			font-size:14px;
    		}
    		</style>
    	</head>
    	<body>
    	<div id="mmModal" class="modal hide fade">
    	  <div class="modal-header">
    	  			<h1>Just fixing some stuff, be back in an hour</h1>
    			  </div>
    	  <div class="modal-body">
    	    <p>Just updating some stuff, be back in an hour</p>
    	  </div>
    	    	  <div class="modal-footer">
    	  <a href="http://www.seedprod.com/" target="_blank">
    	  <img id="credit" src="http://dropkickrugby.com/wp-content/plugins/ultimate-maintenance-mode/framework/seedprod-footer-logo-gray.png" alt="Powered by SeedProd" /></a>
    	  </div><!-- .modal-footer -->
    	  	</div>
    	<script>
    	jQuery(document).ready(function($){
    		$('#mmModal').modal({
    		  keyboard: false
    		})
    		$('#mmModal').on('shown', function () {
    			$('body,.modal-backdrop').unbind();
    		});
    
    	});
    	</script>
    	  <!--[if lt IE 9]>
    	  <script>
    	  jQuery(document).ready(function($){
    	    	    $.supersized({
    	      slides:[ {image : 'http://s.wordpress.com/mshots/v1/http%3A%2F%2Fdropkickrugby.com%2F%3Fmshot%3Dtrue?w=1600'} ]
    	    });
    	    	  });
    	  </script>
    	  <![endif]-->
    	</body>
    </html>
  6. John Turner
    Member
    Plugin Author

    Posted 1 year ago #

    If you've delete the plugin then there is no way for it to show unless it being cached by something.

    The plugin itself does not do any caching.

    Post your url and I'll see if it happens to me.

  7. jjsbetteroff
    Member
    Posted 1 year ago #

    Hi John,

    thanks for coming back to me.

    it wont happen for you, it only seems to creep up every now and then.

    i'm thinking about deleting my caching plugin (w3tc) and seeing what happens, what you reckon?

  8. John Turner
    Member
    Plugin Author

    Posted 1 year ago #

    yep you could try that and see what happens

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.