WordPress.org

Ready to get started?Download WordPress

Forums

big problem! (8 posts)

  1. ObscureSound
    Member
    Posted 8 years ago #

    hi. I accidentally changed my encoding for pages and feeds to UTF-7, and now I can't change it back. I go to options, but it keeps on saying 'error on page' in IE and on Firefox, it doesn't work either.

    the UTF-7 really screwed up my site.

    is there any way possible to get back to UTF-8?

  2. vkaryl
    Member
    Posted 8 years ago #

    Yeah, if you have phpmyadmin available through your host control panel, you have to do this in the database.

    If that's a "yes", post back....

  3. ObscureSound
    Member
    Posted 8 years ago #

    yeah, I do. but I already changed the blog_charset to UTF-8 (and it says so too) but it still shows up all screwy and in the reading options, it still shows as 'UTF-7', and when I try to change it, it even says 'Options Saved.', but the UTF-7 is still in the text box.

    and I can't even login to the wordpress admin account in internet explorer for some reason. I have to use firefox.

  4. vkaryl
    Member
    Posted 8 years ago #

    What happens if you try changing first to ISO-8859-1? Do you see any changes?

    I'm searching for other topics on this....

  5. ObscureSound
    Member
    Posted 8 years ago #

    nothing new. same results. :(

  6. vkaryl
    Member
    Posted 8 years ago #

    I find this:

    http://wordpress.org/support/topic/55282?replies=10#post-303707

    Don't know if it would help at all, seems to be mostly pointed at "accented letters" problems.

    I would, at this point I think if this were me, dump the database, open the sql file in notepad2, and change all the wrong charset lines to the right ones, then import the file. But that's just me, and I don't have a problem dinking around in databases.

    I'll keep looking, but it's late here and I have a VERY long day tomorrow. Maybe podz will have some help for you tomorrow....

  7. Niemi
    Member
    Posted 7 years ago #

    Complete guide to fix the grim WordPress UFT-7 bug:

    1. First open PhpMyAdmin, your domain host can provide you with the adress, in my case it's http://phpmyadmin.needhost.dk/.

    Login with the username and password you would have specified when creating the database.

    2. A list of your databases will appear. Click the one that is your WordPress database. All the tables in your database will appear. Depending on what prefix you have specified in your wp-config.php file you should find something like wp_options. If you can't find this table you prefix isn't wp_. You can look op wp-config.php at the root of your wordpress directory, and find the prefix line.

    example: $table_prefix = 'anotherprefix';

    In this case the table in your database would be ilovewordpressbugsoptions.

    Open the table "wp_options" or "anotherprefixoptions".

    3. Now you should look for the column named option_name. Look through the list and see if you can find an option called "blog_charset". Typically option_id #37. If you can't find it it's because it's on the next page. Click the next page button.

    4. Now you have found the "blog_charset". If you look at the value it says "UTF-7". Because WordPress can't handle this we are going to change this to UTF-8. Click the pen just before the delete function to edit it.

    5. Find the field where it say "UTF-7" and change it to "UTF-8" and press done, or whatever it's called in your language, at the bottom of the page.

    6. Thank God. You're done!

  8. moshu
    Member
    Posted 7 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.