WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
Better WP Security Blocks Open Graph Data (9 posts)

  1. thealchemist
    Member
    Posted 1 year ago #

    I have installed Better WP Security on a number of WordPress sites and have come across something I can't seem to figure out how to resolve except by uninstalling this great plugin.

    When BWPS is installed and we copy a post link (any link from the site, for that matter) into the "share" box on LinkedIn we no longer get the featured image, excerpt or full link! All that shows up is the main URL.

    If I deactivate BWPS and paste the same link into LinkedIn ... the share / status update contains the information it should and looks as it should.

    I believe I have gone through all the setting in BWPS, turning them off and on, pasting, testing, trying to figure out which setting is the problem ... until i was blue in the face.

    Does ANYONE know which setting is responsible? or do I have to use another security plugin for clients who use LinkedIn rather heavily?

    Thanks!

    http://wordpress.org/extend/plugins/better-wp-security/

  2. bishless
    Member
    Posted 1 year ago #

    I'm having a really similar issue... but just on LinkedIn. Sharing to Facebook, Google+, and Twitter all work just fine (thumb, descrip, url, and title all work). But LinkedIn gives me the same behavior you describe.

    Did you have any luck isolating a specific setting in BWPS that resolved the issue?

  3. thealchemist
    Member
    Posted 1 year ago #

    No. I have done this with 3 sites ... turn off all settings, turn them on one-by-one, checking LinkedIn each and every time ...the ONLY way to get the formatting in the LinkedIn system is to remove WP Better Security.

  4. bishless
    Member
    Posted 1 year ago #

    /facepalm

    Boy howdee... you try prevent someone else shooting you in the foot and end up shooting yourself in the foot.

  5. John3121
    Member
    Posted 8 months ago #

    Here is the solution for LinkedIn Open Graph and Better WP Security: http://wordpress.org/support/topic/having-url-preview-problems-in-linkedin-bot-blacklist-is-blocking-them/

    From my point of view, completely disabling the banlist may not be very secure. So I’ve done some research and found out that the following lines are blocking LinkedIn bot.

    RewriteCond %{HTTP_USER_AGENT} libwww [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} libwww-perl [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} ^Link [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} LinksManager.com_bot [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} linkwalker [NC,OR]

    I propose to turn on the "Enable Default Banned List" option and then manually remove the following code from .htaccess file. (The “Remove write permissions from .htaccess and wp-config.php” should be disabled before editing). This solution works for me and it would be great if someone could check it too.

    I read a lot of information and realized that the problem with the incorrect link preview in LinkedIn is very popular. Many people (including me) were not even aware that it may be caused by security measures in WordPress CMS. Therefore, I would like to ask the Better WP Security author to make some changes in the next releases or investigate this problem and include the solution to the FAQ.

  6. bishless
    Member
    Posted 8 months ago #

    This sounds really promising! Thanks for sharing your research. You win the internet!

  7. nightowl99
    Member
    Posted 7 months ago #

    John3121's solution worked for us! Thank you so much!

  8. mixix
    Member
    Posted 7 months ago #

    Same trouble. Did anyone figure out which lines are blocking facebook scraper?

  9. Maggsy
    Member
    Posted 5 months ago #

    Thanks John3121, worked like a charm. Might leave a small hole but in the grand scheme of things Linked In share is more important to my client!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic