WordPress.org

Ready to get started?Download WordPress

Forums

bbPress Enable TinyMCE Visual Tab
[resolved] Better WordPress Minify breaks fancy editor (16 posts)

  1. Martyn_
    Member
    Posted 1 year ago #

    With BWM the fancy wordpress editor breaks for me - you are unable to switch between visual and text modes.

    Versions:

    Better WordPress Minify 1.2.2
    bbPress 2.3.2
    bbPress Enable TinyMCE Visual Tab 1.0.0
    GD bbPress Tools 1.4
    buddypress 1.7.3 (not relevent I think)

    I've no idea how to debug this but can post more - does anyone have a fix/workaround?

    xposted to plugin groups (apols)

    http://wordpress.org/extend/plugins/bbpress-enable-tinymce-visual-tab/

  2. Schaum
    Member
    Posted 1 year ago #

    I have the same problem!

  3. Schaum
    Member
    Posted 1 year ago #

    Ok, I found that is possible to exclude code in "WordPress Minify", but which code is it?

  4. Jared Atchison
    Member
    Plugin Author

    Posted 1 year ago #

    View the source and look for any .js files relating to TinyMCE, that should be the culprit.

  5. Martyn_
    Member
    Posted 1 year ago #

    One presumes the files in wp-includes/js/tinymce/ but I have not had luck finding an exclusion that fixed it...

  6. Jared Atchison
    Member
    Plugin Author

    Posted 1 year ago #

    TinyMCE also uses a lot of inline JS. If that is getting minified it will likely break as well.

    This is really an issue specific to TinyMCE and not this plugin, so I'm closing.

  7. Martyn_
    Member
    Posted 1 year ago #

    ?

    TinyMCE is a part of WP core....

  8. This is true but the problem you are apparently having does not have anything to do with this plugin.

    Minifying .js files is often a hit or miss proposition. This plugin only "Activates the visual tab for the bbPress TinyMCE editor and provides a few other options" and that's not where you're having a problem.

  9. Martyn_
    Member
    Posted 1 year ago #

    Ah - my bad. I wa confused between forums - only posted here for informational reasons to help people who might be seeing the issue in the first place!

  10. Alex Schenker
    Member
    Posted 8 months ago #

    Same problem here, can't find which code to exclude.

  11. esmi
    Forum Moderator
    Posted 8 months ago #

    @Alex Schenker: If you require assistance then, as per the Forum Welcome, please post your own topic.

  12. Jared Atchison
    Member
    Plugin Author

    Posted 8 months ago #

    Unfortunately I'm unable to provide support for other plugins, such as the minify ones.

    I can give some insight though.

    The two files that should definitely be excluded are editor.js and topic.js.

    Also you'll want to disable any inline js minification.

  13. Alex Schenker
    Member
    Posted 8 months ago #

    @esmi, will do thanks!

  14. Alex Schenker
    Member
    Posted 8 months ago #

    @Jared Atchison, excluding those files worked! Thanks so much :-)

  15. roland71
    Member
    Posted 5 months ago #

    Hi there,
    @jared
    @alex
    Can you please explain me what I have to do to exclude the editor.js and topic.js files?
    How can I exclude files? I'm not a dev.
    Thanks

  16. Alex Schenker
    Member
    Posted 5 months ago #

    Hi @roland71, we don't use the WP Minify plugin anymore (we're simply using W3 Total Cache's (W3TC) minify), but there should be an "exclude these files or paths" section in the settings that allows you to specify files to exclude.

    For example, under W3TC > Performance > Minify > Advanced, there's a section "Never minify the following JS files" under which I have:

    wp-content/plugins/bbpress/templates/default/js/editor.js
    wp-content/plugins/bbpress/templates/default/js/topic.js

    Cheers,
    Alex

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.