WordPress.org

Ready to get started?Download WordPress

Forums

Basic stuff ... header image won't display (11 posts)

  1. matrixgirl
    Member
    Posted 1 year ago #

    I'm new to WP and seem to having a very basic problem.
    I'm using the free theme Blaskan and I'm trying to add a custom header.
    I created a jpg file to the recommended pixel size which I'm very familiar how to do and saved it to my computer.
    When I click the Appearance > Header links I get a page to upload my custom header.
    I choose the file from my computer and click the upload button.
    It uploads and shows the filename in my media library but the image won't display. I get the blue question mark and taken to the 'crop image' box again with blue question mark.
    Any idea's? It seems like this should be a very straight forward thing to do so why won't it display?
    My site is unpublished as this is my first page.
    Let me know if you need more info. Thanks.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Check your uploads path in Settings->Media. It should be blank in most installs.

  3. matrixgirl
    Member
    Posted 1 year ago #

    Yes it is blank.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Can you confirm, using FTP, that the image was uploaded successfully to wp-content/uploads?

  5. matrixgirl
    Member
    Posted 1 year ago #

    Ok thanks, just checked it's not there.
    Should I upload the image manually to this folder?
    Shouldn't WP automatically do this?

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    How large was the file that you were uploading?

  7. matrixgirl
    Member
    Posted 1 year ago #

    its 34KB

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    That should be fine. Try checking your server's error logs for clues. If you don't know how to access your error log, ask your hosts for assistance.

  9. matrixgirl
    Member
    Posted 1 year ago #

    OK now I've found the files ...
    I had a tech guy manually install WP into the root folder of my domain for me.
    Here is the location of my header image that won't appear on my page.

    Public_html Folder > yoursuccessbootcamp.com >wp content > uploads >2012 > 11> header.jpg

    I also have these folders under public
    Public_html Folder > wp-admin, wp-content and wp-includes

    Is this something to do with how it's been installed?

  10. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Not as far as I'm aware. Anything in the error logs?

  11. matrixgirl
    Member
    Posted 1 year ago #

    Hmmm ... OK I have to check this later as I have to go out now. Will post again later. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic