WordPress.org

Ready to get started?Download WordPress

Forums

Bootstrap Ultimate
[resolved] Basic Bootstrap classes not working! (3 posts)

  1. starflamedia
    Member
    Posted 5 months ago #

    Hello!
    I've been playing with the them for a day now and I am not sure how to use any bootstrap commands/classes with it, or that it is possible at all.

    Why are basic bootstrap classes like .row, .col-sm-12, .myCarousel not working as they do in bootstrap? Your theme has a great many options in the admin panel but I prefer to write my own code and to literally bootstrap items here and there with the WP php construct but it is not working... Is this on purpose? It kind of cancels the theme being on bootstrap if boostrap commands are not working? Or am I doing sth wrong?

    Example 1: <div class="row"> is left aligned and partially outside of the page instead of centered.
    Example 2: <div class="col-sm-12"> like .row does not follow the rest of the page but aligns left...
    Example 3: When I add the code below to header.php, I get the first photo left aligned instead of centered over the rest of the page, and the controls and shadow expand way beyond the photo overlapping the header, menu and half the content. Additionally, the controls do not take me the next photo, nor is there an auto rotation: Here is a screenshot

    <div class="myCarousel">
    <section class="carousel-inner">
    <div class="active item"><img src="<?php bloginfo('url'); ?>/img/1.jpg" alt=""></div>
    <div class="item"><img src="<?php bloginfo('url'); ?>/img/2.jpg" alt=""></div>
    <div class="item"><img src="<?php bloginfo('url'); ?>/img/3.jpg" alt=""></div>
    </section>
    <a href="#myCarousel"><span class="glyphicon glyphicon-chevron-left"></span></a>
    <a href="#myCarousel"><span class="glyphicon glyphicon-chevron-right"></span></a>
    </div>

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

    Thank you for your help!

  2. eminozlem
    Member
    Theme Author

    Posted 5 months ago #

    That should be #myCarousel and not .myCarousel
    change <div class="myCarousel"> to <div class="carousel slide" id="myCarousel"> and see if that helps.

    Also it appears there might be an extra or missing div somewhere.If you gonna, I suggest instead of copying from bootstrap's site, try copying contents from the theme's carousel.php

  3. eminozlem
    Member
    Theme Author

    Posted 5 months ago #

    It's been a week and haven't heard from you back, assuming it's resolved, let me know if you've further questions.

Reply

You must log in to post.

About this Theme

About this Topic