WordPress.org

Ready to get started?Download WordPress

Forums

Banner's not displaying on IE but Firefox (9 posts)

  1. xtool
    Member
    Posted 9 years ago #

    Hello All. Happy Halloween!
    I've recently updated my Blog with new 3 columns style from scratch and now I can not trouble shoot this problem I ran into. I can see my banner on Firefox fine BUT not for IE. I can hear the music but not the graphic. My banner/logo is a Flash file.
    On my wp-layout looks like this:
    #header {
    background: url(wp-images/logos/logouo.swf) no-repeat;
    margin: 0px 0;
    padding: 0px;
    height: -55px;
    text-align: center;
    background: #008CD2;
    font-family: arial, helvetica, sans-serif;
    }
    It seems like it doesn't work. I manually had to insert the Object line onto my index.php:
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="769" height="100">
    <param name="movie" value="wp-images/logos/logouo1.swf" />
    <param name="quality" value="high" />
    <embed src="wp-images/logos/logouo1.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="769" height="100"></embed>
    </object>
    You can view it here: http://www.forceforge.com
    Thank you in advance.

  2. This is sort of becoming my trademark response here, but if you can get you XHTML to validate ( http://validator.w3.org/check?uri=http%3A%2F%2Fwww.forceforge.com%2Fwp%2Findex.php ), you should be able to check and see what's wrong with your CSS by pasting your site URL here: http://jigsaw.w3.org/css-validator/

  3. xtool
    Member
    Posted 9 years ago #

    Ok, I've cleaned up all the extras and it's validated!
    Still my banner is not working. Looks like more works up ahead. Thank you for all the replies!

  4. xtool
    Member
    Posted 9 years ago #

    Now I can get normal image like Jpg, Png, Gif to display but not Swf [flash]. I had it working once before. I'm just troubleshooting.

  5. xtool
    Member
    Posted 9 years ago #

    Ok it seems the only way to make it to shows on both IE and Firefox is to add the Flash directly into Index.php . But I ran into Validation issues. Now what? Oh.

  6. And the CSS validated after you got the XHTML to validate as well? Honestly, IE is the root of all evil.

  7. xtool
    Member
    Posted 9 years ago #

    Yes CSS validated with zero errors. Only XHTML was not validate for my flash object and nothing else.

  8. Anonymous
    Unregistered
    Posted 9 years ago #

    OK now they both are lined up but I ran into another problem. The left menu can ONLY be viewed on Firefox BUT not IE. I'm doom!

  9. xtool
    Member
    Posted 9 years ago #

    Ops sorry, that was me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.