WordPress.org

Ready to get started?Download WordPress

Forums

Baffled by my permalink problems (6 posts)

  1. Nos402
    Member
    Posted 9 years ago #

    I initially had permalinks working great with the /archives/%post_id% prefix. Then I added an "archives,php" template to the theme, and created an "archives" "page" based on that template. At some point I noticed weirdness, and so I eventually deleted the page and the template from my directory. I found that now my permalinks were all screwy. After deleting the tamplate and page they would only give the old "no posts matched your criteria" error. I deleted my .htaccess file, cleared my cache, and all that. Same problem. I had someone else at at another computer (in another location entirely) try and they got the same error. They had never been to my page so it wasn't cache or cookie problems.

    I eventually found that permalinks will work if I change them to anything else except /archives/%post_id%

    I'm totally baffled. It seems that something got screwed up by having either the template or page called "archives" but they're all gone now and I've totally started witha new .htaccess file.

    Totally baffled.

  2. aetherFox
    Member
    Posted 9 years ago #

    How exactly do you want to store your archives anyway? If /archives/%post_id% is something that is a problem, for the moment, don't use it.

    What are the administration settings that you have for your permalinks? What was in that archives file?

  3. Nos402
    Member
    Posted 9 years ago #

    For the moment I have just changed my permalinks to the year/month/etc option, but it was more curiosity than anything else. I'd just like to know why this problem occurs. The archive file just had the category and monthly archives listed. I copied the "archives.php" file from the default template. I then wrote a "page" based on that template with the title and page slug os "Archives" and saved it.

  4. moshu
    Member
    Posted 9 years ago #

    That's the problem - the name/title, I guess.
    Read this thread: http://wordpress.org/support/topic.php?id=24290
    And I have seen other also complaining about an archives page called archives causing problem in archives :))

  5. Just to add another opinion (since I have no problems with archives and have a page titled "Archives".) You need to have a trailing slash at the end of your permalinks. Use:
    /archives/%post_id%/

  6. Nos402
    Member
    Posted 9 years ago #

    Thanks all. From that other thread I fixed it by changing the page slug. I'm jsut surprised that worked since even when I deleted the page entirely I still had the error! Weirdness.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.