WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Bad URL in confirmation email (6 posts)

  1. danielj@dtdo.net
    Member
    Posted 1 year ago #

    The URL that is being generated in the confirmation email is giving a 404. Here is an example:

    https://blog.doortodoororganics.com/michigan/?s2=1a14d24e0c28f477e28c938e7b7b93cf6155

    But it appears that this user got subscribed anyway.

    I don't know if this started happening recently, or if this is just the first time someone is pointing it out to us.

    What should the URL look like? And any idea on how I can fix it?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @danielj,

    That about what the confirmation URL should look like, you site seems to be running a few redirections. These need to be adjusted to allow for the confirmation URL from Subscribe2 I suspect.

  3. danielj@dtdo.net
    Member
    Posted 1 year ago #

    The only plugin we are using that that would generate any redirects is the https plugin from http://mvied.com/projects/wordpress-https. We are also running multisite, if that matters.

    Can you give me an idea of what the adjustments might look like? You said that is "about" what the URL should look like - what is not quite right with it?

    Thanks,

    Daniel

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Daniel,

    Initially the /michigan/ bit looked a bit odd but it could be correct. However, know I know you are multisite it add more information.

    On the main pages it looks like the site is set up to use subdomains but this link is not operating like that, it's more like a sub-directory install. Which are you using?

    Bear in mind that Subscribe2 must be installed and activate per-site on a multisite install and it will need a sign up page creating for each individual blog.

  5. danielj@dtdo.net
    Member
    Posted 1 year ago #

    We are using subdirectories.

    There is a page for each blog called Subscribe, with [subscribe2] as the contents. And the plugin is activated on each blog, as far as I can tell.

    I appreciate you trying to help me figure this out.

    Daniel

  6. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Daniel,

    I think you may need to choose the 'Subscribe' page in the dropdown at Subscribe2->Settings, under the Appearance tab where it says "Set default Subscribe2 page as".

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags