WordPress.org

Ready to get started?Download WordPress

Forums

Backup
[resolved] Backup Plugin Error (47 posts)

  1. LeeStewie
    Member
    Posted 2 years ago #

    Hi there,

    First of all, I'd just like to say thanks to the developer for this module - it has the potential to be such an excellent addition to any WordPress blog.

    I'm experiencing a couple of problems with the module though.

    First of all - the backup isn't getting transfered to my Google Drive (I've tried this on 3 of my blogs - and all with the same outcome):

    2012-05-20 14:36:26 NOTICE Attempting to upload archive to Google Drive
    2012-05-20 14:36:26 ERROR Failed to upload archive to Google Drive!

    Secondly, now that I have the maximum backups created (I've set this to be 3, I'm also getting another error:

    2012-05-20 14:36:40 NOTICE Attempting to create archive /home/theblogg/public_html/leestewie/wp-content/backup/1337524600.zip
    2012-05-20 14:36:47 ERROR There was a problem creating the zip file! /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php 290

    Thirdly, the frequencies appear to be incorrect. For example, I select 'Monthly' to be 'When to Backup' and for some reason the next Backup is going to be December?

    Any ideas?

    As I say, this is going to be a brilliant plugin - just seems there's a couple of issues to still be ironed out (unless I'm being really thick - then I apologise!)

    Cheers,

    Lee

    http://wordpress.org/extend/plugins/backup/

  2. LeeStewie
    Member
    Posted 2 years ago #

    Ok... regarding the second point I made - might have found the problem for this. It seems there wasn't enough space avalible to save the backup in the /backup/ folder. Can there be an option to remove the backup from the server? In theory the backup that should go to Google Drive is an exact replica so there's perhaps less of a need for both.

  3. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Lee,

    First of all thank you for your great feedback!

    I will try to answer your questions/issues in reverse order.

    1. I solved the frequency problem. It was a miscalculation on my part.

    2. As it is right now, if you set the number of backups to 3, you will end up always having the 3 most recent backups on both Google Drive and your wp-content/backup folder. Would you like an option to not have any backups kept in the wp-content/backup folder?

    3. The failure to upload to Google Drive is a bit more difficult to tackle because as it stands the Google Drive/Docs API is undergoing a lot of changes and I have found that while one implementation might work for me it might not work for others.

    I will have to extend the log file to include the HTTP responses Google gives in order to successfully solve this problem. Please update to the leanest version of the Backup plugin as soon as it is available and post the relevant log entries here.

    Again, I am very grateful for your feedback and help.

  4. Bharath Mandava
    Member
    Posted 2 years ago #

    First of all, I need to thank you for this awesome plugin.

    Here is my query:
    I have tried to backup using Manual Backup URL, but it is not working, is there any solution for that ?

  5. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Bharath,

    Did you successfully authorize your Google Account on the Backup plugin's settings page?

    If so, can you please paste the contents of the wp-content/backup/backup.log file here?

  6. Bharath Mandava
    Member
    Posted 2 years ago #

    I re-installed the plugin and updated it to 1.1 version. Its working fine now and thanks again for such an awesome plugin.

    I also wrote an article on Backup plugin Backup WordPress Blog to Google Drive

    Cheers
    Bharath

  7. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    I'm glad to hear that!

  8. LeeStewie
    Member
    Posted 2 years ago #

    Thanks for the quick feedback hel.io - here is my follow up:

    1) I've updated to the latest version and the time's appear to be a bit mixed up. For example:

    I select 'Never' and it says "Next scheduled backup: Jun 20, 2012 at 22:46:43" (I'm assuming this should correspond to Monthly)

    I select 'Daily' 'Weekly' and 'Monthly' and it says "Next scheduled backup:
    May 21, 2012 at 22:48:30" (this is scheduled for 3 minutes time!)

    Not sure if this is just on my blog, but it seems a bit peculiar! As when I re-load the 'Backup' page, the correct time corresponds to the time period I selected. Perhaps this is just an issue of what is loaded in the "Next scheduled backup:" section?

    2) I think it would be excellent to have that option, as to store even 3 backups on a webserver could be quite resource intensive - therefore the option for just Google Drive (or even to store just manually on the server) would be a useful addition imo.

    3) I have the 'Backup' plugin installed on 3 blogs, and the only message in the error log that I am getting is as below (this is all on the new version):

    2012-05-21 22:54:19 NOTICE Attempting to upload archive to Google Drive
    2012-05-21 22:54:20 ERROR Failed to upload archive to Google Drive!

    Thanks again for supporting your plugin and assisting :)

    Cheers,

    Lee

  9. pisymbol
    Member
    Posted 2 years ago #

    I just tried the plugin and I am getting two different failures when I try to manually backup my site via the /backup URL:

    1) Permission denied on error_log() calls (L779), my entire directory structure is 755 so I am not sure why your plugin is barfing on writing out backup.log

    2) Warning: Cannot modify header information - headers already sent by on <path to backup.php> on 268

    The plug has authorized correctly with Google API Gdrive subsytem. The client ID is correct as well as the folder ID.

    I am not sure why the function error_log is failing. Again all directories are 755 (wp-content/plugins/backup) yet it won't write out backup.log.

    What am I doing wrong?

  10. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    @LeeStewie

    1) No matter what frequency you select, the plugin schedules the first backup for the current date and time, and assuming that the 3 minute difference you're seing is the difference between the server and your computer I would say it functions correctly. I did have to fix the plugin for 'never' though.

    2) I have added a new field on the settings page where you can enter how many backups to be stored locally. You can obviously enter in 0 for none.

    3) I think I am close to nailing it. Update to version 1.1.2 and paste the relevant log entries here.

  11. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    @pisymbol

    You're number 2 issue is related to number 1 so we should figure out why error_log can't write to the file.

    Can you confirm that wp-content/backup/backup.log has been created and contains "#Fields: date time type message file line"?

  12. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    I accidentally broke the plugin with version 1.1.2 so please update to 1.1.3.

  13. LeeStewie
    Member
    Posted 2 years ago #

    Hi again hel.io

    Just updated to 1.1.3 and it's really helped solve some of those problems I was having, and I especially like the new feature (tested locally and working great!)

    I still have problems on all 3 of my blogs though, with sending to Google Drive. The error message is now:

    2012-05-23 21:26:24 NOTICE Attempting to upload archive to Google Drive
    2012-05-23 21:26:24 ERROR Bad response: HTTP/1.1 400 Bad Request /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php 422
    2012-05-23 21:26:24 ERROR Failed to upload archive to Google Drive

    Let me know if you need any further info.

    Cheers,

    Lee

  14. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    We are on the right track. So Google sais we're not making the request right. Let's see what the request header looks like:

    Update to 1.1.4 and again paste the log entries here.

  15. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Oh, there's one thing you need to remember. When pasting the log this time there should be a token in there which you do not want to make public (anyone with this token would be able to do anything on your Google Drive).

    The token should be a long random string just after "Authorization: Bearer ". Just tell me if the token is there and tell me the length of it but don't paste it.

  16. LeeStewie
    Member
    Posted 2 years ago #

    Here's the log:

    2012-05-24 22:29:03 NOTICE Attempting to upload archive to Google Drive
    2012-05-24 22:29:03 ERROR Bad response: HTTP/1.1 400 Bad Request. Request header: Authorization: Bearer *token removed*; Content-Length: 281; Content-Type: application/atom+xml; X-Upload-Content-Type: application/zip; X-Upload-Content-Length: 8796902; GData-Version: 3.0 /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php 422
    2012-05-24 22:29:03 ERROR Failed to upload archive to Google Drive!

    Therefore, yes, the token was there (I've hidden it in the above) and it was 60 characters.

    Let me know if there's any further info you require.

    Cheers,

    Lee

  17. pedal
    Member
    Posted 2 years ago #

    hello, i have two blogs. backup plugin works fine in my small blog (about 1MB database size and 45MB contents)
    But in other blog with 45MB database and 1.5GB files, it doesn't work. it shows only a blank page when i choose Manual backup URL.

  18. pedal
    Member
    Posted 2 years ago #

    my google drive free space is full. is that a problem of php.ini options?

  19. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Hi pedal,

    The blank page you see is normal. That link is for people to use in cron jobs so it shouldn't output anything.

    As for the problems you're having with the backup of the larger site please take a look at the log file generated by the plugin (wp-content/backup/backup.log). If you need help you can paste the lines with errors here.

  20. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    For everyone reading this and wanting to post their issues: Please create a new thread if your issue is not the same or related to the one the original poster has.

    This way we keep things organized and easier to find.

    Thanks!

  21. pisymbol
    Member
    Posted 2 years ago #

  22. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Lee,

    Please update the plugin to version 1.1.5 and see if it works.

  23. LeeStewie
    Member
    Posted 2 years ago #

    Hi again,

    Updated the plugin and there appears to be a php error:

    Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: Entity: line 1: parser error : Start tag expected, '<' not found in /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php on line 550

    Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: Invalid request URI in /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php on line 550

    Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: ^ in /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php on line 550

    Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php:550 Stack trace: #0 /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php(550): SimpleXMLElement->__construct('Invalid request...') #1 /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php(393): get_resumable_create_media_link('ya29.AHES6ZTSkj...', '0B-qsHmeU_X2Zdk...') #2 /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php(326): upload_file('/home/theblogg/...', '1338046782.zip', '0B-qsHmeU_X2Zdk...', 'ya29.AHES6ZTSkj...') #3 /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php(293): do_backup() #4 [internal function]: manual_backup('') #5 /home/theblogg/public_html/leestewie/wp-includes/plugin.php(405): call_user_func_array('manual_backup', Array) #6 /home/theblogg/public_html/leestewie/wp-includes/template-loader.php(7): do_action('template_redire...') #7 /home/theblogg/ in /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php on line 550

    and the log is as below:

    2012-05-26 15:39:42 NOTICE Attempting to create archive /home/theblogg/public_html/leestewie/wp-content/backup/1338046782.zip
    2012-05-26 15:39:48 NOTICE Archive created successfully in 5.72885394096 seconds.
    2012-05-26 15:39:48 NOTICE Attempting to upload archive to Google Drive

    So unfortunately, still some problems by the looks of it! :(

    Cheers,

    Lee

  24. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for testing Lee. We'll get to the bottom of this.

    Please update to version 1.1.6 and try again.

  25. LeeStewie
    Member
    Posted 2 years ago #

    No problem. Seems the error has moved onto line 559:

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 1: parser error : Start tag expected, '<' not found in /home/theblogg/public_html/minglemonkee/wp-content/plugins/backup/backup.php on line 559

    Warning: simplexml_load_string() [function.simplexml-load-string]: Invalid request URI in /home/theblogg/public_html/minglemonkee/wp-content/plugins/backup/backup.php on line 559

    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/theblogg/public_html/minglemonkee/wp-content/plugins/backup/backup.php on line 559

    2012-05-26 18:48:51 NOTICE Attempting to create archive /home/theblogg/public_html/minglemonkee/wp-content/backup/1338058131.zip
    2012-05-26 18:48:55 NOTICE Archive created successfully in 3.7266740799 seconds.
    2012-05-26 18:48:55 NOTICE Attempting to upload archive to Google Drive
    2012-05-26 18:48:55 ERROR Could not create SimpleXMLElement from Invalid request URI /home/theblogg/public_html/minglemonkee/wp-content/plugins/backup/backup.php 561
    2012-05-26 18:48:55 ERROR Could not retrieve resumable create media link. /home/theblogg/public_html/minglemonkee/wp-content/plugins/backup/backup.php 398
    2012-05-26 18:48:55 ERROR Failed to upload archive to Google Drive!
    2012-05-26 18:48:55 NOTICE Deleted old backup file /home/theblogg/public_html/minglemonkee/wp-content/backup/1337808582.zip

    Cheers,

    Lee

  26. pedal
    Member
    Posted 2 years ago #

    this is my log file:

    2012-05-27 02:38:15 NOTICE Attempting to dump database to /var/www/.../wp-content/backup.sql
    2012-05-27 02:38:15 NOTICE Dumping table wp_ads_banners
    2012-05-27 02:38:15 NOTICE Dumping table wp_commentmeta
    2012-05-27 02:38:17 NOTICE Dumping table wp_comments

    Thanks

  27. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    @pedal As there are no errors in the backup.log file I assume the problem is that PHP ran out of memory. You should check the PHP error log to get a more accurate view on what's happening. I would suggest increasing the memory limit in php.ini.

  28. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    @Lee Are you trying to upload to a Google Drive folder? If so, are you sure you entered the correct ID for that folder?

    Also please tell me the version of PHP that you are running.

  29. LeeStewie
    Member
    Posted 2 years ago #

    Hi again,

    Yup - I'm trying to submit to a particular folder, and confirm that I've copied and pasted from the url (of all my blogs) after the #folders/

    My web server is running PHP version 5.2.17

    Just so you know, I've tried 1.1.6 on my other blogs and I get the same errors.

    Cheers,

    Lee

  30. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Could you try and upload to the root folder ( leave the folder ID field empty ) and see if that works?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic