WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
Backup causing long stream of 'Deprecated' errors (6 posts)

  1. rosenzweig70
    Member
    Posted 11 months ago #

    I've tried running backups and when I do I see a long stream of repeating php errors that read like this:

    Deprecated: Function ereg_replace() is deprecated in .... better-wp-security/inc/backup.php on line 92.

    As it turns out the backup actually gets completed and emailed to me, but not before crashing my browser with hundreds of lines of this same error repeated over and over.

    I checked the php version and it's 5.3.15. Can anyone lend a hand? Thanks in advance for your help.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Handoko
    Member
    Posted 11 months ago #

    The backup feature of this plugin has been reported not working several times in this forum.

    You have 2 options: wait until the devoloper fix it or use other backup plugin.

    Note
    The developer seems very busy, this issue has been reported for a quite long time, but no fix yet.

  3. Bozz
    Member
    Posted 11 months ago #

    I receive a white screen when I click on the 'Backup' tab. Site has a fairly large database (300mb). Works on other (smaller) sites just fine.

  4. gh0stshell
    Member
    Posted 11 months ago #

    mine is 16MB and it goes to a 500 error for me, in the logs it shows a PHP memory issue, but i upped my memory to 1GB

  5. Handoko
    Member
    Posted 11 months ago #

    If you're interested to use other backup plugins, there are my recommendations:

    - BackUpWordPress
    Features: works on low resouce webhost environments, schedule or manual backups, file and/or database backups, multiple schedule allowed
    Disadvantage: schedules sometimes don't work on scheduled time (often happen on multiple schedules)

    - BackWPup
    Features: backup to other locations (Dropbox, etc), check/repair/optimize database
    Disadvantage: don't know (because I don't use it)

    @gh0stshell:
    Does the memory issue still happen after you increase the memory?

  6. gh0stshell
    Member
    Posted 11 months ago #

    yup i upped it to 1024MB, verified it within WP and via phpinfo() and still no luck, see my original post for more info including my log files, its a server i own and i have full access, the thing that gets me is my other sites, ill take my main site for example is on the same server, running WP 3.5 BWS 3.4.8 and it works just fine.

    http://wordpress.org/support/topic/backup-now-failing-after-update-to-352?replies=2

Reply

You must log in to post.

About this Plugin

About this Topic