WordPress.org

Ready to get started?Download WordPress

Forums

WP Vegas
[resolved] background vegas slider with sitecorp child theme (12 posts)

  1. getonlineservices
    Member
    Posted 1 year ago #

    Good Morning,
    I would like to use the Vegas Slider with the simplecorp (site 5) theme (with child theme).
    I have installed the plugin and activated, added slides and created the slide show.
    I have copied header.php into the child theme directory and edited with the following:

    ' <?php wp_head(); ?>
    <!-- end of wordpress head -->
    <!-- vegas slider shortcode -->
    <?php get_header(); ?>
    <?php echo do_shortcode( '[vegasslider id="202" fade="" delay="" overlay="http://localhost/www/wp/wp-content/uploads/2013/05/1422057_35148924.jpg" title="Activities" arrows="no" autoplay="yes"]' ) ?>'

    The slides aren't being displayed in the background and the header h1 on every page is being overwritten with "Private: Activities slide show" the name of the Vegas slide show.
    I'm running on a localhost at the moment.

    Should this work with the Simplecorp theme ?

    Thank you,

    http://wordpress.org/extend/plugins/vegas-fullscreen-background-slider/

  2. jamesdbruner
    Member
    Plugin Author

    Posted 1 year ago #

    You absolutely NEED a value for fade and delay. Fade and Delay are in milliseconds so I would use values between 1000 and 5000. It should work with any theme, though it does sound like it may be more than just adding fade and delay. Report back to me with what happens!

  3. getonlineservices
    Member
    Posted 1 year ago #

    Hi James,
    Thanks very much for your reply.
    I changed the shortcode to
    ' <!-- vegas slider shortcode -->
    <!-- <?php get_header(); ?> -->
    <?php echo do_shortcode( '[vegasslider id="202" fade="5000" delay="2000" overlay="http://localhost/www/wp/wp-content/uploads/2013/05/1422057_35148924.jpg" title="Activities" arrows="no" autoplay="yes"]' ) ?>
    '
    The h1 is still being corrupted, all I see on the background is the title "Activities" in the bottom righthand corner.

    If I take the shortcode and place in the content of the page h1 is not corrupted but again only see the title in the background.
    Is it worth me trying to place the code in the footer.php ?
    Thanks again.
    Mike

  4. jamesdbruner
    Member
    Plugin Author

    Posted 1 year ago #

    It's probably not worth putting it in the footer.php but can I get you to send me a screenshot of what it looks like it's doing and copy the source code and paste me a link to paste bin? I just want to see what's going on, and I know you're on a localhost.

  5. getonlineservices
    Member
    Posted 1 year ago #

  6. jamesdbruner
    Member
    Plugin Author

    Posted 1 year ago #

    Can I safely assume that you've been editing this theme pretty heavily? I downloaded the theme and activated on my demo site and the slider is working fine which is why I ask. If you have been editing it just make sure you have wp_head in the header.php and wp_footer in the footer.php

  7. getonlineservices
    Member
    Posted 1 year ago #

    Hi James,
    I have made minimal changes to the theme php. Mainly css changes in style.css of child theme. I have installed a number of plug-ins and made customisation through wp-admin.
    wp_head and wp_footer are both there.
    I did find that the overlay link was wrong, I've corrected this and now see a static image in background but h1 of pages is still corrupted. I have also noticed that the slide show is always published as private even when I change it to public ?
    I have deactivated all the plug-ins apart from Vegas slider and removed all child theme changes apart from the shortcode in header.php.
    I have placed a screenshot here https://www.box.com/s/ugx7yzxgjj7t10oztepd

    Looks like I may have to start again !?
    Thank you,
    Mike

  8. jamesdbruner
    Member
    Plugin Author

    Posted 1 year ago #

    Change title="Activities" to title="" to remove the title at the bottom right.

    To stop posts from publishing as private (I should probably make this an option, I'll work on that eventually) go to the plugin editor and at the bottom of index.php you'll see

    //Force to publish private
    //...but first make sure they are not 'trash' otherwise it is impossible to trash a post
    function force_vegas_private($post)
    {
        if ($post['post_type'] == 'vegasslider') {
            if ($post['post_status'] != 'trash') $post['post_status'] = 'private';
        }
        return $post;
    }
    add_filter('wp_insert_post_data', 'force_vegas_private');

    Just remove that.

  9. jamesdbruner
    Member
    Plugin Author

    Posted 1 year ago #

    Did you figure this out? If you still need help let me know!

  10. getonlineservices
    Member
    Posted 1 year ago #

    Hi James,
    Sorry I haven't had an opportunity to try this yet. I will as soon as possible as the slider background looks great.

    Thanks very much.
    Mike

  11. jamesdbruner
    Member
    Plugin Author

    Posted 1 year ago #

    Did any of that work or are you still having trouble?

  12. jamesdbruner
    Member
    Plugin Author

    Posted 11 months ago #

    I'm marking this as resolved since you didn't come back for further assistance. If you're still having trouble just shoot me and email or create another topic here!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic