WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager will not Activate (19 posts)

  1. mikeperazzetti
    Member
    Posted 2 years ago #

    I am using the Annotum Theme at mikeperazzetti.com, and I have been told by my hosting provider that I have the latest version of PHP but I keep receiving this error. The hosting provider suggested I go into the .htaccess file to add the string

    # Use PHP 5.3
    AddType application/x-httpd-php53 .php

    to make this work but that did not help (unless I added it in/to the wrong line.

    Error: Unsupported version

    The plugin "Background Manager" requires PHP version 5.3.0 or better.

    Because of this error, the plugin was automatically deactivated to prevent it from causing further problems with your WordPress site.

    Error source: /home/mikepera/public_html/wp-content/plugins/background-manager/background-manager.php

    I would really like to make this plugin work for me because I feel it will be useful, but my efforts have come to naught at this point.

    Hope you can help,

    Mike Perazzetti

  2. myatu
    Member
    Posted 2 years ago #

    Hi!

    Create a PHP file, for example "my-test.php" containing the following line:

    <?php phpinfo(); ?>

    Then call it from your browser using the URL "ww.mikeperazzetti.com\my-test.php". It will give you the full details about your PHP environment, including which version you're using.

    For security, don't use "my-test" as part of the filename but something of your own imagination (as others read these forums), and once you have verified the version of PHP, delete the test file. Reason is that phpinfo() exposes a lot of details.

  3. mikeperazzetti
    Member
    Posted 2 years ago #

    Thank you. Done. This is what i see once I load the page as instructed.

    <?php phpinfo(); ?>

    What exactly does this mean and is PHP installed at all? The guy that hosts this web site and a few others says that the latest PHP is installed. He also does not like wordpress and he wants to charge me for extra work which I would like to avoid for something as minor as this (but something I would like to fix so I can fix up my page with your plugin.

    Thanks for your help,

    Mike

  4. myatu
    Member
    Posted 2 years ago #

    It looks like the file wasn't processed by PHP. The file extension has to be ".php" though - it should give you a long list of details about your PHP installation.

    It could very well be that the latest version of PHP is installed, but needs to be activated. As you've mentioned, you need to add a line to the .htaccess file, which is quite common amongst webhosts.

    However, if you've already added this line (as you said you did) and the plugin is still reporting an error, there's only two possibilities: the line you added didn't work/is incorrect or there's a bug in Background Manager that incorrectly detects the PHP version. So by looking at what phpinfo() gives, you can determine the actual version of PHP, as reported by PHP itself - if that's 5.3.0+, then I need to fix a bug on my side :)

    If you need any additional help, particularly if the webhost is unwilling to lend a hand, feel free to contact me directly via the contact form.

  5. mikeperazzetti
    Member
    Posted 2 years ago #

    Yes I would definitely appreciate all of the help you can provide given the website host. I am at work now so may not be able to access the files you need to see to determine where we go from here. As soon as i am able i will copy and paste the .htaccess file contents and not the changes I made and where. There is always a good chance I did this wrong and i want to determine that first before going to the next step. Thank you again for all of your help. I really appreciate it.

    Mike

  6. mikeperazzetti
    Member
    Posted 2 years ago #

    The file that I created at your request is a .php file. Unfortunately, that is the only information it yielded.

    Here is the contents of the .htaccess file. The portions I added are in bold. Other than that, the contents of the file are the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # Use PHP 5.3
    AddType application/x-httpd-php53 .php

    # END WordPress

    Please let me know what next steps are. I am hoping that the solution to this is something very elementary and simple. Looking forward to your assessment.

    Mike

  7. myatu
    Member
    Posted 2 years ago #

    Hi, sorry for not replying sooner - couldn't login to WordPress.org.

    Not sure which webhosting company you are using, but each one uses a different method to activate PHP 5.3.0+.

    For example, 1&1 Webhosting it's AddType x-mapp-php6 .php, OVH it's SetEnv PHP_VER 5_3 and Bluehost it's AddHandler application/x-httpd-php53 .php -- very varying.

    If the version hasn't changed, it could be the difference between AddType and AddHandler for example.

  8. mikeperazzetti
    Member
    Posted 2 years ago #

    I understand. It was rather busy today for me as well and I have not had a chance to respond until now. I requested this information from my host provider and he provided me with a link to look and see what version I have, http://www.radiocasbah.com/phpinfo.php which gave me this

    The requested URL /phpinfo.php was not found on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    He wrote me back and let me know that he would look into it and let me know what's wrong.

    At this point, I believe it still may be an issue at the site end, not yours.

    I will keep you posted as soon as I hear something. He also mentioned that my .htaccess file is fine and configured fine.

    Thanks for all the help. I appreciate it,

    Mike

  9. mikeperazzetti
    Member
    Posted 2 years ago #

    Myatu,

    It's working now and thank you for all of your help. Now I am not exactly sure how to operate the plugin. I would like only one photo in the background (no rotating gallery at this point) which I have on my desktop (I am not sure how to upload it), and I would like a plain white foreground for the articles that I write. Is there an easy way to accomplish that?

    My site is here: mikeperazzetti.com

  10. myatu
    Member
    Posted 2 years ago #

    I'm glad you got it working!

    You start by accessing the WordPress Administration and select Appearance -> Background. This will bring you to Background Manager.

    Next to the title, you have a Add New Image Set link, which will allow you to create an image set for your photo. Give it a title, then - similar to adding an image to posts - click on the grey icon next to Upload/Insert (underneith the title).

    This will give you a window with various options of adding an image, and you will likely want to use the first page to upload your photo. You can use the WordPress drag & drop feature, or click the Select Files to browse for the photo.

    Optionally give the Image Set a short description in the box at the top right, and click Add Image Set.

    Next time, this Image Set will be listed under the currently highlighted Image Sets (in the menu under the Background Manager title), which will allow you to modify it in future. Click on Settings to return to the main page for Background Manager.

    On the Settings page/menu, select your Image Set you just created as the Background Image Set, make any additional modifications you'd like (ie., only have it appear on the Front Page under Active On, display the image in Full Screen or Normal modes) and click Save Changes.

    Hope this helps to get you started. Let me know if you need additional help :)

  11. mikeperazzetti
    Member
    Posted 2 years ago #

    Excellent so far if you would like to see. I like the way it works, but I need a blank white space in the middle for the articles and I am not sure how to make that happen similar to your demo pages.

    At the moment, the image covers the entire screen (at full screen not normal. Normal gave me no background image at all.), and it gives me no blank white space in the middle in which to post articles. The posts and pages are barely visible now with that background image.

    I know there must be a very simple solution. I just don't know what it is. Can you help?

    Mike

  12. myatu
    Member
    Posted 2 years ago #

    Hi, I just had a quick look. It has to do with your theme, but can easily be fixed with Background Manager without editing the theme itself.

    Edit the Image Set you have just created, and underneath the large box you will see a box for Custom Stylesheet. Add the following bit in that field:

    .act .in {
        background-color: #fff;
    }

    This will give you a white background for your articles.

    I have noticed that the article title is pushed against the top-left corner as well, so if you wish to give it some padding, you can add the following bit to the above (after the closing } sign):

    #main-body {
        margin: 0;
        padding: 15px;
    }
  13. mikeperazzetti
    Member
    Posted 2 years ago #

    Thank you. I appreciate that. I am trying to find this large box you are speaking of and I cannot seem to find it anywhere.

  14. myatu
    Member
    Posted 2 years ago #

    It's from the WordPress administration area, Appearance -> Background.

    Then click Image Sets from the menu displayed under the title.

    Click on the title of the Image Set to start editing it. You have the title, the large box containing the photo you've uploaded and underneath that is the Custom Stylesheet box where you enter those details from the earlier post.

    If this box is not showing, in the upper-right corner you have two tabs: Screen Options and Help. Click the Screen Options tab, and select/tick the box for Custom Stylesheet. The box should now appear on your screen.

  15. mikeperazzetti
    Member
    Posted 2 years ago #

    That did the white background perfectly, thank you.

    But I did not expect the Blog title to become white and transparent as well. Is there a way to fix that?

  16. mikeperazzetti
    Member
    Posted 2 years ago #

    And it added white background behind the transparent blog title above the Home link and search tab.

    That wasn't there before and I have looked everywhere to see how to revert that back, but I am not certain how to revert it back to what it was. If you can help, I would greatly appreciate it.

    Thanks

  17. myatu
    Member
    Posted 2 years ago #

    That was my error, sorry. Change this:

    .act .in {
        background-color: #fff;
    }

    to:

    #main.act .in {
        background-color: #fff;
    }
  18. mikeperazzetti
    Member
    Posted 2 years ago #

    Wonderful! Thank you for everything.

    I should have content up there in days or weeks if you are curious. It's going to be a sociology blog in preparation for admission to grad school.

  19. myatu
    Member
    Posted 2 years ago #

    Good stuff, glad it's all working now :) And good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic