WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
[resolved] Background Manager Links not Working (32 posts)

  1. velouk
    Member
    Posted 1 year ago #

    I have been through the pages here and seen that many have the same problem as I do but not yet found a solution that works with my website.

    I am able to add a background image with no plugin by using this custom code into the themes Custom CSS box:

    {
    background: url(http://www.velouk.net/wp-content/uploads/2013/02/2013_VeloUK_BackgroundImageR_05.gif) no-repeat top center; #000;
    }

    But what I need is the link for the background to work.

    The website is: http://www.velouk.net/

    The Background Manager plugin is great and I have managed to see a lot of the functions working but the key feature, that of a clickable background does not.

    Have tried adding a normal url such as https://twitter.com/AussieLarry to the

    Clickable Backgrounds is ticked in Settings.
    The Background Image Link box has had the URL added in the settings for a 'set'.

    The site theme is Bold News by Woo Themes.

    http://wordpress.org/extend/plugins/background-manager/

  2. velouk
    Member
    Posted 1 year ago #

    PS. the host is using PHP 5.3.21 which I understand is fine for this plugin.

    Larry Hickmott

  3. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi!

    The common issue is that there is an "invisible" HTML element that covers the entire screen - you can see through it, but user actions that happen behind it, such as a background click, cannot occur. And this is also happening in your case.

    This is usually resolved with margins. You should be able to solve it by adding the following code to the Image Set's "Custom Stylesheet" box:

    #wrapper {
      width: 940px;
      margin-left: auto;
      margin-right: auto;
    }

    Hope this helps

  4. velouk
    Member
    Posted 1 year ago #

    Thank you from the bottom of my heart!!!

    One issue (minor!) is in one browser, Chrome, it tried to open as a 'popup' and failed as those are blocked on my browser. I changed the setting and it now opens a new window. Any solution to that as many users will have popups blocked?

    Will now explore and make a donation for what is an excellent plugin.

    Larry

  5. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    I will have a look into this, as this may have to do how BGM opens the link for the user. Was the link to a third party website, or within your own website/domain?

  6. velouk
    Member
    Posted 1 year ago #

    The link was to an external website, my twitter page. As I said, minor but could be a problem for those blocking pop ups with Crhrome. What a mine field with different browsers, themes and so much more.

    Good luck and thanks.
    Larry

  7. Ajoyshop
    Member
    Posted 1 year ago #

    Trying to make my background clickable. Tried the wrapper code in the custom stylesheet area but still no luck:

    #wrapper {
    width: 940px;
    margin-left: auto;
    margin-right: auto;
    }

    Here's the website I'm testing it on:

    http://www.bagogames.net/wii-u/

    The Production site is:

    http://www.bagogames.com

  8. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Ajoyshop!

    The code you've used depends on the theme used, and cannot be universally applied.

    In your case, there's a DIV element with ID omc-transparent-layer that appears to be interfering. Additionally, you are using a fluid theme, so this may need some extra code. Try the following:

    @media only screen and (min-width:1024px) {
      #omc-transparent-layer {
        width: 990px;
        margin-left: auto;
        margin-right: auto;
      }
    }
    
    @media only screen and (min-width:768px) {
      #omc-transparent-layer {
        width: 720px;
        margin-left: auto;
        margin-right: auto;
      }
    }

    You have additional width settings, but based on the above, you should be able to apply this to them as well.

  9. Ajoyshop
    Member
    Posted 1 year ago #

    The Background is clickable now but it made it all funky. The site overlays the right side of the picture and the clickable area carries over on to the content. Any suggestions? Maybe the widths are off.

    http://www.bagogames.net/wii-u/

  10. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    The order is incorrect, sorry. I would just leave the portion between @media only screen and (min-width:768px) { ... } out for now.

  11. Ajoyshop
    Member
    Posted 1 year ago #

    It seems to be working now. Thanks! What was the other part of the code for?

  12. Ajoyshop
    Member
    Posted 1 year ago #

    I put it up on my production site and now it's not working. Not sure what I'm missing.

    http://www.bagogames.com/

  13. Ajoyshop
    Member
    Posted 1 year ago #

    Nevermind. Got it! Forget to change the image set!

  14. giovannidjojowardi@gmail.com
    Member
    Posted 1 year ago #

    Hi Myatu!

    Small intruction, Dutch user of you plugin for my affilate/magazine-like blog.

    Can't seem to get the links working. Tried the following:

    - All the codes of the above
    - Changing the px of the codes to either very wide or very narrow (2500 px and 100 px), did nothing for me really.
    - Deactivating the plugin and activating again
    - Removing my background before activating the plugin
    - Made the url http://google.com/
    - Cried
    - Removed background glare and wrapper in theme css

    Nothing worked, tried everything I'm capable off.
    Hope you can help me out.

    The link is http://www.heromen.net

    Thanks in advance!

    Gio

  15. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Goedemiddag!

    The Custom Stylesheet code that would work for your website is:

    #art-main {
      width: 1000px !important;
      max-width: 1000px !important;
      margin-left: auto;
      margin-right: auto;
    }

    You may also need to add the following, if you notice that it only works at the top of the page, but not at the bottom:

    body {
      height: auto;
    }
  16. giovannidjojowardi@gmail.com
    Member
    Posted 1 year ago #

    Worked!!

    You're my hero/jedi/ ninja!

    Liked the dutch opening by the way, altough you probably wouldn't if you knew how it actually sounds haha

    Anyway thanks again.

    If i could be any help to you somehow -> gio@greymedia.nl

    Cheers!

    Gio

  17. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi!

    I'm glad it worked!

    And I do know how it sounds: Geboren en getogen in Nederland ;)

  18. telesemana
    Member
    Posted 10 months ago #

    Hi Myatu,

    I have been trying to figure out the code for my site given the examples above and looking at the code of those pages, but nothing works on mine either. Can you check it?

    http://lalinternaverde.com/archives/category/analisis

    Thanks,

    Rafa

  19. techcityng
    Member
    Posted 9 months ago #

    Hi Myatu,
    I use this plugin on my site: http://www.techcityng.com the background image is not clickable. and i have made all the necessary settings. please i will appreciate if you can help with this.

    Thanks
    TechCityNG

  20. myatu
    Member
    Plugin Author

    Posted 9 months ago #

    @techcityng

    You may need the following as a Custom Stylesheet for the active Image Set:

    #outer-wrap {
      max-width: 1170px;
      margin: 0 auto;
    }

    Also, at the moment there does not appear to be a Background Link associated with the image(s) in the Image Set.

  21. jdewees1133
    Member
    Posted 9 months ago #

    GREAT PLUGIN

    I am not able to get the "link" part of this working

    Phillylacrosse.com

    Thanks!

  22. myatu
    Member
    Plugin Author

    Posted 9 months ago #

    @jdewees1133

    There does not appear to be a background link associated with the image.

    - Go to the Background Manager (WP Admin -> Appearance -> Background)
    - click "Image Sets" menu for Background Manager
    - click on the active image set (or select the "Edit" link for it)
    - When you click on an image, in the upper-left corner you will find an edit icon (looks like a piece of paper/notepad with a pencil), click on it
    - On the "Edit Image" window that appears, near the bottom of it you will find a "Background URL" - enter the full URL, ie., "http://wordpress.org" here for that image. You will have to do this for any image that needs to be click-able.

    If you still experience trouble with it after setting the background URL, let me know and I will have another look at the website.

  23. zvornikdanas
    Member
    Posted 9 months ago #

    Hi,
    I use this plugin on my site: http://www.zvornikdanas.com/
    the background image is not clickable. and i have made all the necessary settings.

  24. myatu
    Member
    Plugin Author

    Posted 9 months ago #

    @zvornikdanas,

    The site contains some JavaScript errors that will need to be corrected. For example, in http://www.zvornikdanas.com/wp-content/themes/tribune/js/tooltip.js: Uncaught TypeError: Cannot read property 'msie' of undefined

  25. lododicesimo
    Member
    Posted 8 months ago #

    @myatu

    my backgorund link doesent work aswell.
    the website is http://www.oliservices.it

    how can i fix it?
    thanks

  26. myatu
    Member
    Plugin Author

    Posted 8 months ago #

    @lododicesimo - You will need to follow the same instructions as given to @jdewees1133 (you haven't set a background link for the image)

  27. lododicesimo
    Member
    Posted 8 months ago #

    fantastic.

    thnaks!!!!!

  28. UrbanDol
    Member
    Posted 6 months ago #

    I have the same problem on my website, the link appears for a sec and then it's gone when the whole site loads --> http://www.avtonasveti.com/ could you please check and see what's wrong?
    Many thanks!

  29. danhalenmhk
    Member
    Posted 6 months ago #

    I am also having an issue with the background links if you get a minute or two to take a look at it!

    http://www.purerock.com/k-rock-hunting-page/

    Love the plugin so far, and it will be perfect once I can link the background to another site!

  30. nhouser77
    Member
    Posted 6 months ago #

    I've added the background banner and it look great. I am also running into the issue with the link. Could you please investigate and let me know if there is something I can tweak in the css to allow the link to work.

    I currently am testing the plugin out on a dev site at http://delta.wosu.org/2012/.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic