WordPress.org

Ready to get started?Download WordPress

Forums

background image not working, 2nd eye please (6 posts)

  1. smokinJ
    Member
    Posted 4 years ago #

    here is the code for the sidebar in one of the themes. I am trying to insert an image in the cell but no matter what i do it wont show up. What do you see is wrong here? i tried background-image: and background: already, then i thought i would try img src. please help

      <p align="center"><span class="sb-box"></span></p>

    here is the whole code if that helps
    <form method="get" action="<?php bloginfo('url'); ?>/" class="searchbar">
    <p>
    <input type="text" class="txt" value="<?php the_search_query(); ?>" name="s"/>
    <input type="submit" name="submit" value="Search" class="btn"/>
    </p>
    </form>
    <div class="clr"></div>

    <?php /* Widgetized sidebar, if you have the plugin installed. */
    if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar(1) ) : ?>
    <div class="sb-box">
    <h2></h2>

      <p align="center"><span class="sb-box"></span></p>

      </div>

      <?php endif; ?>

    • smokinJ
      Member
      Posted 4 years ago #

      <ul><p align="center"><span class="sb-box"><a img src="http://www.emlynch.com/wordpress/wp-content/uploads/2009/10/brand.gif"; no-repeat;></a></span></p></ul>

    • smokinJ
      Member
      Posted 4 years ago #

      I forgot to put the code in backsticks, here is the whole code:

      <form method="get" action="<?php bloginfo('url'); ?>/" class="searchbar">
                          <p>
                          <input type="text" class="txt" value="<?php the_search_query(); ?>" name="s"/>
                          <input type="submit" name="submit" value="Search" class="btn"/>
                          </p>
              </form>
              <div class="clr"></div>
      
      			<?php 	/* Widgetized sidebar, if you have the plugin installed. */
      					if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar(1) ) : ?>
                      <div class="sb-box">
                          <h2></h2>
      				<ul><p align="center"><span class="sb-box"><a href="http://www.bbb.org/central-northern-western-arizona/business-reviews/marketing-consultants/em-lynch-marketing-assoc-in-scottsdale-az-1000003757/" target="_blank">Click Here to View Report</a> </span></p></ul>
      <ul><p align="center"><span class="sb-box"><a img src="http://www.emlynch.com/wordpress/wp-content/uploads/2009/10/brand.gif"; no-repeat;></a></span></p></ul>
      
       <ul></ul>
      
                      </div>
      
      			<?php endif; ?>
    • mtw28
      Member
      Posted 4 years ago #

      Try changing this

      <a img src="http://www.emlynch.com/wordpress/wp-content/uploads/2009/10/brand.gif"; no-repeat;></a>

      to

      <img src="http://www.emlynch.com/wordpress/wp-content/uploads/2009/10/brand.gif/"/>

      You were mixing up html and css styling a bit, so it wouldn't render right. ("a" tags are links). Learn more about img tags here.

    • smokinJ
      Member
      Posted 4 years ago #

      <ul><img src="http://www.emlynch.com/wordpress/wp-content/uploads/2009/10/brand.gif/"/></ul>

      so i changed the code to the correct code but for some reason the pic is still not showing up

      check out emlynch.com, there should be an image that pops up under the search bar on the right side of the page

    • mtw28
      Member
      Posted 4 years ago #

      Sorry, my bad, an extra / slipped in the filename. This is corrected:

      <img src="http://www.emlynch.com/wordpress/wp-content/uploads/2009/10/brand.gif"/>

    Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags