WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Background image not appearing in div except on home page (5 posts)

  1. Nik_10
    Member
    Posted 1 year ago #

    Hello,
    I set my div.header-container to have a background image. The only place this image is appearing in my theme is on the home page. When I use firebug it shows that the same div is being used on every page so I can't figure out why it isn't on all the others.

    ALSO, When I go to the home page or hit the home button, the blog menu item is also showing like its's been clicked at the same time. None of my other menu buttons are doing that, and I can't figure it out.

    Any help would be really appreciated!

    http://www.simplifiedinteriors.com

    Thanks!

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    I can see the background image on different pages.
    Have you tried clearing your cache?
    Which browser and browser version are you using?

  3. Nik_10
    Member
    Posted 1 year ago #

    Hi Andrew! Yes I figured it out... it was an issue with my permalinks. Seems to be working fine now, thank you for your response!

    Still not sure why my Feng Shui Fridays menu item also appears with the hover color when I just go to the home button. It doens't do it with any other pages, only when I am at the index.

    Do you have any ideas?

    Thanks!

  4. Maneetpuri
    Member
    Posted 1 year ago #

    hmm..What I guess by looking at the CSS of your page is that you may have declared the ‘Home’ page as the parent and the ‘Feng Shui Friday Blog’ page as the child, which is why the latter is inheriting the former.

  5. Nik_10
    Member
    Posted 1 year ago #

    With this theme the home page was a custom link. The blog page is a page menu item. Can that page be a child of a custom link?

Topic Closed

This topic has been closed to new replies.

About this Topic