WordPress.org

Ready to get started?Download WordPress

Forums

Background image issue using Twentyten Child-theme (4 posts)

  1. jpoc
    Member
    Posted 1 year ago #

    I am experiencing a problem with my Twenty Ten Child theme when using a background image.

    My CSS knowledge basically consists of copy-pasting stuff I find on these support forums onto my site. I put this code into my child theme style.css, to show a background image in the theme:

    body {background: url(images/headerbg2.png) repeat-x;}

    It works in Firefox:

    https://dl.dropbox.com/u/51767121/Problem%20with%20bg%20image/Untitled-2.png

    But not in Chrome, where sometimes the background image is cut off:

    https://dl.dropbox.com/u/51767121/Problem%20with%20bg%20image/Untitled-1.png

    The image is 1px x 180px and repeats full width in the body of the page. But something seems to be cutting it off in Chrome. Sometimes it works as it should in Chrome, but if you refresh the page it will display incorrectly again.

    I designed the theme in Photoshop and thought that translating it into Twentyten would be simple, but may have to give up at this rate.

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Is your website valid?

  3. jpoc
    Member
    Posted 1 year ago #

    Hadn't checked this. I copied and pasted the output HTML into that site and it came up with an error, so will work on fixing that I guess. I'm working on it locally at the moment so I can't provide links unfortunately.

  4. jpoc
    Member
    Posted 1 year ago #

    From http://validator.w3.org:

    Validation Output: 2 Errors

    Line 96, Column 185: Bad value category for attribute rel on element a: Not an absolute IRI. The string category is not a registered keyword or absolute URL.
    …="View all posts in Uncategorized" rel="category">Uncategorized </span>
    Syntax of link type valid for and <area>:
    A whitespace-separated list of link types listed as allowed on
    and <area> in the HTML specification or listed as an allowed on and <area> on the Microformats wiki without duplicate keywords in the list. You can register link types on the Microformats wiki yourself.
    Syntax of absolute IRI:
    An absolute URL. For example:
    http://example.org/hello, but not /hello. Spaces should be escaped as %20.

    Line 133, Column 102: Bad value generator for attribute rel on element a: Not an absolute IRI. The string generator is not a registered keyword or absolute URL.
    …emantic Personal Publishing Platform" rel="generator">Powered by WordPress.
    Syntax of link type valid for and <area>:
    A whitespace-separated list of link types listed as allowed on
    and <area> in the HTML specification or listed as an allowed on and <area> on the Microformats wiki without duplicate keywords in the list. You can register link types on the Microformats wiki yourself.
    Syntax of absolute IRI:
    An absolute URL. For example:
    http://example.org/hello, but not /hello. Spaces should be escaped as %20.

    Firefox HTML Validator shows 0 errors and 7 warnings:

    Result: 0 errors / 7 warnings
    line 6 column 1 - Warning: <meta> proprietary attribute "charset"
    line 6 column 1 - Warning: <meta> lacks "content" attribute
    line 44 column 4 - Warning: <div> proprietary attribute "role"
    line 58 column 4 - Warning: <div> proprietary attribute "role"
    line 76 column 4 - Warning: <div> proprietary attribute "role"
    line 103 column 1 - Warning: <div> proprietary attribute "role"
    line 115 column 2 - Warning: <div> proprietary attribute "role"
    Info: Document content looks like HTML Proprietary

    Could these be causing the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic