WordPress.org

Ready to get started?Download WordPress

Forums

Backend/Styles problems with new localhost WP 3.7.1 MS install into windows/XAMP (2 posts)

  1. DrDevin
    Member
    Posted 9 months ago #

    I am hoping to develop and test my first site - a community website - using multisite on my desktop before uploading to my webhost.
    This has been a tortuous process, having failed miserably with a Bitnami Wampstack installation,and now trying the Xampp route. Now, several weeks later, I am still beating my head against a brick wall trying to get the site operational.
    The problem is that, whilst I can sucessfully build & access the site and create sub-sites as a Super Admin, I can't access the Admin pages for the sub-sites. I can edit the site configurations, and access the subsites, but they remain unstyled and their log-ins do not work.

    I have trawled the support sites, and the codex, and it seems the issues might lie in one or more of either the wp-config, .htaccess, or Apache httpd.conf files. I have tried many suggestions,but none of them have worked.

    My install configuration is: Clean install of WP 3.7.1 in a separate disc partition (K:) into the K:xampp/apps directory with xampp 3.2.1
    pre-installed, Apache/mySQL running and all plugins deactivated. No problems with the install, theme Twenty Thirteen & pretty permalinks working.

    I think that the relevant lines of the key files are:

    my wp-config file:

    define('WP_ALLOW_MULTISITE', true);
    define('DB_NAME', 'bitnami_wordpress');
    define('DB_USER', 'bn_wordpress');
    define('DB_PASSWORD', '');
    define('DB_HOST', 'localhost:3306');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    $table_prefix  = 'wp_';

    .htacces is:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    and the httpd.conf file is:

    ServerRoot "K:/xampp/apache"
    Listen 80
    LoadModule rewrite_module modules/mod_rewrite.so
    ServerName localhost:80
    <Directory />
        AllowOverride Options All
        Require all granted
    </Directory>
    DocumentRoot "K:/xampp/htdocs"
    <Directory "K:/xampp/htdocs">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride FileInfo Options
        Require all granted
    </Directory>
    Include "K:/xampp/apps/wordpress/conf/httpd-prefix.conf"

    I have installed the Apache RewriteRules plugin and this gives the following for the running site:

    Operational mod_rewrite rules:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    Rewrite-Related Settings:
    True: using_permalinks, using_mod_rewrite_permalinks, use_trailing_slashes
    False: using_index_permalinks

    Permalink_structure: /blog/%year%/%monthnum%/%postname%/

    feed_base ->feed; front -> /blog/; root -> ‘’; index-> index.php

    I am now totally out of ideas, with no place to go. My personal configuration is: battered, tortured, bloodied, desperate, despairing, etc, etc.....

    Does anybody have any suggestions?

  2. DrDevin
    Member
    Posted 9 months ago #

    Sorry about duplicate posts - my post went into the wrong forums and I tried to mark them resolved so that I could move them to multisite. I'm new at this, so my mistake.

Reply

You must log in to post.

About this Topic